Ethernet, USB-modem, Ethernet-modem and lotsa problems

Discussion in 'Apple' started by Danny, Jul 23, 2004.

  1. Danny

    Danny Guest

    This will be a pretty extensive post. Sorry, but I think you might want
    all details:

    My bro has a G4 AGP (Sawtooth), 350Mhz and Mac OS10.2.8. We have tried
    to connect to his new DSL provider with a D-Link DSL 300G. The
    connection is OK, since the ISP has pinged, and he gets responses from
    the modem.

    But there's no way in hell to make the machine to connect to the modem.
    In the preferences, everything is configured OK: PPPoE, correct
    username/password. Appletalk has been both on and off. We have tried
    connecting to the modem via a browser and address 198...something.0.1
    (can't recall exact number right now) and an IP of the machine set to
    198.....0.2. All we get is an error message saying that no PPP server
    could be found.

    Eventually, I thought it might be a hardware problem: Perhaps the
    built-in ethernet card didn't work. So I Installed an external card
    (Asante Fast 10/100 690 something) which I used to have in my old b/w G3
    and which worked just fine when I uninstalled it. We also installed
    latest drivers for OS X.

    No go. The machine didn't even find the new card (mounted in the third
    slot, btw), but it gets power since two of the little green lamps on it
    is shining bright and clear.

    Can someone with more experience than me (or rather: the two of us),
    because I'm about to blow a fuse.

    PS: Before trying with the modem above (which connects to the computer
    via Ethernet), we tried using a USB-modem. But since we never managed to
    make that work and never managed to connect a browser to the modem, we
    took for granted the modem was useless. In hindsight, maybe it wasn't.
    Maybe it's something with the entire network set-up in the machine
    that's corrupted, making it impossible to use both USB and Ethernet?

    ....at least the built in phone modem works....

    Any suggestion is welcome. We're at road's end here....

    TIA
    Danny
     
    Danny, Jul 23, 2004
    #1
    1. Advertisements

  2. Danny

    Danny Guest

    Jones,

    Thanks for the education. Useful. Yes, the ISP want me to use DHCP, no
    problems.

    But you're missing the entire dilemma: I can not make the computer
    connect to the modem whether I'm using PPPoE or DHCP.

    (BTW: The original test - as suggested by the ISP - was to use either
    PPPoE or DHCP to log in to the modem and in turn configure that with
    DHCP to the ISP.)

    Any suggestions?

    Cheers,
    Danny
     
    Danny, Jul 23, 2004
    #2
    1. Advertisements

  3. Danny

    Danny Guest

    If you read, you'd have seen that I first tried a USB modem (because it
    was there), and when that didn't work, I got an ethernet modem.
    Because it was the one my brother had - first.
    No static IP. DHCP is OK.
    But you're unfortunatelly missing the problem: I can not connect to the
    modem, whether using DHCP or PPPoE.

    D
     
    Danny, Jul 23, 2004
    #3
  4. Danny

    Steve Guest

    Are you getting connectivity lights on the computer end, and the DSL modem
    end? IOW, is the ethernet connection showing a green light? You say that the
    ethernet card on the computer is showing green lights, what about the LAN
    light on the modem? If both ends have two green lights, you should be able to
    ping out to the modem, which means that you should be able to connect to the
    modem via a browser window. My guess is that your computer is not set to the
    same ethernet settings as the modem.

    Steve
     
    Steve, Jul 24, 2004
    #4
  5. Danny

    Danny Guest

    Hi Steve,

    Yes, all lights are green.

    I think we have narrowed down the problem to be the modem: It doesn't
    take any signal from the computer. When setting the computer's IP to
    192.168.0.2 while using DHCP and trying to connect via a browser to the
    modem through IP 192.168.0.1 I get an error message saying that the
    connection was refused.

    When trying the same using PPPoE, the browser is trying to connect but
    eventually gives up.

    So, I believe it's the modem and obviously wonder if there are any ways
    to fix it, i.e. some hidden reset-button or something?

    Danny
     
    Danny, Jul 24, 2004
    #5
  6. Danny

    Steve Guest

    If the modem is set up to provide DHCP, and the computer is set up to receive
    DHCP, you would not want to specify the IP address of the computer as you
    seem to indicate.

    Steve
     
    Steve, Jul 25, 2004
    #6
  7. Danny

    Danny Guest

    Bought a new modem today. Installed in 30 seconds flat. Everything is up
    and running.
    Thanks all for suggestions and help!

    D
     
    Danny, Jul 25, 2004
    #7
  8. Danny

    stan Guest

    You might have a faulty ethernet card, faulty network cable, or
    outdated ethernet card driver. One way to test this very quickly
    is to connect the Mac directly to the DSL modem and see if it works.
    Also, can you "ping localhost" from your Mac?
     
    stan, Jul 25, 2004
    #8
  9. Danny

    Danny Guest

    Thanks for suggestion, Stan.

    However, if you had read my other posts, you would have seen that the
    problem was the modem itself, which is now replaced with a new one and
    everything is honkey-dorey day. ;-)

    Cheers,
    Danny
     
    Danny, Jul 25, 2004
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.