Fasttrak100 Lite Drivers....new ones

Discussion in 'Soyo' started by Grubb, Jul 15, 2004.

  1. Grubb

    Grubb Guest

    Where can I get them? The ones from soyousa.com and soyo.com.tw are
    old and do not work. I have tried every version I can find on the
    net. The fasttrak bios recognizes my 320gig stripe (2 160's), but in
    winXP, depending on which fasttrack driver I install from the floppy,
    it shows 265 - 305. None of them will format a partition, it just
    hangs. It won't install to a pre-formatted partition either.

    thanks!

    Jason
     
    Grubb, Jul 15, 2004
    #1
    1. Advertisements

  2. Grubb

    Jim B. Guest

    (Grubb) wrote in message
    It would help if you gave more information on the system with your question.
    When you updated the drivers did you install a new BIOS for your motherboard?
     
    Jim B., Jul 16, 2004
    #2
    1. Advertisements

  3. Grubb

    Grubb Guest

    XP 1900+ on a k7v dragon+
    BA7 BIOS flashed. This updated the promise fasttrak100 lite
    controller as well. I assumed that is why my previous winXP drivers
    didn't work, but none of them I can find (usually around version
    2.0.B18) will work. The promise bios can see both drives in full
    capacity, and assign a raid0 array for 320g. My format utility that
    came with the drives can then sees a single 320g drive, and can
    partition and format it. If I install winXP to a preformatted
    partition (less than 137g), it just hangs when copying files (at 0 or
    1%). It never sees it as 320g. Anything else be of help?

    thanks,

    Jason
     
    Grubb, Jul 18, 2004
    #3
  4. Grubb

    Grubb Guest

    XP 1900+, K7V Dragon+
    Bios version BA7
    Promise bios recognizes both drives and makes a raid0 320g drive.
     
    Grubb, Jul 18, 2004
    #4
  5. Grubb

    Jim B. Guest

    Yes that is why your previous WinXP driver didn't work. Now if the RAID-0
    array is reconized by the controller and you have the new driver on a floppy
    disk for use during the setup of WinXP why haven't you just used the
    partitioning and formatting functions that come with WinXP's setup program.

    One of the possible problems your having could be that WinXP likes drives
    larger then 20gig to be formatted using NTFS and most likely your formatting
    utility that came with the drives formats in FAT-32.
     
    Jim B., Jul 19, 2004
    #5
  6. Grubb

    Grubb Guest

    I of course am using NTFS ;)

    I don't have "the new driver", that is what I'm asking for. I've
    tried letting WinXP create the partition, format it, and every
    combination I can think of. I'm just assuming since on the winxp
    partition screen in setup it sees the drive size wrong, that is why it
    cannot write to it. If I do a quick format, it hangs at 20%. If I do
    a full format, it hangs at 100%. It will create a partition fine, but
    like I said, doesn't see the full capacity of the drive.

    How do I know what the current winXP fasttrak drivers are?

    thanks,

    Jason
     
    Grubb, Jul 19, 2004
    #6
  7. Grubb

    Jim B. Guest

    You do have a problem, since Soyo fails to provide a new driver for the
    updated BIOS version for the Promise controller.

    The latest FastTrak 100 windows driver from Promise supports drives larger
    then 137gig but there site says it requires BIOS version 2.00.0.25 and the
    latest BIOS version that came with the K7VDragon Plus is only version
    2.0.00.23. I would try the driver from Promise with it and if that one
    doesn't work you can contact Promise support to see if they have any ideas.

    When you contact Promise support tell them which BIOS version for the
    controller the Soyo motherboard BIOS update provided you (version 2.0.00.23)
    if they have no help for you the next suggestion would be to buy a PCI RAID
    controller and shut down the one on the motherboard. Sounds drastic but if
    you want large capacity use with a RAID array it would seem the way to go.
    Your not going to see anymore support for this board from Soyo its just to
    out of date for them.

    Here is the link to Promise Technology, Inc. in case you don't already have
    it.

    http://www.promise.com/
     
    Jim B., Jul 19, 2004
    #7
  8. Grubb

    Grubb Guest

    You're right. And here is their response:

    I found the link to the driver that SOYO provided and you are right; it
    doesn't support the larger drives. Unfortunately it would require a BIOS and
    driver to both be 48bit supporting. In the case of a built-in chip the MB
    BIOS is the only update and this one falls short on 48bit support. There is
    no way to update the chip BIOS separately. (Changing to a separate card that
    has 48bit support would require a total reinstall of any content that was on
    the original array because the RAID engines are too different.)
     
    Grubb, Jul 22, 2004
    #8
  9. Grubb

    D Larsen Guest

    Grubb,

    There are hacked versions of the Soyo/Promise BIOS...apparently, the
    Promise chip used on the Dragon + is only crippled (the "Lite" version)
    by the BIOS installed....a full version can be installed by using the
    hacked BIOS and drivers. This gives you more control over stripe size,
    etc. If you are unsure what you're doing, or you don't have a "BIOS
    Saviour" then forget about it <g> !

    If you DO know what you're doing, then maybe check out the BIOS and
    drivers at this web site :

    http://lumberjacker.kettenfett.com/

    I can't vouch for any of these BIOSes having the .25 Promise BIOS or
    supporting >137 gig, but I'm running a modified Soyo BIOS (2BA8) with
    the Promise .24 BIOS embedded....I don't have drives exceeding the 137
    gig limit (2 20 gig WD drives in RAID). I haven't had any problems so
    far <g> !

    Note that you MUST use the software drivers from this page, as well.
    Also, you can't just update the BIOS and have your "old" RAID
    configuration work correctly. I used Drive Image to reinstall my system
    on the new RAID array, set up using the new BIOS.

    Good luck if you go this route....let us know if things work out ! I
    might want to bust the 137 gig limit someday, too <g> !

    Dean...
     
    D Larsen, Jul 22, 2004
    #9
  10. Grubb

    Grubb Guest

    BIOS flash worked fine, upgraded to .24. I'm not positive which
    driver to use from that page, but the only one that even saw a drive
    was the lite/speed driver, and it had the same problem as before. I
    guess I'll just pick up a PCI card (was trying to avoid as I'll have
    to pull something out to put it in. Oh yeah, as far as software goes,
    I'm starting fresh. Had a RAID0 with the infamous IBM drives that had
    the premature failure problem...both died in < 2 years (went to a
    single drive setup when the first went)

    VV
     
    Grubb, Jul 26, 2004
    #10
  11. Grubb

    uffe Guest

    I also have a Soyo k7v dragon+ motherboard and 2x80GB (which gives
    more than 137GB) and would like to flash my bios, but the page which
    contains the bios file is under construction. If someone has the
    driver or an alternative link, would you mind sending the file or the
    link?
     
    uffe, May 6, 2005
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.