1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Fibre Channel drives with "12V Only" marking

Discussion in 'Sun Hardware' started by DoN. Nichols, Apr 19, 2008.

  1. DoN. Nichols

    DoN. Nichols Guest

    I recently acquired a couple of 146 GB Seagate FC drives marked
    with a "FCV" suffix, and with in large print on the label "12V ONLY".
    (Full designation -- "ST3146807FCV")

    These do not work in my Sun Fire 280R (where I am already using
    two of the same drives except for the 'V' tag on the suffix.

    They also don't work in an external FC housing -- Criiterion/EMC
    -- which works fine with the 36 GB drives which came with it (in use as
    a ZFS array) or with the 9GB drives which came in its companion -- but I
    can't see paying the power costs to run 1.6" 9GB drives these days. :)

    Does anyone know what I would need to run these drives -- or
    what modifications I might need in the drive cage for either the Sun
    Fire 280R or a Sun Blade 1000 (I'm using both here)?

    I don't really expect anyone to know what to do to the
    Criiterion/DMC housing to make it accept such drives -- but if anyone
    does know, that information would be welcome, too.

    DoN. Nichols, Apr 19, 2008
    1. Advertisements

  2. You really need to explain what "these do not work" means.

    The only tidbits I can pass along with what little information you gave is

    1) the 12V only sticker is meaningless.
    2) the V at the end stands for Video which was some attempt from Seagate to
    market drives with 16mb buffers over the 8mb as being "special".

    If the drive seems to power up, you ran devfsadm then ran format and it
    doesn't come up in the list, the drives are shot. Either the firmware is
    blown out or there is a defective onboard controller.

    In either case above, they are only handy for leveling tables or chairs.

    If the problem is after "format", you'll need to explain what is happening.

    Bruce Esquibel, Apr 19, 2008
    1. Advertisements

  3. DoN. Nichols

    DoN. Nichols Guest

    When inserted in either the Sun Fire 280R card cage in a spud,
    or in the EMC 10-slot FC drive bay in the appropriate sled, the drive
    remains invisible to devfsadm and to the "-scanbus" option to cdrecord
    (which is a nice tool to see whether something is on the bus without
    having to drop down to the OPB level and run probe-scsi-all).

    When withdrawn, the drives do not give the typical inertial
    behavior of a spinning drive.

    I'm reluctant to bring the system down to the OBP level and run
    probe-scsi-all, because my wife will be using it (the Sun Fire 280R is
    our file server) even if I will be over at the console looking at the
    results of the probe-scsi-all.
    A search through google found at least one maker of PC boards
    for driving FC drives which offers a special card to go between the
    drive and the fc card to make a "12V Only" drive work when it otherwise
    will not work.
    The drive does not seem to power up at all.
    At $55.00 each, that is a pain. Especially since they are a bit
    too thick for most table or chair leveling tasks that I have
    encountered. :-(
    The problem is long before format.

    DoN. Nichols, Apr 20, 2008
  4. DoN. Nichols

    DoN. Nichols Guest

    [ ... ]
    I'm reluctant to bring that system down to the OBP level, as it
    is our file server, and my wife depends on it even when I am playing
    with another system. :)

    But I did run the "cdrecord -scanbus" and it did not see them,
    though it saw others which were on the same EMC housing. Here is the
    output of that as an example:

    Cdrecord-Clone 2.01 (sparc-sun-solaris2.10) Copyright (C) 1995-2004 Jörg Schilling
    Warning: Using USCSI interface.
    Warning: Volume management is running, medialess managed drives are invisible.
    Using libscg version 'schily-0.8'.
    0,0,0 0) *
    0,1,0 1) *
    0,2,0 2) *
    0,3,0 3) *
    0,4,0 4) *
    0,5,0 5) *
    0,6,0 6) 'TOSHIBA ' 'DVD-ROM SD-M1401' '1009' Removable CD-ROM
    0,7,0 7) *
    1,0,0 100) 'SEAGATE ' 'ST3146807FC ' 'MS06' Disk
    1,1,0 101) 'SEAGATE ' 'ST3146807FC ' '0006' Disk
    1,2,0 102) *
    1,3,0 103) *
    1,4,0 104) *
    1,5,0 105) *
    1,6,0 106) *
    1,7,0 107) *
    1,10,0 110) 'IBM ' 'DRHL36L CLAR36 ' '3347' Disk
    1,11,0 111) 'IBM ' 'DRHL36L CLAR36 ' '3347' Disk
    1,12,0 112) 'IBM ' 'DRHL36L CLAR36 ' '3347' Disk
    1,13,0 113) 'IBM ' 'DRHL36L CLAR36 ' '3347' Disk
    1,14,0 114) 'IBM ' 'DRHL36L CLAR36 ' '3347' Disk
    1,15,0 115) 'IBM ' 'DRHL36L CLAR36 ' '3347' Disk
    5,0,0 500) 'SEAGATE ' 'ST39173W SUN9.0G' '2815' Disk
    5,1,0 501) *
    5,2,0 502) '' '' '' NON CCS Disk
    5,3,0 503) *
    5,4,0 504) 'SEAGATE ' 'SX336704LC ' 'BC10' Disk
    5,5,0 505) *
    5,6,0 506) *
    5,7,0 507) *
    5,8,0 508) 'SEAGATE ' 'ST318404LSUN18G ' '8590' Disk
    5,9,0 509) 'SEAGATE ' 'ST318203LSUN18G ' '034A' Disk
    5,10,0 510) 'FUJITSU ' 'MAG3182L SUN18G ' '1111' Disk
    5,11,0 511) 'SEAGATE ' 'ST318305LSUN18G ' '0340' Disk
    5,12,0 512) 'SEAGATE ' 'ST318404LSUN18G ' '4207' Disk
    5,13,0 513) 'FUJITSU ' 'MAJ3182M SUN18G ' '0503' Disk

    1,0,0 and 1,1,0 are the internal drives -- plain vanilla "ST3145607FC"s
    as you can see. 1,10,0 through 1,15,0 are a zfs raidz2 array plus two
    hot spares in the EMC housing which does not see the "FCV" drives.
    5,0,0 and 5,4,0 are miscellaneous filesystems, and 5,8,0 through 5,13,0
    are another zfs filesystem and one hot spare -- those (SCA drives) in a
    D1000 hung on a HVD controller.

    I was able to unmount the filesystems on 1,1,0 (and unexport
    them) so I could pull that hot and plug in one of the FCV drives to see
    whether it behaved any differently than the same drives in the EMC
    drive bay. This drive which I pulled to test this one is a ST3145607FC
    (without the 'V'), so I know that those work fine in the same bay.
    They do not -- based on the lack of a gyroscopic feel when I
    pull them.
    And they work fine in the Sun Fire 280R (I'm using two of them),
    and when I bid on the eBay auction I didn't expect the 'V' suffix to
    make a difference. It certainly did. :-(
    I would expect it to see the non-V drives fine, since the same
    system board is used in both the SB-1000 and the Sun Fire 280R in which
    I am using two of the non-V versions of the drives.

    There is a fibre channel multipack? What is the model number so
    I can search for them in eBay. They seem to have come out after my
    Field Engineer's Handbook (2000 -- it covers the SB-1000 but not the
    SB-2000, and not the Sun Fire 280R.)

    DoN. Nichols, Apr 20, 2008

  5. Well, might be time to send the better half out to the movies and check it
    with the OBP but I still think you have a couple door stops.

    Seagate appears to have buried or taken offline the white papers and
    engineering stuff, but when this "12V only" subject came up before there was
    a document they had available for the FC drives which broke down all the
    options and variations in that line (guess its Cheetah, 10k, FC). There
    wasn't a single one made that was 12V only, they all used the split 12v/5v
    for power.

    A while back I ran into the same thing, some ebay specials for 18GB's (which
    were twice as expensive as what you paid for the 146GB, figure the timeline
    out yourself) and they too had that sticker or imprint on the label.

    We contacted the place they came from and they said (we took it with a grain
    of salt) that they got them from a place that built disk cabinets which were
    universal, sort of. They had their own internal non-standard bus and
    supplied the appropiate carrier (spud bracket) to adapt whatever kind of
    drive to it. So with minor changes to the back plane, the same cabinet could
    be used for FC, scsi sca or plain old scsi drives.

    The reason the drives were marked 12V because of this was some OTHER drives
    made by maybe fujitsu or hitachi did in fact use 18 or 24v for the motor/arm
    supply (still 5v for the logic) and those cabinets were not to be used with
    the 12V drives.

    Yes I know, it would make more sense to mark the cabinets "18V drives only"
    but this is what they told us.

    I don't know what you found on google about this adapter but my guess is
    it's along the same lines. I'd say it's more likely there are some host
    adapters out there that used it, not the other way around.

    Anyway, the 18GB drives marked "12V only" worked just fine in a A5200
    cabinet so I'd say they should work in the 280R as well.

    If you don't think the motor is spinning up at all, that really is the kiss
    of death I think. A bad firmware update can cause that but I never found a
    way around it. Probably needs to go into a manufacturing mode using some
    magic cable or secret combination of jumpers.

    Still, I admit I can be wrong about all of this but after taking advantage
    of several "ebay lots" over the past 6 or 7 years, I don't think so.

    Bruce Esquibel, Apr 20, 2008
  6. DoN. Nichols

    DoN. Nichols Guest

    Thanks for both.
    Except with the Sun Fire 280R, which does allow hot swapping --
    as long as you can first umount the filesystems involved.

    Thanks again,
    DoN. Nichols, Apr 21, 2008
  7. DoN. Nichols

    DoN. Nichols Guest

    You know -- I think that it has probably been fifteen to twenty
    years since we last saw a movie. I think that it was "Gremlins". :)
    Yes -- that is precisely what it is. ST3145807FCV
    Interesting -- since the label says (in the finer print to the
    right of the bold-print ST3145807FCV:

    VDC Amps
    +5 -
    +12 1.4

    so at least the label seems to think that it draws nothing from the +5V

    If I had a spare connector pair to match the 40-pin SCA style
    connector, I would try hooking it up and using a clamp-on ammeter to
    verify whether this is truly so.
    Hmm ... sort of useful cabinet, if it it turned out to be
    Interesting. Reminds me of my first personally owned Sun -- a
    2/120. It used a MFM (or was it ESDI) disk with a controller board to
    turn that into SCSI. And -- it used an open-frame QIC style tape drive
    for loading the OS and for backups. Both used the same connector (the
    common +5V/+12V D shaped nylon connector still used on 5.25" and 3.5"
    drives -- but the connector to the disk drive had 24V in place of the
    12V - no such thing as using a different connector to prevent frying
    drives by mixing them up. :)
    What would make even more sense would be to key the connectors
    so you could not plug the 12V drives into the 18V backplane. :)
    Folded URL to the item which I found, FWIW.


    Interesting that this thread is what comes up at the top on the search
    today. :) The search string on Google is:

    How to "12V ONLY" (FC,"Fibre Channel")

    The next hit of interest is:


    But it is pretty useless other than to confirm that someone else has
    some "12V ONLY" drives -- and fairly recently -- 18 March 2008. :)
    Well ... both don't work in the EMC/Criiterion cabinet, and the
    only one which I tested directly in the 280R also did not work. I guess
    that it is time to upset my wife and bring the system fully down and
    test both drives at once.

    The EMC cabinet is old enough so it only supports the 1 GHz
    Fibre Channel, but the drives are supposed to be able to switch, and the
    internal card cage should handle it as well.

    A pity that the 280R won't accept the 1.6" high drives that the
    SB-[12]000 will.
    Since these were two of something like 58 drives that the vendor
    had -- either his source zapped them all, or there is something else

    Given how low the price for the "12 ONLY" fix that the offer, I
    could believe that it could be something as simple as a resistor to draw
    current from the 5V line to convince the port switching that there was a
    drive there to talk to.
    Most of them work out -- but not all. A pity that I don't have
    a single drive chassis for FC so I could power up the drive and feel for
    gyroscopic effects while measuring current drain.

    I presume that contacting Seagate won't do much good? :)

    Thanks much,
    DoN. Nichols, Apr 21, 2008

  8. Well, if that is what is on the label, that is what it must be and I'm

    Only suggestion at this point is download and examine this...


    I don't know how you get to those anymore from seagates site but I found the
    old "product manual" when we ran into this, adjusted things accordingly and
    googled enough to track down the specific one.

    It has everything you want to more about the drive than you probably care to
    know, including the connector pinout, misc jumpers and general theory of

    Again, it makes no mention of a 12V only option and the half dozen pages
    explaining the power requirements are always showing a 12/5 source. Even has
    graphs showing current measurements of both feed lines as the drive is going
    through various stages of operations.

    Best of luck finding a solution but I'm still betting on it being defective

    Bruce Esquibel, Apr 21, 2008
  9. DoN. Nichols

    ChrisQuayle Guest

    Have had a few issues with fc drives, using a couple of the older emc
    10 drive boxes with s/h none sun seagate 10k drives. Each box of 10 is
    configured under solaris 8 / disksuite as a single raid array, with the
    second box powered up only for rsync between the first and second.
    Controller is a dual channel sun (FC100 iirc) sbus card, host is Ultra
    II. The good thing about the emc boxes is the lower power consumption
    compared with stuff like a5100, which draws 600 or so watts with 12
    drives fitted.

    Part of the problem may be due to the fact that the whole setup is
    unsupported and a real dog's dinner, but one thing for sure is that none
    of the drives were recognised without a boot -r, when the boot process
    probes for all peripherals it can find. After that, it's just a case of
    using format to partition, format and bad block scan the drives.
    Overall, nice cheap storage, but f/c drives don't seem as
    straightforward as scsi...

    ChrisQuayle, Apr 21, 2008
  10. DoN. Nichols

    DoN. Nichols Guest

    [ ... ]
    Thanks! It is printing as I type.
    Well ... I did kick my wife off the server for a little while
    today and replaced both 146 GB drives in the hot-swap housing with
    these, and probe-scsi did show them.

    So -- back to the normal pair of drives and reboot, then copy
    everything off the second drive to a zfs pool (four filesystems) and
    re-export them from there -- and change the client mount information so
    I could do without that second drive for a while.

    Now it sees it (after the usual "devfsadm -C -c disk" (we seem
    to need the "-C" to clean up the old WWN linkages in the /devices tree),
    and I am currently formatting it. 30000 tracks into the first verify

    Once that is done, I will try again to get it recognized in the
    EMC housing. It would be nicer if I could trust it to mount there as
    well as in the internal cage.

    Thanks much,
    DoN. Nichols, Apr 22, 2008
  11. DoN. Nichols

    DoN. Nichols Guest

    O.K. I've managed to get the drives in question working in the
    internal drive cage in the SF 280R, and after I finish the full format
    of the first of them, I'll see whether it moves to the EMC housing this
    time -- though it did not before. I'll also test the non "12V ONLY"
    drive of the same size in there and see what it does.

    Do you happen to know whether the EMC box needs the loopback
    "terminator" on the "out" connector? I've got one (home-made) there and
    it is working fine with the original drives at least. I'm reluctant to
    pull the terminator because that also potentially shuts down my internal
    drives thus shutting the whole system down. :)
    Hmm ... for me, with the original drives (seven 36 GB FC drives)
    all I needed to do was "devfsadm -c disk" to get it to see the "new"
    drives in the array. When I went to test the ten 9 GB FC drives out of
    the second box, three at a time, I had to use "devfsadm -C -c disk" to
    clear the old drives out of the /devices/ tree.
    Perhaps in part because of the unique "WWN" (World Wide Number)
    in each drive -- which gets encoded into the /devices tree. Here is an
    example from the first drive in my system:

    /devices/[email protected],600000/SUNW,[email protected]/[email protected],0/[email protected],0:a

    The part between the '@w' and the ",0:a" at the end is the WWN, and I
    think that having multiple ones tied to the same drive path could
    confuse the system. The "-C" option to devfsadm tells it to clear any
    unused ones. I use the "-d disk" option simply to avoid the risk that
    it could confuse the sgen entry for the tape jukebox, and the entries
    for the tape drives.

    DoN. Nichols, Apr 22, 2008
  12. DoN. Nichols

    DoN. Nichols Guest

    [ ... ]
    The plain vanilla drive does not work in the EMC housing either.
    I suspect that the EMC is 1 GHz only in the FC, and is not setting the
    pins to tell the drive to back down to 1 GHz from 2 GHz. I've only used
    the EMC housing with the 36 GB and 9 GB drives which came in the

    Thanks all,
    DoN. Nichols, Apr 23, 2008
  13. DoN. Nichols

    ChrisQuayle Guest


    Thanks for the tip about replacing the drives hot. It probably is the
    WWN number change that's confusing the system - just never figured out
    which utils to use to fix it. More frequent rtfm I guess :). One thing
    to watch with the emc stuff is that some of the drives are formatted for
    a non standard sector size - iirc 578 bytes rather than 512. If you
    download the fc utils from the seagate web site, and use an Emulex
    lp8000 or similar pci card in a pc running the seagate utils, there is
    an option to change the sector size. Have never tried this, as all my
    drives were already at 512 bytes, but the utility will tell you what the
    sector sizes are and iirc, bad block the drives at low level, prior to
    sun format.

    As for the terminator, don't konw, but not using one here. The sun sbus
    controller has removable transceivers. One array has a 9 pin D
    transceiver, while the other uses fibre and a fibre to 9 pin mia adapter
    at the array end. Both seem to work flawlessly. The drives are a mix of
    early f/h st173404fc and the same type but later h/h drives, iirc

    ChrisQuayle, Apr 23, 2008
  14. DoN. Nichols

    DoN. Nichols Guest

    [ ... ]
    In Solaris 10, at least, use:

    devfsadm -C -c disk

    If you don't have weird tape drives and jukebox on the SCSI or FC bus,
    you don't need the "-c disk" (limit the work to class "disk"). The "-C"
    says to clean up links and /devices entries which are no longer in use.
    I think that those were ones on a SGI system. :)
    That first requires me to get the lp8000 or similar, and move the
    token Windows machine out to where it can access the array. :)
    Hmm ... another possibility would be to use "sformat" from
    schily -- the same fellow who wrote the "cdrecord" program which is
    supplied with Solaris 10 in the "Software Companion" DVD-ROM. But
    you'll have to find and download the source for that one yourself. And,
    you'll have to download and compile the source for his "smake" first.
    He has his own version of make, and writes his other sources to expect

    So -- that makes "make", "gmake" and "smake" so far, but at
    least gmake is in the /usr/sfw/bin directory, so it is already installed
    with Solaris 10 anyway -- even if you skip the Software Companion stuff.
    That means that it is self terminating. That is good to hear
    about. I didn't need to make my own terminator.
    O.K. I'm using the FC interface which is built into the Sun
    Fire 280R and the Sun Blade [12]000 systems. That uses a special flat
    connector which is like a wider and longer RJ-45 (but black not clear)
    at the back of the computer. To use with the EMC system, I have to have
    a cable to go from that to the DA-9 connector.

    As for the terminator -- it really is just a loopback, and I
    made my own (pin 1 to pin 5, and pin 6 to pin 9) rather than depending
    on the EMC to be self terminating, since otherwise I would interfere
    with access to the two internal drives in the SF-280R, one of which is
    the boot drive and thus a bad thing to lose on a server. :)
    O.K The drives which came with the EMC array which are still in
    use are 36 GB 1.6" high drives marked as:

    Vendor: IBM Product: DRHL36L CLAR36

    from the output from "iostat -E -n". Also, the 9GB drives (also 1.6"
    high) which are labeled ST19171FC by Seagate (though I don't know what
    the IOSTAT will call them).

    Also it works with a ST336605FSUN36G (pulled from the SB-1000
    when I put in one of the 146 GB FCV 12V only drives).

    And 1" high ST39102FC (9GB) drives also work well in the EMC

    The 146 GB drives ST3146807FC or SX3146807FC (Seagate drives
    which have passed a certain number of service hours magically change the
    second character of their identification from 'T' to 'X', and at least
    IBM AIX systems bitch like made about them every time they boot claiming
    that the drive is ready to fail any minute. However Solaris 10 simply
    reports the "SX" in place of the "ST" and still happily used the drive.
    (Yes, both of these "12V ONLY" drives had been run to the "SX" point.
    But I now have one in each of the SB-1000 and the SF-280R.

    I've got a friend and neighbor who has a spare 171 GB 1.6" FC
    drive which I will try in the EMC soon -- just to try to figure out what
    is worth getting from eBay and what I should skip over. The 1.6" drives
    certainly won't work as internal drives in the SF-280R, because it has a
    smaller card cage than the SB-[12]000.

    Anyway -- whatever it is, the problem is somewhere in the EMC,
    since the 146 GB drives work nicely in the SF and SB drive cages.

    Obviously, if I could find an affordable Multipack-FC I could
    grab a full set of the 146 GB ones and be quite happy.

    Thanks and Good Luck,
    DoN. Nichols, Apr 24, 2008
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.