1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Fibre connectivity qla 2342 - brocade - 6120

Discussion in 'Sun Hardware' started by me, Jun 29, 2007.

  1. me

    me Guest

    All,

    I am trying to connect a v480 to a Sun 6120 disk array via a brocade
    switch. If I physical connect the server directly to the controller on
    the 6120 I can see the slices that I've created. However if I put the
    brocade between the server and the array, the server see's no disks.

    The brocade is working and works with other servers, my thinking is that
    it's because of the different fibre topology and that direct its point
    to point and via the switch its a loop.

    When I look at /kernel/drv/qlc.conf I can change the
    hba0-connection-options from 2 to 1 & 0 neither help the situation, 1
    causes a kernel panic and the 0 causes a "FL switch topology is not
    supported" error message at boot but does boot, but cannot see the disks.


    I then loaded the, Solaris SPARC Driver (QLA)5.03, so have tried making
    changes in the /kernel/drv/qla2300.conf but these do not take effect,
    even after a boot -r.

    ## Installing part 1 of 1.
    /kernel/drv/q3ip
    /kernel/drv/q3ip.conf
    /kernel/drv/q3ip_64bit
    /kernel/drv/qla2300
    /kernel/drv/qla2300.conf
    /kernel/drv/qla2300_64bit
    /opt/QLogic_Corporation/drvutil/qla2300/qldriverop
    /opt/QLogic_Corporation/drvutil/qla2300/qldriverop_readme.txt
    [ verifying class <none> ]
    ## Executing postinstall script.
    devfsadm: driver failed to attach: qla2300
    Warning: Driver (qla2300) successfully added to system but failed to
    attach

    boot -r, still no disks seen and I tried the changes in
    /kernel/drv/qla2300.conf as /kernel/drv/qlc.conf with no joy.

    My senario is almost identical to :
    http://unix.derkeiler.com/Mailing-Lists/SunManagers/2005-09/0015.html

    but I'm using Solaris 8 02 04 and a QLogic 2342 dual port 2gb card.

    I've installed
    111097-25 SAN 4.4.x: qlc driver patch
    the latest patch cluster
    SANsurfer CLI 1.7.0 Build 12

    How do I find out if/what the driver is being loaded for the QLogic 2342
    ? I've tried

    bash-3.00# modinfo | grep -i qla
    bash-3.00# modinfo | grep -i qlc
    25 128a0e0 69b50 104 1 qlc (SunFC Qlogic FCA v20050307-1.61)
    bash-3.00#
    why does it not show the QLA2300 driver ?

    If I connect the disk array straight in I can see them no problem, and
    the SAN switch is not the issue as I have tried a HP aswell.


    Any ideas / step by step guides would be appreciated.

    Paul
     
    me, Jun 29, 2007
    #1
    1. Advertisements

  2. me

    Chris Cox Guest

    Post the output of your zone configuration and tell us what ports
    you have the cables plugged into. Usually things like this
    are caused by a zoning issue.
     
    Chris Cox, Jun 29, 2007
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.