Flash drive annoyance

Discussion in 'Dell' started by Bob Pownall, Dec 16, 2005.

  1. Bob Pownall

    Bob Pownall Guest

    On my Dell Inspiron 8500 (Windows XP Pro, SP2), I've recently begun
    experiencing an annoyance.

    When I plug my SanDisk 512Mb flash drive into one of the USB ports on
    the docking adaptor, Windows pops up a window saying:

    The disk or device contains more than one type of content.
    What do you want Windows to do?

    I want it to "Do Nothing", and I've told it this in the past. (It
    appears that my I8500 has "forgotten", as up to about three days ago, it
    "Did Nothing".)

    On other systems where I used the flash drive, this dialog window has a
    "Don't ask me this again" check box, but for some reason the check box
    doesn't appear on my I8500. (I'm almost sure it did in the past, and I
    checked the "Don't ask me again" message.)

    Any ideas? As I said in the subject, this isn't really a problem, but
    it is rather annoying.

    Bob Pownall
     
    Bob Pownall, Dec 16, 2005
    #1
    1. Advertisements

  2. Bob Pownall

    Ted Zieglar Guest

    It's actually quite logical - even if annoying - when you understand that
    every time you plug in a USB or 1394 device, Windows treats it like new
    hardware and tries to configure it. When you unplug the device, Windows has
    no way of knowing if you're ever going to plug it in again.

    Given the relatively recent proliferation of USB and 1394 storage devices,
    perhaps Vista will ship with a way to deal more efficiently with this type
    of hardware.
     
    Ted Zieglar, Dec 16, 2005
    #2
    1. Advertisements

  3. Bob Pownall

    Tom Scales Guest

    Actually, I don't believe that is quite true. If you plug a USB storage
    device in the SAME port, it should NOT cause this problem. Only when you
    put it in a NEW port should this happen. Windows remembers devices that
    have been inserted in that port before.

    Tom
     
    Tom Scales, Dec 16, 2005
    #3
  4. Bob Pownall

    Ted Zieglar Guest

    You know, I've never tried that before. I'll give it a try this weekend.

    My experience with my USB flash drive is that Windows always asks how to
    handle multimedia formats, but I've never paid attention to what ports I've
    been plugging into.
     
    Ted Zieglar, Dec 16, 2005
    #4
  5. Bob Pownall

    LastYJ Guest

    I was able to turn off the AutoPlay for one of my USB drives.

    If that "Don't Prompt Me..." option is not available, just ignore the
    initial dialogue box.

    Once the USB drive is plugged in and recognized, go into My Computer,
    right-click on the drive and click Properties.

    You should then see a tab that says "AutoPlay". Click that, and then in
    the drop down box, select Mixed Content and below that in the Actions
    section, choose "Select an action to perform", and then select "Take no
    action". Apply the changes.

    After that, unplug the USB drive and plug it back in. You should no longer
    get the annoying prompt asking you what you want to do.

    However, if you look at the AutoPlay properties again, it would have been
    changed, but just cancel out of it. Well, at least that happened to me,
    but without making any changes, I unplugged it and plugged it back in and
    it did not auto-play.

    -lyj
     
    LastYJ, Dec 16, 2005
    #5
  6. Bob Pownall

    Bob Pownall Guest

    <snip>

    I may have not been clear in my original post, so I'll try again.

    1) The "What do you want Windows to do" message comes up when I plug in
    the flash drive on all XP systems I use. However, my I8500 is the only
    one where this message does *NOT* have a little "Don't ask me this
    again" message. (Or is it "Always take this action"? I forget, and my
    I8500 is the only XP system I have handy at present.)

    2) I believe I had checked this box some previous time when the "What do
    you want Windows to do" message appeared on my I8500, as before about
    three days ago, the "What do you want Windows to do" message did *NOT*
    appear on my I8500. Now it's started appearing again, and I can't
    figure out how to make it stop.

    Bob Pownall
     
    Bob Pownall, Dec 17, 2005
    #6
  7. Bob Pownall

    Bob Pownall Guest

    Following up on my own post, sorry.

    Just after my most recent post in the thread, I got smart, tried Google,
    and found something that seems to have led to a solution.

    While I still can't figure out why I'm not seeing the checkbox on the
    "What do you want Windows to do" window, I seem to have figured out how
    to stop the window from appearing in the first place.

    I plugged in my flash drive, selected "My Computer", to display all the
    drives and peripherals associated with my I8500, selected drive D: (my
    flash drive), right clicked, selected "Properties", then selected the
    "AutoPlay" tab. In the AutoPlay tab, I selected in turn each type of
    file in the pull-down menu. For each type of file, I clicked on the
    "Select an action to perform" radio button, then selected "Take no
    action", and applied the setting.

    After going through all four file types listed in the AutoPlay menu
    (Music files, Pictures, Video files and Mixed Content), I no longer have
    the "What do you want Windows to do?" annoyane. I can plug and unplug
    the flash drive, without any annoying Windows window coming up and
    prompting me to take some action.

    Hope this helps somebody else.

    Bob Pownall
     
    Bob Pownall, Dec 17, 2005
    #7

  8. Yup, it did! Thanks.

    *TimDaniels*
     
    Timothy Daniels, Dec 17, 2005
    #8
  9. Bob Pownall

    Clint Guest

    Helped me too! Thanks! To continue the giving, you can use TweakUI to add
    additional tasks to the list of Autoplay Actions. I'm going to see if I can
    get Nero to run when I insert a blank disc...

    Clint
     
    Clint, Dec 19, 2005
    #9
  10. Bob Pownall

    hayworth Guest

    Bob:
    As far as I can tell it's random and probably some kind of bug. When I
    plug in my flash drives I get lots of problems. One is like you said,
    it asks you what action to take. Sometimes I saw the "don't ask again"
    or "always do this" checkbox and sometimes I didn't - no telling when
    it will show and didn't make a shred of difference anyway. I even did
    the Drive Properties thing where I went down and told it to "take no
    action" for everything but, like someone else mentioned, it seems to
    forget this after a while. Moreover, when you plug in a different
    flash drive, all bets are off. It probably recognizes it is different
    because of the different serial number, so even if you get it to work
    for your drive, when you stick your friends drive in there it may ask
    again. So while your solution may work for a while, don't bet on it.
    I've just learned to live with it, as annoying as it is.

    The other, even more annoying problem is that it automatically assigns
    a drive letter to it that is already being used. To be specific, we
    use Novell Netware and the H: drive is our personal network drive. If
    I plug in the flash drive, sometimes, but not always although fairly
    often with friends flash drives, it will assign the drive letter to H
    even though H is already being used! When you go to WIndows Explorer,
    Windows Explorer still shows the Netware H drive, not the flash drive
    contents. However, if you use the Computer Management tool (control
    panel) and then click on Disk Management, it shows that the H drive is
    the flash drive not the Netware drive - COMPLETELY THE OPPOSITE OF
    WINDOWS EXPLORER! I then have to change the drive letter there (in
    Disk Management) and then it is OK. Well at least for some random time
    when it will go back to using H again. Like I said, it happens often
    or virtually always for friends drives that I plug into my computer and
    every two or three weeks for me. Any ideas on this?

    Mark H
     
    hayworth, Jan 6, 2006
    #10
  11. Bob Pownall

    Tom Scales Guest

    Windows is very unpredictable if the removeable drive and network drive get
    the same letter. Manually change the letter of the flash drive in Computer
    Management. It will remember it the next time you plug it in.
     
    Tom Scales, Jan 7, 2006
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.