GA-8GPNXP Duo: some issues with IDE drives

Discussion in 'Gigabyte' started by Noël Danjou, Feb 21, 2005.

  1. Noël Danjou

    BruceM Guest

    Yes, I agree with you about not wanting to start a "flame war" & that's why
    I'm butting out.
    All I'd like to do is to just come up with an answer about how someone
    (anyone?) can get these new age boards up & running with IDE equipment.
    In the next year or two there are going to be thousands, if not millions who
    migrate over to these boards & want to take their IDE HD's & other (optical)
    drives with them.
    I believe that the easy way is simply to buy all new drives (SATA) to suit.
    Wouldn't it be good if we could come up with an answer that states how to do
    this in a simple 10 steps or so to follow?
    Sorry to all the hundreds who might be going to read this thread that we
    haven't come up with an answer for you.

    Just take notice that on this board, the "only true IDE" ports are pink.
    You can't read optical drives through a raid. (on a raid?)
    You can't see or read your HD on a raid until you have your raid drivers
    installed & your raid setup.
    In closing just let me say that the one I setup is working with a CD & a DVD
    on IDE1 & an IDE 80GB on IDE2 running as a single disk raid. (normal) with
    bios set to boot from SCSI & bios HD boot order set to boot from this disk.

    To get these to work you HAVE to forget all those years of "I've never
    seen................."
     
    BruceM, Feb 24, 2005
    #21
    1. Advertisements

  2. Noël Danjou

    HammerToe Guest

    Hmmm. I guess I could be legitimately criticized for not researching
    the specs of the particular MB before I commented but... "So much to
    do, SO LITTLE TIME..."""

    INTERESTING!

    This is the first MB I've come across with only one 'normal' (instead
    of two 'normal') IDE ports. A NEW TREND....???

    Anyway, explains a lot of things/why you were trying to do what you
    were.

    Taking your latest response into consideration, I would
    (unfortunately) pressimistically have to predict that moveing to SATA
    drives in and of themselves will not do anything!!! I mean, if there
    is NO WAY to get your optical drives (even ONE) recognized on IDE1,
    then I things it maye well be come kind of fundamental incompatibility
    between your MB and (at least) YOUR particular optical drives, if not
    'in general'...

    Sound like your ONLY option is to (at least PARTLY) try and get some
    NEW writers, EITHER IDE or SATA that will work on IDE1 or SATA. If you
    could get SATA writers that worked, then you could still use IDE1 for
    HDs....

    BUT what you're proposing (also getting SATA drives) should hopefully
    give you 'in total' a way to get a working system...

    Good Luck!!!!

    And PS: Let us know how things work out.
     
    HammerToe, Feb 25, 2005
    #22
    1. Advertisements

  3. Noël Danjou

    HammerToe Guest

    Please see my reply to Noel.

    Like I said there, this is the first time I've come across 'such a MB'
    with only one 'normal' IDE port. Things now make more sense...

    BTW: I DO agree with all your comments. This is something I will have
    to watch for in future upgrades. My main at home WS is a 7n400 Pro2
    with *9* HDs (7 IDE and 2 SATA) and a single (IDE) writer (on IDE2)
    and everything works fine.

    BUT BOY, it sure restricts your choice of new MBs when you think about
    a change if you want to take all this alone and 'now this'....
     
    HammerToe, Feb 25, 2005
    #23
  4. Noël Danjou

    Noël Danjou Guest

    Hello all,

    I received my SATA drives and I installed them today. It's better but still
    not perfect!

    I first plugged my 4 drives 2 * Maxtor 80GB SATA and 2 * Plextor PX-712SA.

    I plugged the 1st HDD on SATA1 (ch0, master), the second on SATA3 (ch0,
    slave), the 1st writer on SATA2 (ch1, master) and 2nd writer on SATA4 (ch1,
    slave).

    I configured the BIOS like this:
    - Disabled both On-Chip Primary and Secondary PCI IDE
    - Disabled On-board H/W GigaRAID
    - Disabled SATA RAID/AHCI Mode
    - Set On-chip SATA mode to "Non-combined"

    Since the disks are brand-new I wanted to boot off a Windows XP SP1 CD but
    in this configuration, the bootable CD was not detected and I got message
    like "System Disk not found. Press Enter". Sorry I don't remember the exact
    message.

    I then tried to set "SATA RAID/AHCI Mode" to AHCI, it is said that it is to
    support hotplug but I don't know what else it does. So when I set this
    option the bootable CD was seen (i.e. the DVD drives are detected in SATA!
    pfff)

    When I hit a key, the bootable CD starts, the Windows Setup begins but after
    the Setup is done loading the drivers I get a BSOD:

    STOP: 0x0000007B (0xF78DA63C, 0xC0000034, 0x00000000, 0x00000000)

    Out of curiosity, I tried my Longhorn alpha preview CD and I got about the
    same result.

    The BIOS was set to boot like this:
    1. Floppy
    2. CD-ROM
    3. Hard Disk

    There is no option to boot from "SATA".

    Any ideas how to fix this?

    Since I could not boot off the CD, I had to put back my IDE HDD and remove
    the SATA drives (while I still don't have a fix) so that I could install my
    system.

    In the BIOS I set the options like this:
    - Enabled the On-chip Primary and Secondary PCI IDE
    - Disabled SATA RAID/AHCI Mode
    - Disabled On-board H/W GigaRAID
    - Set On-chip SATA mode to "Enhanced"
    Ch0 -> M/S PATA
    Ch2 -> M/S SATA Port 0/2
    Ch2 -> M/S SATA Port 1/3


    I connected my IDE HDDs to the true IDE connector (pink) and that way I can
    use Windows and use my two SATA DVD writers.

    It's almost OK but I still cannot boot from my CD/DVD without the BSOD and
    now I'd like to be able to install Windows XP and LH on my SATA 80GB HDDs so
    that I can disable all the IDE ports and only work with SATA.

    Also I still don't see the POST screen, I wonder why. Is it an issue with
    BIOS V. F6?

    Your suggestions are welcome. Thank you.
     
    Noël Danjou, Feb 26, 2005
    #24
  5. Noël Danjou

    HammerToe Guest

    You're getting into areas/technology now (with the MB and SATA
    opticals) that I've had no experience with so I can't help you much.

    But, one idea: have you considered trying to install the OS by GIVING
    UP on the idea of BOOTING (the OS Install CD) from an optical drive
    and instead try booting up from an XP Install ***DISKETTE*** set?

    It's not clear to me if you simply can't BOOT from an optical here OR
    you can't/WON'T be able to 'see' it at all (from an OS) if you get one
    installed.

    If 'booting' is the only problem, THIS workaround MAY enable you to
    get up and running at least.
     
    HammerToe, Feb 26, 2005
    #25
  6. Noël Danjou

    Tim Guest

    The stop message (7B - Inaccessiable boot device) most likely means you did
    not supply the SATA drives using F6 during setup.
    The drivers are invariably on the motherboard CD and you will need to create
    an install floppy - the method will be detailed in the manual. Consider
    checking the web site for a more recent driver set to save updating later.

    My apologies for falling into the trap and assuming that you mobo had two
    real IDE ports... Times are changing.

    - Tim
     
    Tim, Feb 27, 2005
    #26
  7. Noël Danjou

    kayizm007 Guest

    So has anyone been able to make this motherboard work correctly? I
    have tried switching from IDE 1 to 2, etc, back and forth, I have all
    IDE hard drives and I cant seems to make this thing work. Any
    suggestions? PLEASE HELP!!
     
    kayizm007, Feb 28, 2005
    #27
  8. Noël Danjou

    BruceM Guest

    Does your page in the bios setup or in your manual look similar to this?
    http://www.kingstonsesa.com/SATA.jpg
    To get this to work you need to forget some of the traditional way we've all
    gotten used to doing it.
     
    BruceM, Feb 28, 2005
    #28
  9. Noël Danjou

    Noël Danjou Guest

    Hello all,

    I have a working solution with only SATA drives and IDE fully disabled.

    I plugged my HDD on SATA1, my 1st PX-712SA on SATA2 and my 2nd PX-712SA on
    SATA4. For those tests I did not plug the 2nd HDD to SATA3 but that should
    work ok.

    In "Integrated Peripherals" I set the options like this:

    On-Chip Primary PCI IDE -> Disabled
    SATA RAID/AHCI Mode -> AHCI
    On-board H/W GigaRAID -> Disabled

    After rebooting, in "Standard CMOS Features" I get:

    IDE Channel 0 Master [None]
    IDE Channel 0 Slave [None]
    IDE Channel 2 Master [S_ATA1-Maxtor 6Y080M]
    IDE Channel 2 Slave [None]
    IDE Channel 3 Master [S_ATA3-PLEXTOR DVDR]
    IDE Channel 3 Slave [S_ATA4-PLEXTOR DVDR]

    Not sure who'd be IDE1?

    I created a chipset diskette from iaa40.exe on the CD. I could not find a
    newer version from Giga-Byte or Intel though it seems like there is a 4.1
    version of IAA, at least I think I read something like this in a readme.

    When I restart, I hit a key to boot from the Windows XP SP1 CD (after the
    message is shown). I hit F6 when requested, I select "82801FR AHCI" from the
    diskette and successfully complete the installation. The Windows XP Setup
    completes very quickly and the system seems to work just fine.

    The SATA controller appears as "Intel(R) 82801FR SATA AHCI Controller" under
    "IDE ATA/ATAPI controllers".

    I tried the same with the LH alpha preview CD, the 1st part of the Setup
    worked but I got the BSOD (0x7B) when LH started after the Setup restarted
    the system. I'd think that it is due to a possible lack of native SATA
    support in this alpha of LH. We will see with the upcoming preview.

    This configuration would be OK for me but I still wonder whether the system
    should be able to boot from a CD when SATA RAID/AHCI is set to Disabled? If
    this option is disabled and it could possibly boot from a CD, would a
    diskette still be required? I wish I did not need a diskette to complete the
    installation just like with standard IDE.

    Now I am looking for good SATA racks to put my HDDs in and then close my box
    hopefully once for good. I am looking for Enermax UC-S106TMFA since I am
    satisfied with the IDE version of those racks.
     
    Noël Danjou, Feb 28, 2005
    #29
  10. Noël Danjou

    BruceM Guest

    I'm glad you got it going.
    Is your computer in a business environment or just casual use?
    It would be nice if you could now document exactly the procedure to get to
    your pesent situation. (which you have done)
    Then go back & try to sucessfully get it going with all IDE hardware & also
    record your steps.
    I can see a very big demand for this advice in the near future.
    Pity Gigabyte, ASUS & others can't create more detailed documents for
    following.
    I would have taken more care in recording my exact steps to get my first one
    going & if it was mine I would do just that but it's in a University now
    half way across the country.
    Regards.....

     
    BruceM, Mar 1, 2005
    #30
  11. Noël Danjou

    kayizm007 Guest

    I connected my optical drves into the first IDE slot. I connected my
    hard drives to the other IDE channels. After the RAID drivers were
    loaded everything finally appeared fine until it rebooted and I get
    the message "Disk error replace disk and reboot". What the hell am I
    doing wrong?
     
    kayizm007, Mar 1, 2005
    #31
  12. Noël Danjou

    BruceM Guest

    I'm flying blind here but did you set your machine to boot from SATA? (yes I
    know it's not a true SATA)
    Is there the option in yours to swap IDE1 over with IDE2? Maybe try that.
    And then in "boot from HD" set it to the one with your OS loaded on it.
    Wright each down so you can try dif ones. There are about 5 things that you
    can try in dif settings so that makes 5X5=25!!!
    Just make sure you keep a record of what happens with each one.
     
    BruceM, Mar 1, 2005
    #32
  13. Noël Danjou

    Noël Danjou Guest

    Bruce,

    This new computer is to replace my current development system (I am a
    freelance software engineer). I also prepared it for the upcoming
    beta-testing.

    Here is a summary of my current experiments. I won't have time to further
    investigate the issues I had with my IDE optical drives. I think I tried all
    possible combinations and none worked in my case.


    The Giga-Byte GA-8GPNXP Duo motherboard has 3 IDE ports:

    - 2 green ones (IDE2/IDE3) which support ATA133 and RAID

    - a pink one, a true IDE port which suppors ATA33/66/100.


    I ran all my tests on the green ports with the "GigaRAID Function" setup
    option set to ATA in "Integrated Peripherals" so that the GigaRAID
    controller works as a true IDE/ATAPI controller.

    I could not get any of my Plextor optical IDE drives PX-116A, PX-130A and
    PX-712A to work on any of the IDE ports (IDE, IDE2 or IDE3). Only my old
    Plextor PX-W2410 and my Maxtor 40GB IDE HDDs did work on any of the IDE
    ports.

    My quick and only solution for the optical drives were to buy 2 optical
    Serial ATA (SATA) drives. So I bought 2 Plextor PX-712SA since I could not
    find a SATA DVD reader.

    Once I had my SATA optical drives, the remaining issue was to be able to
    boot from a CD when a bootable CD is inserted in any of the optical drives.

    With the F6 revision of the BIOS, my bootable CD are not detected as
    bootable when the "SATA RAID/AHCI Mode" setup option is set to Disabled.
    This always led to a Disk Error message since my HDDs were not formatted
    yet.

    On another hand I am able to boot from a CD when the SATA Mode option is set
    to AHCI. The only drawback of this solution is that this mode requires an
    Intel ICH6R (IAA) chipset driver diskette to install Windows.

    AFAIK the SATA drives support in Windows XP is only available with the
    Service Pack 1 and later.

    I now have two possible working solutions, one with only SATA drives and one
    with IDE HDDs and SATA optical drives.



    * The mixed IDE/SATA solution:

    - I plugged both my Maxtor HDDs to the true (pink) IDE port with a
    80-conductor cable, one drive as master and the other one as slave.

    - I plugged the first SATA optical drive to the SATA1 connector and the
    second one to the SATA3 connector.

    - In the BIOS, I set the related options like this:

    On-Chip PCI IDE [ Enabled ]
    SATA RAID/AHCI Mode [ AHCI ]
    On-board H/W GigaRAID [ Disabled ]


    Note: I could have used the GigaRAID ports instead of the true IDE, the
    options would have been:

    On-Chip PCI IDE [ Disabled ]
    SATA RAID/AHCI Mode [ AHCI ]
    On-board H/W GigaRAID [ Enabled ]
    GigaRAID Function [ ATA ]

    Hard Disk Boot Priority: 1. SCSI-0: IT8212


    This solution would require to provide an ITE IT8212 chipset drivers
    diskette during the Windows installation as well.



    * The full SATA solution:

    - I plugged my SATA Maxtor HDDs to the SATA1 and SATA3 connectors

    - I plugged my SATA Plextor optical drives to the SATA2 and SATA4 connectors

    - In the BIOS, I set the related options like this:

    On-Chip PCI IDE [ Enabled ]
    SATA RAID/AHCI Mode [ AHCI ]
    On-board H/W GigaRAID [ Disabled ]




    * Installing Windows XP

    In either case, the installation of Windows is the same process.

    - you first need to create the chipset diskette for the SATA controller in
    AHCI mode. To do so, extract the files from "iaa40.exe" (on the CD provided
    with the motherboard) to a diskette.

    - Once the BIOS is configured, save the configuration and reboot with a
    bootable CD of Windows XP SP1 in the first optical drive. Hit a key when the
    message "Hit a key to boot from CD" appears. The Windows XP setup starts.

    - When the message "Hit F6 for additional SCSI and RAID drivers" message
    appears hit F6 and follow the steps to select a new driver from the
    diskette. Select "82801FR AHCI".

    - You can now successfully complete the Windows setup.


    I hope this helps.

    Regards,

    Noël
    http://noeld.com/
     
    Noël Danjou, Mar 1, 2005
    #33
  14. Noël Danjou

    Noël Danjou Guest

    Here is another working (mixed PATA/SATA) configuration but which requires
    no diskette to install the system, so no need to hit F6 and so on, just like
    a standard IDE configuration.

    I successfully tested it with Windows XP SP1a CD and Longhorn alpha preview
    DVD.

    Hardware:

    - I plugged both my Maxtor HDDs to the true (pink) IDE port with a
    80-conductor cable, one drive as master and the other one as slave.

    - I plugged the first SATA optical drive to the SATA1 connector and the
    second one to the SATA3 connector.

    - In the BIOS, I set the related options like this:

    On-Chip PCI IDE [ Enabled ]
    SATA RAID/AHCI Mode [ Disabled ]
    On-Chip SATA Mode [ Enhanced ]
    On-board H/W GigaRAID [ Disabled ]
     
    Noël Danjou, Mar 8, 2005
    #34
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.