GA-8KNXP LAN Speed problem...

Discussion in 'Gigabyte' started by nobody, Jul 19, 2003.

  1. nobody

    nobody Guest

    Hello,

    Has anyone else noticed a problem with the onboard "Intel
    Pro/1000 CT Desktop" ethernet controller only detecting a 10 MB
    network, even if you're on a 100 MB network? This problem is driving
    me insane. I've already tried flashing the BIOS and updating the
    drivers, and the problem persists. Their stupid software thinks
    there's a bad wire or something, and I tested all 8 wires myself, and
    they're fine. I even tested it with multiple patch cords.

    Thanks
     
    nobody, Jul 19, 2003
    #1
    1. Advertisements

  2. nobody

    Darmok Guest


    Enet detect speeds are based on the quality of the data ... if the LAN
    set is getting errors, it will keep dropping back until an acceptable
    data exchange level is reached. Could be totally in your mb LAN
    hardware, and nothing to do with your LAN. Have there been driver
    updates for that? Might be worth a check.

    The LAN on my GA-8IK1100 (basically same board as yours) can't be
    used, as it and my ATI Radeon 9700 AIW don't seem to like one another.
    My solution was just to stick a NIC in the system, and leave it at
    that.

    Good luck
     
    Darmok, Jul 19, 2003
    #2
    1. Advertisements

  3. First of all, are you using high quality patch cables that are certified for
    100-Base-T?

    If you buy your patch cables, I would reccomend that you buy patch cables
    certified as Cat-5e.

    If you install the Intel Proset software that came on the CD, you can bring
    that up, and try changing the speed setting there. It normally defaults to
    auto-set, but you can manually choose your speed.
     
    Timothy Drouillard, Jul 19, 2003
    #3
  4. nobody

    nobody Guest

    Has anyone else noticed a problem with the onboard "Intel
    It says so in the Intel PROset software that came with the
    motherboard. There's a button that says, "Test Link Speed". When I
    test it, this is what it says back: "A Category 5 cable is required to
    run at 1000 Mbps. The cable connected to the device either has only
    two pairs or has faulty wires."

    Also, the 100 light on the router is turned out for this port
    - only the 10 is turned on. FYI, I have tried switching to another
    jack and also tested the cable with another computer (works at 100
    there). There's also a "Test Cable" button, and that doesn't detect
    any errors on the line.

    The funny part, is I made this particular wire myself using
    Cat5e cable, so it should be good for 100 or 1000. I don't have any
    problems with any of my other computers reaching 100 - I'm not really
    going for the full 1000 speed here (I personally thing that's a waste
    of time until hard drives become faster).
    No there are no errors.
     
    nobody, Jul 19, 2003
    #4
  5. nobody

    nobody Guest

    I have a few store bought cables, but I usually make them
    myself from Cat-5e cable. I know they work, because the router always
    detects them at 100 and I can transfer files a lot faster than 10
    mbps. I tested it with this new NIC, and it's taking 15 mins to
    transfer a file that used to come across in 3 or 4 mins - so the
    software's not misreporting the speed or anything.
     
    nobody, Jul 19, 2003
    #5
  6. nobody

    Bob Davis Guest

    How can you tell?
     
    Bob Davis, Jul 19, 2003
    #6
  7. nobody

    nobody Guest

    The easy part is what color wire goes to what pin.
    Thanks for the info, it's always good to double-check yourself, but
    that's exactly how I make my cables.

    1. White/Orange
    2. Orange
    3. White/Green
    4. Blue
    5. White/Blue
    6. Green
    7. White/Brown
    8. Brown
    I'll have to keep that in mind for next time.
    That's funny, because my friends complain that I take too long to make
    my cables, because I'm making them just like you described. Most
    people let it all hang out and just put a boot on it - I personally
    don't like that. Now you've justified my slowness in making cables!
    :)

    Another weird thing I just noticed, and this is kind of a slap in the
    face, is the Intel PROset software has this message: This adapter is
    capable of connecting at a higher speed. I have a feeling Intel
    created this NIC with 1000 only in mind. I have no way of checking
    the impedience on the lines, but I have check all of them for
    continuity.

    Is anyone out there running this same exact board on a 100mbps network
    successfully?
     
    nobody, Jul 19, 2003
    #7
  8. I Have mine cabled to a Linksys Cable/DSL Router (connecting at 100mbs)
    along with a second PC (also connected at 100Base-T) and two printers and it
    works flawlessly.

    Yes the Intel software tells you it's capable of higher speed, it can go to
    1000mbs .
     
    Timothy Drouillard, Jul 20, 2003
    #8
  9. Also check to make sure you're running at full duplex as well.
     
    Timothy Drouillard, Jul 20, 2003
    #9
  10. nobody

    nobody Guest

    Also check to make sure you're running at full duplex as well.
    Well, I checked eveything I could, and it all looks fine.

    I just had a good idea... I'm going to test it through a hub,
    and see if this NIC is incompatible with my router. I figure the hub
    will talk to the router, thus bypassing the whole situation of this
    NIC talking directly to the router.

    Guess what guys?!! It worked! Going through the hub it has
    no problem connecting at 100. FYI, I'm using the same exact cable to
    connect, and I previously tested other ports on the router.

    Now I just have to figure out why this NIC doesn't like my
    router - I have a Netgear RT314. Anyone else using one with this
    motherboard successfully?

    Thanks everyone for all your help, I really really appreciate
    it. This was driving me up a wall. I might have to email Intel and
    Netgear to see if they know anything we don't. I'm just glad to be
    back at 100!
     
    nobody, Jul 20, 2003
    #10
  11. nobody

    Tim Guest

    FYI:

    I have a new 8KNXP using a direct connect Cat5e cable to a CNet 1gbs card in
    my server.
    This works at 1gbs - although some (IE ALL) of the disc drives on the server
    are not capable of much at all.

    The CNet card is a 64 bit card in a 32 bit PCI 2 slot. The server runs an
    Asus P2B-DS with dual P 2 400's running W2KS. The only hassles in installing
    this config were:

    1) I had a cat5 cable - didn't like that & said there were missing pairs
    etc. This cable went through wall sockets etc, so rather than stuff around
    to find where I had made a wiring mistake if any, or a poor connection I
    just augmented the cable with a new direct connect cat5e cable without any
    intervening sockets, plugs or other failure points.

    2) the CNet driver on floppy was stuffed - caused W2K BSOD's. The error
    (0x21 I think) indicated a checksum error in the driver file, so I
    downloaded the most recent driver (appears to be older) and used that
    instead. Works flawlessly now.

    My reason for the faster link is for faster backups of the server disc to
    disc over the network. When the backup is processing large files on the
    faster discs I get around 100% improvement in throughput using 1gbs - IE
    from about 6MBs to about 12 (the drives are slow). Where there are many
    small files EG a W2K system directory, there is not improvement in
    throughput - it still goes as slow as 100 - 200 KBs (yes K) turning over
    many dozens of files per second - this is process and / or disc / seek
    bound.

    I get a faster backup - shaving around 1/2 hour a night off a full system
    backup, so I get more sleep :)
    Peak performance on the link is aroung 15MBs - twice that previous - this is
    *good* as far as I am concerned as when the server is replaced (soon -
    anyone want to buy it?) the rest of the network will already be heading in
    the right direction. BTW I am using NTBackup - a different backup package
    would no doubt result in a substantial performance gain.

    So the moral? As you would expect. 1gbs is quick, don't expect old systems
    to give performance where none is to be got. The improved (reduced) turn
    around time in the network no doubt contributes for backups, but the amount
    is tiny. The 1gbs interfaces are a lot more flexible - they don't care about
    direct connect, cross over cables, duplex or half duplex, or how fast the
    other end is - they just run at the best speed for the conditions. I won't
    be buying any more 100mbs cards from now on.

    Shame you had so many problems.

    HTH
    - Tim
     
    Tim, Jul 20, 2003
    #11
  12. nobody

    nobody Guest

    Hey Zippy,

    Thanks for the reply. That's very interesting stuff. That
    thought actually crossed my mind too. I've never had good luck with
    Intel networking equipment. I usually go with D-Link or Netgear. I
    really like Netgear, but their stuff isn't as peppy as D-Link and it
    costs more. Almost like the old days with US Robotics Courier modems,
    compared to the cheapie modems that would smoke them (sorry, getting
    off the topic there).

    Anyway, what you were saying about the Intel chipsets being
    too sloppy with their timing and causing the switches to sense a fault
    - or they are too rigid and are flagging a fault on a valid
    datastream. That totally makes sense to me, because that's what I was
    kind of gathering while I was testing it. It seemed to me like it was
    jumping to conclusions, and just selecting the wrong spec or not
    giving it enough time to really determine the best solution. I wish I
    knew more about how it determines the speed internally, because then I
    could probably fix it.

    I did exactly as you did, I tried to adjust the Flow Control
    and all the other settings, but they didn't help. I even messed with
    the PME settings for the NIC, and in my BIOS - nothing made any
    difference. I flashed my BIOS too, and even tried newer PROset
    drivers and chipset drivers.

    Sometimes it would sense a 1 Gig network connection, and then
    switch to "Cable Unplugged". I was interpreting it as, it's sensing
    all 8 wires, but then something went wrong and it dropped the
    connection. That's very strange behavior from a NIC card, especially
    considering I only have a 100 mb network.

    I was thinking about what you said, about putting a cheap
    D-Link NIC into the computer to fix the problem. In my opinion, the
    best solution would be to buy a cheap hub. This way you can keep your
    PCI bus free for other things.

    Oh, as an FYI, I'm now running at 100 mbps Full Duplex, and
    there have been 0 Send / Receive errors. Pretty good for a homemade
    cable, huh? Anyway, thanks again.

    Nobody
     
    nobody, Jul 20, 2003
    #12
  13. nobody

    Gary Seven Guest

    In Windows 2000
    Under Device Manager, right click on your LAN connection. hit
    Properties, under the Advanced Tab, Click on Link Speed and Duples
    under that list of 'stuff.' On the right hand side you can manually
    set what speed you want the card at.
     
    Gary Seven, Jul 20, 2003
    #13
  14. I have a Netgear RT314 connected to my 8KNXP, a Macintosh G4 DP 1ghz and
    another PC, an nforce2 rig.

    I have no idea how to determine the network speed. Tell me how and I will
    check it.
     
    rodeoislander, Jul 21, 2003
    #14
  15. nobody

    nobody Guest

    Do you have Windows 2000 or XP on any of them? If so, you can go to
    the Task Manager (Ctrl-Alt-Del) and it will tell you on the Network
    tab at the bottom usually. Also you can use the Intel PROset software
    to tell you. Another way to tell (for XP and 2k) is to click Start /
    Settings / Control Panel / Network Connection / Local Area Network.
    And lastly, you can check the Link/Act lights on your router, since
    you have the RT314. If the light for 100 is out, you're running at
    10.

    Nobody
     
    nobody, Jul 22, 2003
    #15
  16. Both my router (doh!) and Windows Task Manager (XP) report my speed at
    100mbps.
     
    rodeoislander, Jul 22, 2003
    #16
  17. nobody

    nobody Guest

    Both my router (doh!) and Windows Task Manager (XP) report my speed at
    Okay - thanks for the info. Have you ever upgraded the Firmware on
    your router? I'm using V3.24, but they have a V3.25 out now. Also,
    just to verify: You're using the GA-8KNXP motherboard, right? And
    your computer is directly plugged into the route, not going through a
    hub or anything else first?

    I was looking for a motherboard Revision number, but I don't see one
    on this motherboard... We might have different revisions of the
    board, and that's why yours works and mine doesn't. Does anyone know
    how to find the revision for this board? There might even be
    different revisions of this router, outside of the firmware.

    Nobody
     
    nobody, Jul 23, 2003
    #17
  18. nobody

    nobody Guest

    My two year old Netgear Rt314's firmware is currently 3.25
    So you are using a new firmware than mine. Maybe I should
    upgrade mine too. They claim the upgrade to 3.25 won't affect US
    users, or something like that (was meant for people in Europe).
    Thanks, I found it! Yeah, mine is the same rev 1.0.
    I tested multiple ports on the router, and they were all the
    same. I've never had any problems with that router before.
    Mine says it's version 8.0.0.0 - numbers don't really match
    what you said above. Where did you find that version number?
    I don't think the board is broken, but the problem is coming
    from the Intel chip or software. As I stated before, I am running at
    100 now, but going through a hub into the router. Thanks for all your
    help.

    Nobody
     
    nobody, Jul 23, 2003
    #18
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.