GA-MA78G-DS3H problem with SATA-drives

Discussion in 'Gigabyte' started by Frank, Jun 18, 2008.

  1. Frank

    Frank Guest

    Hi all,

    equipment: - board as above
    - 2x2GB RAM-DDR2-800 bars
    - Athlon 64 X2 6400
    - Western Digital 500 GB SATA HDD (not partioned, not formatted, new)
    - Hitachi 250 GB SATA HDD (not partioned, not formatted, new)
    - Samsung DVD Burner SATA
    - two eSATA slot brackets with cables attached to mainboard (no
    devices attached outside)
    all brand new.

    Boot sequence is "1=CDROM" "2=HDD"
    XP CD is inserted
    "Enabled" BIOS' "OnChip SATA Controller"-option
    If I turn on "AHCI" as "OnChip SATA Type" boot process stops while
    "Verifying DMI Pool Data...."
    If I turn on "Native IDE" as "Type" boot process finishes and XP
    starts installation stating there were two disks ("drive 0 id 0 bus 0
    and drive 0 id 1 bus 0") each with 131.070 MB

    What is this all about?
    Why does boot process stop when in AHCI mode? It might be necessary
    to install os-drivers to fully use AHCI, but that should not work if
    AHCI is turned off by BIOS (from my point of view or did I understand
    something wrong?)
    Why does XP report 131.070 MB for the drives?

    Any hint appreciated
    Frank
     
    Frank, Jun 18, 2008
    #1
    1. Advertisements

  2. Frank

    Frank Guest

    Thanks Andy!

    Finally solved the issue as follows:
    - First, my initial description was uncomplete. An important missing
    detail is that I tried to install XP, which failed prior to "you have
    the following disks, where do you wanna install XP?". And it failed
    with a blue screen. Afterwards system behaved liked described. What I
    learned is, that this step modifies the MBR of the disk although,
    there wasn't any partioning or formatting done to that point. I
    thought, the disk would be clean and new at that time.
    - Using Hitachi's Drive Fitness Tool to clean the MBR led to correct
    beheauviour of the system. If you now use the floppy (F6 while
    install) with "AMD SATA Drivers", everything works fine (no blue
    screen and correct drive sizes)
    - strange effect is, that not using the floppy leads to a somewhat
    strange MBR, which blocks you on "Verifying DMI...)

    Kind regrdas
    Frank
     
    Frank, Jun 19, 2008
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.