1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

GeForce4600 and Philips LCD problem (long)

Discussion in 'Nvidia' started by B, Dec 22, 2003.

  1. B

    B Guest

    What hppens if you run one of the older games in compatibility mode.

    regards

    B
     
    B, Dec 22, 2003
    #1
    1. Advertisements

  2. I am having a problem with a few games on my PC where the game starts
    and the monitor tries to resize the display and can't so minimises the
    application to the taskbar. I have posted this on the specific game's
    Forum and although I got a lot of help, I didn't manage to get a
    solution...

    ====

    Hardware/Drivers:

    I have WinXP Home, Intel P4 2.26, 1Gb ram, Asus P4S533 motherboard
    running 1010 bios and 4x AGP with sideband on, Chaintech Geforce4ti
    4600 128mb and a Philips 180p2m LCD monitor running at 1280x1024x32 at
    60Hz over a DVI-DVI cable. I am running DX9.0b, nVidia 45.23 and the
    latest drivers for all devices including the monitor. Nothing is
    overclocked.

    ===

    The problem:

    When starting Zeus, the loading screen is OK (640x480 scaled to fit
    the screen), teasing monsters, summoning heroes etc, but as soon as I
    would expect the game proper to start, the monitor tries to resize the
    display, goes black (true black, not the screensaver black) for a
    couple of seconds and then minimises the game to the taskbar. Clicking
    the game open again does the same thing. Nothing I then do will get
    the game to display at all.

    I get this same effect on several older games (Grim Fandango, many
    shareware games (Brave Dwarves 2 Gold)) plus the demo of Space Colony.
    I know Zeus plays perfectly on this PC with a CRT analogue monitor
    attached (just not with this LCD over DVI).

    With Emperor Rise of the Middle Kingdom, the loading screens are OK
    and the game opens perfectly, BUT as soon as I try to resize the
    display (change from 800x600 to 1024x768 or change from fullscreen to
    windowed) I get exactly the same problem I had with Zeus - the monitor
    tries to change resolution and the game minimises to the taskbar. More
    interestingly, if I close the application and try again, I get the
    minimizing bug immediately - it won't even display the loading screen.
    If I then reboot the PC it works OK at the new resolution (assuming I
    don't try to change it).

    Other games such as Everqust work perfectly at any resolution I
    select, can change resolution on demand correctly and swap between
    windowed and fullscreen mode.

    I get no graphical artifacts, I get no unexplained crashes, the
    machine is stable and running relatively cool - there is plenty of
    cooling in the case and the video card. It has never been overclocked
    or run without cooling. All 2D applications are perfect.

    ===

    DXDiag problem:

    Dxdiag will not complete the "Test Direct3d" test, saying the User
    pressed a key to cancel all the DX7/8/9 tests

    ===

    Things I have tried on the advice of the official Citybuilders forum
    chap who is very helpful include...

    For Zeus - getting rid of the bink video file on startup after teasing
    the monsters and ejecting the cd

    trying latest nVidia drivers (52.16 at the time)

    trying old nVidia drivers (30.82)

    setting default plug and play monitor

    setting 1024x768x16bit as background resolution

    setting "Centre in screen" rather than "scale to fit" in nvidia
    drivers options

    setting nVidia refresh rate in D3D to force 60HZ rather than
    application select

    Hardware acceleration off

    make sure via Philips aftersales that I have the latest monitor
    drivers (I do)

    ===

    So, I am kinda stuck here - I am hoping that someone with the same
    setup can tell me if I am alone, or if I am able to post any extra
    information which will help narrow this down. I am open to suggestions
    of diagnostic options or any monitor/videocard testing applications.

    I'd like to keep the DVI DVI cable as the quality difference in
    Everquest was just amazing, though I do still have both analog/analog
    and analog/dvi cables.

    Advice or solutions please (if relevant to my issue - I am not looking
    for comments like "go play a proper game").

    Thank you in advance.
     
    HelixStalwart, Dec 23, 2003
    #2
    1. Advertisements

  3. B

    Me Guest

    Are the games trying to set a specific REFRESH rate fro the game session ?

    Try running ReForce or similar to force the refresh rates at a given
    resolution to 60Hz for example.
     
    Me, Dec 23, 2003
    #3

  4. Already tried that thanks, see...
     
    HelixStalwart, Dec 23, 2003
    #4
  5. Compatability mode didn't seem to work - I set the game icon to load
    into compatability mode for both Win95 and Win98 and just got the
    hourglass for a second and the application wouldn't load - I didn't
    spend a lot of time trying to get it to work that way - maybe I should
    read about it and try it again.

    How is this supposed to work?
     
    HelixStalwart, Dec 23, 2003
    #5
  6. B

    Me Guest

    Don't use the Nvidia settings.
    I've found that games quite often ignore it.
    Give Reforce. a try.
     
    Me, Dec 24, 2003
    #6
  7. OK, I got ReForce.exe and ran it - it faultlessly detected the monitor
    and correctly noted the maximum refresh rates at all resolutions from
    320x200 up to 1280x1024.

    I set 60Hz to all resolutions and tried Emperor again, and got exactly
    the same issue - it works perfectly until I try to resize the screen.
    I can play the game ONCE but as soon as I exit the game I have to
    reboot the PC otherwise it won't load a second time, diving for the
    taskbar as soon as it starts.
     
    HelixStalwart, Dec 24, 2003
    #7
  8. B

    Me Guest

    Damn, have you tried the games wb site to see if this is a known bug and if
    there is
    a fix for it?
     
    Me, Dec 25, 2003
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.