1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Greetings and help about Sunfire 280R

Discussion in 'Sun Hardware' started by supervinx, May 10, 2011.

  1. supervinx

    supervinx Guest

    Hi to everyone in this NG !
    I've rescued a Sunfire 280R.

    I can connect through serial console "A" only if I remove the RSC card
    (which has three connector on the back, marked serial, phone and network,
    and an internal 56k modem card).
    1) There's a way to re-route console output to serial "A" with the RSC
    card inserted ?
    2) I'm in lack of a suitable RJ-serial cable to connect at the RSC card.
    I have a Cisco RJ-45 to DB9 cable. Can be used harmlessly ?
    3) How does the RSC card work ? May I connect through the RJ-45 network
    port on the RSC card ?

    Thanks !
     
    supervinx, May 10, 2011
    #1
    1. Advertisements

  2. You don't have direct access to the console with the RSC
    installed. You have to login to the RSC first, and then console up
    through it. If the console is still going to ttyA with the RSC card
    inserted, then you may have to set the output to be the RSC with the
    commands (from the OS level)
    eeprom input-device=rsc-console
    eeprom output-device=rsc-console
    Or from OBP
    diag-output-to rsc
    setenv input-device rsc-console
    setenv output-device rsc-console
    Yep, Cisco pinout works just fine for everything Sun (and almost all
    other network hardware using RJ45 pinouts).
    Read up on the docs. Page 107 starts a whole chapter on the RSC

    http://download.oracle.com/docs/cd/E19088-01/280r.srvr/806-4806-10/806-4806-10.pdf

    Granted, finding documentation within Oracle now-a-days is a beast in itself.

    The RSC lets you have offline remote console access through serial or network.
    (at least if its the version I'm familure with, IIRC there was two
    different versions of these cards for this server).
     
    Doug McIntyre, May 10, 2011
    #2
    1. Advertisements

  3. supervinx

    supervinx Guest

    I re-inserted the RSC card and tried to connect through the Cisco cable.
    The RSC told me: "please login".
    Ouch, it's not the Solaris login.
    This in not a problem: I issued (from ssh connection)
    eeprom input-device=ttya
    eeprom output-device=ttya
    and on next reboot talked with serial "A".

    I've no rsc package installed, Sun download center has migrated to Oracle
    (what a mess), and couldn't be able to find it.
    I've installed Solaris 10: when the rsc package can be found ?
    I checked my DVD, no luck :(
     
    supervinx, May 10, 2011
    #3
  4. supervinx

    DoN. Nichols Guest

    Congratulations! Nice machines.
    Hmm ... may need to re-configure the RSC card -- which requires
    an installed OS, and the special program for the RSC card. If you are
    lucky, it does not have passwords set. Can you put a framebufer in
    there and plug in a keyboard and mouse?

    For useful documentation search on Google to find a link into
    Sun's/Oracle's site for the following documents:

    806-4806-10.pdf (Owner's Guide)
    806-4807-10.pdf (Service Manual)
    806-4808-14.pdf (tells you which fan tray you need if you use the "Cu" CPUs*)
    816-2726-10.pdf (CPU installation guide -- if the book in the system is gone)
    816-3314-12.pdf (RSC 2.2 User's Guide)
    816-3315-10.pdf (RSC 2.2 Release Notes)

    * The "Cu" CPUs require a more powerful fan in the center location
    of the fan tray -- or from their point of view, you to purchase
    a different model fan tray with the more powerful fan. :)

    You'll want this to deal with the RSC:

    rsc2.2.3_packages_s9.zip

    And this will update the OPB to the latest version:

    118323-01.zip

    OBP 4.16.4 2004/12/18 05:18
    That was the default condition with mine -- from a hamfest.
    That is precisely the correct pinout -- although the connector
    name is wrong, I fear. That is a "DE-9". "DB" is the size shell which
    will accept 25 normal sized pins, 50 high-density pins, or various mixes
    of coax and normal pins like the 13W3 used for older Sun Framebuffer
    connectors (three coax out of a total of 13 pins). The reason that "DE"
    is smaller than "DB" is that it was an afterthought. "DA" was the 15-pin
    connector, "DB" the 25-pin, "DC" the 37 pin "DD" the 50-pin three row
    used for earlier SCSI connectors among other things, and when they
    discovered a need for a smaller one in that series, since they could not
    go to negative *letters*, the just wrapped around to "DE".

    If you are connecting to a PC as a terminal that is fine.
    Yes -- if you know the IP address which it is set to. You may
    need to go in through the RJ-45 RS-232 first to set the IP address (and
    a few other things).

    If the password is set -- *unplug* the power from the SF-280R
    (it powers the RS-232 socket even when the computer is off), then pull
    the connector from the rechargeable battery *and* pull the coin cell from
    its holder and hope that this zeros the memory. It might be that the
    jumper block right by the coin cell (J0403) can zero it if you move the
    jumper block to the other pair of pins for a while and then restore it.

    Anyway -- once the IP address is set to something in your
    subnet, you can telnet to it -- or use the RSC software (on either
    another Sun or on a Windows box) to talk to it via a GUI.


    ======================================================================
    Mysys:someone 20:14:33 > telnet RSC280R-rsc
    Trying 10.0.0.43...
    Connected to RCS280R-rsc.
    Escape character is '^]'.

    RSC version 2.2.3 (RCS280R)

    Please login: XXX
    Please Enter password:

    rsc>
    ======================================================================

    And once you are logged in, you can type "help" for a list of
    commands.

    No bet what a previous user may have assinged as a username to
    allow login. But -- from an installed Solaris 10 (installed with the
    RSC card missing), with

    rsc2.2.3_packages_s9.zip

    installed, you can reset the passwords and everything else from there.

    If you *do* get in without a password, "usershow"will list all
    valid user names what their permissions are, and whether they have a
    password or not.

    Bootmode sets how it will boto (normal, forth, reset_nvram,
    diag, and skip_diag).

    Shownetwork tells you what IP it is given, what gateway and
    netmask it is using, and what the MAC address is.

    Obviously, even with good passwords, you want to assign it to a
    non-routable IP address behind your firewall.

    Of course -- you don't *really* need the RSC card installed,
    unless you want to administer it remotely. I do -- so I made mine work,
    but I'm not sure whether you can download the rsc2.2.3_packages file
    since Oracle took over.

    FWIW -- the computer is quite happy with a pair of 146 GB FC-AL
    drives in it -- even though they are not listed as approved (the drives
    are newer than the system, of course. :) But you can't mount a 1.6"
    high FC-AL drive in there, unlike in a Sun Blade 2000, which uses the
    same system card and CPUs.

    As for the modem -- you can set it up to allow logins, or to
    allow the system to call out to a beeper (or these days cell phone) to
    indicate problems.

    Good Luck,
    DoN.
     
    DoN. Nichols, May 11, 2011
    #4
  5. supervinx

    supervinx Guest

    Wow ! :)
    Yes, it's a Cu CPU and I noticed that the central fan was different from
    the other two on the sides...
    I had to reinstall Solaris 10, the two disks seemed to be wiped out.
    Now I'll hunt for the rsc package (rsc2.2.3_packages_s9.zip) since my
    Solaris DVD was without it.
    I set input-device and output-device to ttya, since the rsc card asked me
    for a password.
    Tried some frequently used combinations, but no luck.

    I use linux hosted putty and a notebook, it works well...

    Thanks a lot !
     
    supervinx, May 11, 2011
    #5
  6. supervinx

    supervinx Guest

    Well, found rsc software and eeprom upgrade.

    1) Installed the rsc software (pkgadd).
    rsc-config tells me that no hardware is present.
    The rsc card "talks" to me.
    What I'm missing ?
    Hardware drivers because I reinstalled Solaris 10 with the card removed ?

    2) Big troubles with the eeprom upgrade.
    Tried first method, boot disk ....
    OPB states that the file is not a valid executable (talks about stack
    errors)
    Tried the shell script ... I have a localized Solaris version and got
    special character troubles in the answers.
    There's a way to revert, temporarily, to english so I can answer yes/no ?
    Meanwhile, I'll play with the terminal emulator and its character set.
     
    supervinx, May 11, 2011
    #6
  7. supervinx

    supervinx Guest

    Il Wed, 11 May 2011 16:48:46 +0000, supervinx ha scritto:
    Solved the rsc problem.
    Had to power-cycle (not reboot) the machine.
    Now the rsc is up and running...
     
    supervinx, May 11, 2011
    #7
  8. supervinx

    supervinx Guest

    supervinx, May 11, 2011
    #8
  9. supervinx

    DoN. Nichols Guest

    O.K. Yes -- IIRC a 14W fan, while the others are 7W.
    It does not come on the Solaris DVD. I had to download mine
    from Sun's site -- before Oracle took over. No idea whether it is still
    available without a support contract these days. If not, just pull the
    RSC card, since it will only be wasting power and getting in your way.
    Did you try pulling the coin cell and the rechargable battery
    connector to see if that erased the configured users and passwords?

    I *think* that I had to create my users from the configuration
    program in that "rsc2.2.3_packages" file.

    The _Users Guide_ is installed from that, too.
    Good enough.
    You're welcome.

    Good Luck,
    DoN.
     
    DoN. Nichols, May 13, 2011
    #9
  10. supervinx

    DoN. Nichols Guest

    That could have been it. Look for /dev/rsc-control. On my
    system, it is the following symlink:

    ======================================================================
    lrwxrwxrwx 1 root root 58 Feb 17 14:03 /dev/rsc-control ->
    ../devices/[email protected],700000/[email protected]/[email protected],3062f8:sspctl
    ======================================================================

    You might be able to create it by doing a "boot -r" (reconfigure
    boot) to create the /dev and /devices enries. Once those are there,
    rsc-config should find it.

    It has been a long time since I last needed to do it.
    Ouch! Do you know which version of the OBP you currently are
    running? You can get that either off the OBP screen at the start, or
    from "prtdiag -v | grep OBP"
    Ouch! again.
    O.K. Good Luck
    DoN.
     
    DoN. Nichols, May 13, 2011
    #10
  11. supervinx

    DoN. Nichols Guest

    Great!

    Enjoy,
    DoN.
     
    DoN. Nichols, May 13, 2011
    #11
  12. supervinx

    DoN. Nichols Guest

    O.K. OBP 4.5.21 from one of the photos (60 of 64).

    An 4.16.4 is the last version avaialble.

    BTW photo 15 of 64 shows me that you pulled the system board
    the wrong way (but I've received replacement boards from vendors
    which had also been pulled the wrong way.

    You are supposed to pull three marked screws on the back of the
    system and then pull the system board, *with* the metal frame on the
    underside forward and then lift out. The cage for the CPUs will also
    still be there if it is done properly. Pulling all those screws which
    attach the system board to the frame is really unnecessary. (I think
    that the eBay vendors do it to reduce the shipping weight -- but it
    removes the stiffening which helps the life of the board too.)

    Enjoy,
    DoN.
     
    DoN. Nichols, May 13, 2011
    #12
  13. supervinx

    supervinx Guest

    Il Fri, 13 May 2011 04:28:43 +0000, DoN. Nichols ha scritto:
    I realized it *after* dismounting :)
    Found no service manual about taking it apart, and I removed everything :)
     
    supervinx, May 13, 2011
    #13
  14. Cydrome Leader, May 16, 2011
    #14
  15. I've always like the torque-screwdriver included inside the case of
    that class of Sun gear to make sure you can torque down the CPU card
    just right...

    Not too retro when I have customers running them fully in production here..
     
    Doug McIntyre, May 16, 2011
    #15
  16. We've finally trashed the last of the e220Rs here. Here's what I love
    about this solaris stuff- These decade old machines were running some
    legacy nonsense that must be kept around for years and years. They were
    upgraded from solaris 8 to 10 with no problems, then eventually moved into
    zones on various machines that handle legacy stuff to consolidate what
    used to be multiple tier architectures into single machines (as they don't
    have a workload anymore). Whatever the apps are, they work perfectly and I
    don't see any reason they will ever stop running. Say the base OS was
    linux or windows- this would simply have been impossible to pull off by
    just copying files around and rebooting, across major OS releases and
    various generations of hardware.

    I love to rip on sun at any chance, but their binary compatibility and
    upgrade routes that really work are truly amazing. Hats off to anybody
    involved in making sure all of this stuff works.
     
    Cydrome Leader, May 16, 2011
    #16
  17. supervinx

    DoN. Nichols Guest

    [ ... ]
    Those CPU connectors are rather sensitive -- a *lot* of pins, so
    too little torque and you don't have all the pins engaged. Too much,
    and you crush the connectors, so the torque screwdriver makes sense.
    And they upgraded the screwdriver from the time of the Sun Blade 1000,
    when the screwdriver was a loop of chrome-plated steel wire with one end
    bent down to make the square drive bit, and the other end bent out to
    form a radius, and the torque limit was when the two ends of the loop
    just barely touched. Those *had* to be cheaper to make, and later Sun
    switched to the torque limiting screwdriver -- presumably because of bad
    experience.

    Certainly, if you are getting weird CPU errors, the best bet is
    to pull both CPUs, then re-install CPU 0 first, check it out, then
    re-install CPU 1 and repeat the check-out.

    They also specify the actual torque needed, so if you don't have
    *their* tools, but have a torque limiting interchangeable bit
    screwdriver (I do, even though I also have their tools), you can still
    do it right. Apparently, even later (based on the downloaded manuals)
    they stopped putting the screwdriver in the system case, and instead
    shipped it with a replacement or additional CPU ordered from them --
    presumably more motivation to not buy used CPUs from eBay. :)

    Enjoy,
    DoN.
     
    DoN. Nichols, May 17, 2011
    #17
  18. I've had alot of people comment on what the weird green tube is inside
    the case... I'd imagine that many were chucked as being odd/weird/out
    of place and then later on figured out that they really did need them.

    Put it right in front of people's face for the task at hand and
    they'll figure it out quicker..
     
    Doug McIntyre, May 17, 2011
    #18
  19. supervinx

    DoN. Nichols Guest

    There is the "README" book about how to pull and replace the
    CPUs right on top of the CPU modules in the SF-280R. It is a little
    less obvious on the SB-{1,2}K -- it is stuck to the inside of the side
    panel.

    And add that the jackscrews for the CPUs both have a broad ring
    the same dayglow green, and a Robertson (square) screw slot, so a normal
    screwdriver does not work well and people should get the idea pretty
    quick.

    The wire loop version was in a (similarly green) plastic holder
    which slid into the card cage between the two drives (not enough room
    for that in the SF-280R, of course.)

    Enjoy,
    DoN.
     
    DoN. Nichols, May 19, 2011
    #19
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.