hdiutil "requires that you type your password" - but only from one account

Discussion in 'Apple' started by Timur Tabi, Sep 23, 2006.

  1. Timur Tabi

    Timur Tabi Guest

    I have two admin accounts on my Mac, running OS X 10.3.9. I wrote a
    complex shell script that performs backups every night of the both
    accounts. This script uses hdiutil to create a .dmg file.

    When I run the "hdituil create" command from one of these accounts, it
    works fine. When I run it from the other account, a dialog box appears
    that says "hdiutil requires that you type your password". This is new.
    A couple days ago, hdiutil didn't do this, and now I can't make it

    Obviously, something is different between these two accounts, but I
    can't figure out what. Of course, I did repair permissions, but that
    didn't help.

    So, not only do I not know why one account doesn't work, I also don't
    know why hdiutil would ever need authentication. After all, I'm just
    creating a .dmg file in my home directory.

    Can anyone help me?
    Timur Tabi, Sep 23, 2006
    1. Advertisements

  2. Timur Tabi

    Timur Tabi Guest

    Never mind, I figured it out. hdiutil does this when a file I'm trying
    to archive belongs to another user. I guess I should have read the man
    page for hdiutil more carefully! The fix is to add the option
    Timur Tabi, Sep 23, 2006
    1. Advertisements

  3. Timur Tabi

    Hans Aberg Guest

    Strange: it does not work at all on my computer. :)
    Are you putting the backup in your home directory?
    Scary: can the program give root permissions to anyone?

    Anyway, when backing up /Users/ onto optical media, I found it necessary
    to do it as 'root', in view of the permissions issue.
    Hans Aberg, Sep 23, 2006
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.