HELP! ASUS P6T Deluxe v2 Bios does not detect optical drives, HDD´s

Discussion in 'Asus' started by Viajero, Aug 7, 2010.

  1. Viajero

    Viajero

    Joined:
    Aug 7, 2010
    Messages:
    1
    Likes Received:
    0
    So, I´m a bit of a noob here but I ve tried as much as I could before posting here, including reading many of the posts around. So bear with me and help if you can please.

    New PC to be built with the Asus P6T Deluxe v2, booting it up bios runs fine but does not detect any SATA devices in my system:

    Optical: Plextor PX-B940SA, Sata
    SSD: 2.5" 120GB SATA II vertex turbo series, ocz technologies
    HDD: Western Digital, 2TB, sata, 64 mb cache,
    RAM: Kingston, in the compatibility list and fully detected

    I then tried a Plextor PX-130A which has an IDE conexion and it was detected but that was the end of it. I tried to run the Windows 7 disc with it but since no HDD or SDD are detected I can not install anything.

    In adition, to add insult to injury, no usb flash drives for flashing the bios were detected (although thankfully the keyboard was), so I burned the latest bios version in a CD and flashed the bios from the old plextor 130A which is about teh only thing I have managed to detect...

    I have tried playing with most of the bios options including the SATA and USB ones to no avail... So here I am completely puzzled as I can not do anything with this.

    Any ideas what I am doing wrong or what solutions could there be for this problem? I really hope is something in the Bios and that the mobo is ok...

    Thanks in advance!

    PS: this is my first experience building my own PC and I am really bummed by this. Prior to this P6T mobo I tried a Rampage III and it was faulty (took us 3 days of troubleshooting) so I am getting really depressed... help!
     
    Viajero, Aug 7, 2010
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.