Help! Need Help Please - Reposted with some additions

Discussion in 'Abit' started by M, Sep 19, 2003.

  1. M

    M Guest

    The question is concerning slow/poor/why RAID performance for the IT7Max2v2
    motherboard for a RAID 0+1 array.

    Not intending to spam the NG, but I am reposting in need of some help. I
    have also made a few changes to my original post yesterday.

    So...

    Greetings, all. I have a RAID 0+1 configuration using 4 x 40 GB Maxtor
    6E040L0 drives resulting in an 80 GB stripe + mirror with 16K stripe size.
    BIOS for the motherboard is current version, DF.

    Windows XP w SP1 installed on this drive on first 30 GB of space
    availableand formatted as FAT32. These drives are all the same model and
    size at ATA133 and 2MB buffer each. RAID is configured on the HPT374 with
    cable select and short, round, shielded cables. The motherboard BIOS reports
    v1.23 is the integrated Highpoint BIOS and I am using the version 1.23
    drivers for XP from the Abit web site. I have installed the chipset software
    and all devices report they are working properly.

    The remaining space on the RAID set is partitioned and formatted for data
    storage as 30GB and 20 GB formatted as FAT32.

    As the system is multi-boot with several different configs of XP, I have a
    question about performance. Specifically, the boot time to a useable desktop
    is on the order of 3 to 4 minutes on the above RAID set. Another drive in
    the system, an 80 GB Maxtor used as a single drive boots to the desktop in
    45 seconds with Windows XP same as above.

    Sandra reports 35126 MB/sec for the 80 GB and 41000 MB/sec for the RAID set.
    It would [seem] the performance of the RAID is pretty good, and [should]
    boot as quickly [as the stand alone 80GB drive].

    I have already re-built the RAID set from the first attempt using the
    default stripe size of 64K. Performance has neither improved nor degraded
    from the 64K to the 16K stripe. I have [since] tried the 32K stripe size
    with, again, no real change.

    I ran the BOOTVIS program and optimized boot performance to no improvement.

    Highpoint RAID management software reports all drives healthy, that is, no
    errors in the log.

    1. Does RAID just take longer to boot and stabilize?

    2. Should I make each drive a Master or Slave instead of using the Cable
    Select?

    3. What am I missing in understanding the performance difference?

    4. Any veterans have any hints to offer on improving this boot performance?

    Thanks for all replies.

    Mike
     
    M, Sep 19, 2003
    #1
    1. Advertisements

  2. M

    TomG Guest

    just as a test, have you tried it with the raid array in just a raid 0
    config instead of 0+1?

    --

    Thomas Geery
    Network+ certified

    ftp://geerynet.d2g.com
    ftp://68.98.180.8 Abit Mirror <----- Cable modem IP
    This IP is dynamic so it *could* change!...
    over 115,000 FTP users served!
    ^^^^^^^
     
    TomG, Sep 19, 2003
    #2
    1. Advertisements

  3. M

    M Guest

    Created a RAID 0 only and performance went up, but just a bit.

    I have also tried selecting members of the RAID set choosing <raid
    channel:device> as 0:1, 1:1, 0:2, 1:2 and that did not help.

    An interesting "symptom". There seems to be regular occasions where the HDD
    light is on constantly, that is, the system seems "blocked" for I/O
    activity. System is not responsive; I cannot invoke other programs or
    windows. No interrupts are shared by the Highpoint and other system
    devices. I placed these 40GB devices on the regular IDE chain and ran the
    Maxtor factory re-cert program and all passed with the message "Your drives
    are certified error free". (for what it is worth).

    Next I am going to try NTFS.

    As an aside, I have a BD-7RAID with a pair of drives in RAID 0, and the
    system boots very quickly.

    Any more ideas?

    Mike

     
    M, Sep 21, 2003
    #3
  4. M

    TomG Guest

    wow. something is dogging the performance of those drives or hogging the
    bus. can you test each drive individually to see of one or more are seeing
    different performance from the others?

    how are they jumpered?

    --

    Thomas Geery
    Network+ certified

    ftp://geerynet.d2g.com
    ftp://68.98.180.8 Abit Mirror <----- Cable modem IP
    This IP is dynamic so it *could* change!...
    over 115,000 FTP users served!
    ^^^^^^^




     
    TomG, Sep 21, 2003
    #4
  5. M

    M Guest

    The drives are jumpered as Master and Slave on each channel. Initially,
    they were in Cable Select mode. The manual setting has not improved or
    detracted from performance.

    I will pair them up, two at a time, and perform the installation (what a
    headache time-wise), and see if one pair is "faster", then, isolate a
    potential bad drive.

    Curiously, I had a similar problem, too, on an older Maxtor that caused a
    long-boot time, but was not totally failed and that hint reminded me.

    Thanks, and I will report back when I know more.

    Mike

     
    M, Sep 21, 2003
    #5
  6. M

    TomG Guest

    you tried cable select with them on their own controllers - one on one ide
    channel and one on another?

    --

    Thomas Geery
    Network+ certified

    ftp://geerynet.d2g.com
    ftp://68.98.180.8 Abit Mirror <----- Cable modem IP
    This IP is dynamic so it *could* change!...
    over 115,000 FTP users served!
    ^^^^^^^




     
    TomG, Sep 21, 2003
    #6
  7. M

    M Guest

    Been doing much detective work. Short story is:

    Drives have been both CS and M/S jumpered - no effect

    Tried both NTFS and FAT32 partitions - no effect

    Very curious discovery. When I boot the system and open the Highpoint RAID
    management software from the system tray, and then double-click each of the
    drives, they all report ATA/133. After I run Sandra 2003 9.73 (free), and
    then return to the Highpoint software, the drives on Controller 1, Channel
    1, Master and Controller 1, Channel 1, Slave report ATA/100?!?!? Moving the
    drives, as pairs, will yield same result. Have used different ATA/133
    cables, reseated, etc. Is it possible the Controller 1, Channel 1 from
    above is falling "back" to ATA/100 for some reason attributable to the
    chipset? Could I have an intermittent condition, headed towards failure,
    RAID controller chipset? All too much wasted time, but interesting all the
    same.

    Comments?

    Mike

     
    M, Sep 23, 2003
    #7
  8. M

    TomG Guest

    any errors being logged in Event Viewer? I have seen drives that were
    declaring parity or other data integrity errors cause the OS to
    auto-downshift to a lower transfer setting to attempt to correct the errors.
    faults were being logged in event viewer in that situation and it turned out
    to be a bad cable.

    --

    Thomas Geery
    Network+ certified

    ftp://geerynet.d2g.com
    ftp://68.98.180.8 Abit Mirror <----- Cable modem IP
    This IP is dynamic so it *could* change!...
    over 115,000 FTP users served!
    ^^^^^^^




     
    TomG, Sep 24, 2003
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.