Help: System lost DVI video on bootup (post) and linux console

Discussion in 'Tyan' started by Mannr@uwaterloo.ca, Apr 16, 2004.

  1. Guest

    I recently had a system crash, probably due to flakey power.

    Anyway, since then my system is fine, but it won't work properly on DVI output.
    Something strange happened and I can't diagnose the problem!

    Originally I had a single cable from the video card (ATI Radeon 7500) to the
    DVI connection on my monitor (Samsung 191T). It worked fine before, from boot
    ("post"), to Linux console mode, to X. I am running a Tyan S2469 motherboard
    with 1.07 bios. Software is Linux, Debian "testing", XFree 4.3.0.

    Now booting ("post") or linux console messages only show up on VGA. Behaviour
    in X is unpredictable. On certain monitors (Viewsonic VG181) it detects the
    DVI connection fine. That is, if both VGA and DVI are connected, it switches
    to DVI as expected. But on other monitors (the Samsung 191T) it won't go into
    DVI. When I looked at the logfile for X it reports two monitors, but both are
    analog.

    I've tried lots of stuff, changing the video card, the monitors, the cable,
    etc. I also tried clearing CMOS and re-flashing the bios. Nothing helped.

    Does anyone know what could cause this type of problem? Someone suggested
    that the SMBus/I2C on the motherboard could be hosed. Is there a way to
    diagnose this kind of problem? I do lot of hardware stuff, but this one has
    me stumped!

    Thanks,
    Richard
     
    , Apr 16, 2004
    #1
    1. Advertisements

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Similar Threads
  1. Yousuf Khan

    Linux, AMD64, and 3D console games

    Yousuf Khan, Oct 6, 2003, in forum: Intel
    Replies:
    56
    Views:
    1,827
    wogston
    Oct 29, 2003
  2. Frank

    DVI, DVI-D, DVI-I

    Frank, Nov 5, 2003, in forum: ATI
    Replies:
    2
    Views:
    578
    Frank
    Nov 6, 2003
  3. Martin Crozier
    Replies:
    2
    Views:
    717
    Kent_Diego
    Jan 13, 2004
  4. zion_curtain
    Replies:
    2
    Views:
    448
    zion_curtain
    Aug 10, 2005
  5. Phil Tomaskovic
    Replies:
    2
    Views:
    374
    Phil Tomaskovic
    Mar 24, 2007
  6. ***** charles
    Replies:
    2
    Views:
    1,024
    ***** charles
    Apr 26, 2007
  7. Ant
    Replies:
    9
    Views:
    1,405
  8. hrh1818
    Replies:
    3
    Views:
    1,150
    hrh1818
    Aug 28, 2012
Loading...