HELP Upper Memory Area is gone in my prosignia 300

Discussion in 'Compaq' started by Mario, Feb 6, 2004.

  1. Mario

    Mario Guest

    I've bought a prosignia 300 from a friend. The prosignia has 16 Mb intern
    memory. I will use it for a linux router. First I install DOS on it. When I
    type the dos command MEM I see:

    Conventional: 638k
    Upper: 0
    Reservation: 0
    Extended (XMS): 15,360k

    Where's my Upper memory? Must I change something in the Bios. When I look
    with mem/c I see that is nothing in the upper, there is no upper. What can
    be the problem?

    Mario
     
    Mario, Feb 6, 2004
    #1
    1. Advertisements

  2. Mario

    HH Guest

    Do you have HIMEM.SYS loading in CONFIG.SYS?
    HH
     
    HH, Feb 6, 2004
    #2
    1. Advertisements

  3. Mario

    Mario Guest

    Yes, but this is for the higher mem above 1 Mb. The upper is above 640k
    convential and about 360k. I don't think I need Himem.sys to execute a
    LOADHIGH?
     
    Mario, Feb 6, 2004
    #3
  4. Mario

    HH Guest

    Nope, you need it to create upper memory. EMM386.EXE is for extended memory
    above 1024 K.

    HH
     
    HH, Feb 7, 2004
    #4
  5. You have your functions reversed. HIMEM.SYS is an extended memory
    manager and also handles the first 64 kilobytes minus 16 bytes of
    memory above 1024 kilobytes. EMM386.EXE is an expanded memory
    emulator and also handles the upper memory area above 640 kilobytes
    by remapping extended memory into that area. Without HIMEM.SYS,
    EMM386.EXE has no upper memory to manage because extended memory
    will not be recognized
     
    Earl F. Parrish, Feb 7, 2004
    #5
  6. Mario

    Mario Guest

    Yes I understand, it's not the problem with the memory managers. I first
    load himem and then emm386.

    I think it's an other problem: The bios, videocard.... etc. uses upper
    memory. When I switch the S6 switch on the mainbord (Invaldidates non
    volatile RAM and configuration is cleared), I see 150k upper memory. Now
    when I restart again I must load with the system configurations floppy's the
    bios again because the memory is cleared. The BIOS information is stored in
    the upper memory.

    Computers alway uses this memory, but there is alway al little we can use to
    load TSR's..... With the prosignia the whole upper is used. How can I
    resolved this problem, I must have some UMA because I need some more
    Conventiol memory.

    Best Regards Mario the pizzaman.
     
    Mario, Feb 7, 2004
    #6
  7. Mario

    HH Guest

    Duh....They say memory is the second thing to go and I forget what the first
    is.
    HH
     
    HH, Feb 7, 2004
    #7
  8. Mario

    Mario Guest

    Ok, but is it possible to get more Upper memory or is this not possible with
    a compaq?



     
    Mario, Feb 7, 2004
    #8
  9.  
    Earl F. Parrish, Feb 7, 2004
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.