HELP: Very slow memory throughput with new KD7

Discussion in 'Abit' started by Timothy Miller, Jul 16, 2003.

  1. I recently bought a KD7, and I'm having a few problems with it. I
    hope you can please help me with them.

    According to the BIOS screen, the board model I have is
    KT400-8235-6A6LYA1AC-DN. I have an Athlon XP 2800+ (barton core,
    333mhz fsb) with 1 GIG of PC2700 DDR. The board has AwardBIOS.

    The Corsair memory I'm using turns out to be from SpecTek, which uses
    Micron silicon. I called SpecTek to get a datasheet, and they
    directed me to the data sheet for Micron MT46V64M4TG-6T.

    I use the following settings for memory:

    CAS latency: 2.5
    Bank Interleave: 4
    Trp: 3T
    Tras: 7T
    Trcd: 3T
    Drive strength and controls are all Auto
    DRAM Access: 3T
    Enhance DRAM Performance: Disabled
    DRAM Command Rate: 1T
    Write Recovery Time: 3T
    tWTR: 1T

    The first problem that I encountered was that I seem to be getting
    unusually low memory throughput. Using "memtest86", I get 665mb/sec.
    Using STREAM under Linux, I get closer to 1040 mb/sec peak. Doing
    some searches on google has revealed that most people get closer to
    their peak bandwidth, so, I should be expecting at least 2400 from
    STREAM, judging from the numbers others are getting. I know in the
    real world, you never get peak, but in synthetic tests, I should not
    be getting half the rated bandwidth.

    If you could please help me to figure out what is slowing things down,
    I would appreciate it very much.

    When working to determine what might be amiss, I decided to flash the
    latest BIOS. After following the directions exactly, I went into the
    BIOS settings and restored all of the settings to what they had been
    before I flashed the BIOS. The machine would not POST. After some
    tinkering, it seems to be "Fast CPU command decode" which causes the
    machine to not POST. (This is the case, even if it's the only setting
    I change, with everything else being default values.) This setting
    worked before, so what changed to break it? Should "fast command
    decode" not work with my system?

    Thank you.
     
    Timothy Miller, Jul 16, 2003
    #1
    1. Advertisements

  2. Timothy Miller

    - HAL9000 Guest

    - HAL9000, Jul 17, 2003
    #2
    1. Advertisements

  3. Timothy Miller

    David Guest

    If your system allows it, try the following settings at 166 MHz:

    CAS latency: 2
    Bank Interleave: 4
    Trp: 2T
    Tras: 6T
    Trcd: 2T
    Drive strength and controls - Set to HIGH instead of Auto on all banks
    if unstable with above settings
    DRAM Access: 2T
    Enhance DRAM Performance: Disabled
    DRAM Command Rate: 1T
    Write Recovery Time: 3T
    tWTR: 1T
     
    David, Jul 18, 2003
    #3
  4. Timothy Miller

    - HAL9000 Guest

    Oh yea, reference your earlier question. Seems like someone said fast
    command decode only works when the FSB is 100. May want to do google
    search if you want more info.

    http://groups.google.com/groups?hl=en&lr=&ie=UTF-8&group=alt.comp.periphs.mainboard.abit

    You were talking about ram clock and not fsb clock, right?

    Here is a far fetched one... Is there any chance you have upgraded
    the bios and then not reset it afterwards?

    Forrest

    Motherboard Help By HAL web site:
    http://home.attbi.com/~hal-9000/
     
    - HAL9000, Jul 18, 2003
    #4
  5. I have the datasheet on the RAM chips, and your changes (CAS, Trp,
    Tras, Trcd) would be running it out of spec. But I'm sure you know
    this. In any event, according to this article, making those changes
    won't affect it much, and CERTAINLY won't increase throughput by a
    factor of two:

    http://www.techwarelabs.com/reviews/memory/memory_timings/index.shtml

    According to the article:
    "The memory timings on our particular setup that had the most impact
    on performance involved setting the Bank Interleave to 4 Way,
    decreasing the DRAM command rate to 1T, and decreasing tRCD to 1T
    [sic, they mean 2T]."

    I think maybe I'll try your suggestion anyhow.

    Drive strength will affect signals between the northbridge and the
    RAMs, but it isn't going to do anything about instability due to
    running RAMs out of spec. In this case, we're dealing simply with
    signal delays inside of a chip. One way to deal with THAT is to
    increase the supply voltage, but I'm not sure if I want to do that.

    My situation is this: I want a stable system. I could see a few
    percent drop in performance due to some conservative settings, but I
    they surely would not cut the performance in half.

    Thanks.
     
    Timothy Miller, Jul 18, 2003
    #5
  6. Will do, thank you.
    Both, actually. Both are set to 166. The BIOS recognizes my CPU as
    an Athlon XP, so I simply told it that I had a "2800+(333)".
    Additionally, in the memory settings, I have told it manually that the
    clock is 166mhz.
    I did reset it. And since setting "fast command decode" caused the
    system to not POST, I have reset it more than once. You're talking
    about moving that little CCMOS jumper next to the battery over,
    leaving it for 1 minute, then putting it back, right?



    Thanks!
     
    Timothy Miller, Jul 18, 2003
    #6
  7. I tried your suggestion. memtest86 performance went up from around
    650 to 725. STREAM performance went up by about 100 megs/sec.

    I'm still nowhere near where I'd expect to be.

    I lothe to do this, but I do have a spare disk lying around. I could
    install Windows and run SANDRA. It may be that it does a better job,
    or it may be that it inflates scores.
     
    Timothy Miller, Jul 18, 2003
    #7
  8. Timothy Miller

    - HAL9000 Guest

    That's the one. Of course the computer needs to be unplugged while
    your doing this.

    Forrest

    Motherboard Help By HAL web site:
    http://home.attbi.com/~hal-9000/


    On 18 Jul 2003 07:58:55 -0700, (Timothy Miller)
    wrote:
     
    - HAL9000, Jul 19, 2003
    #8
  9. Timothy Miller

    John TL Lee Guest

    Make sure you clear your CMOS after you flash yer bios.
     
    John TL Lee, Aug 13, 2003
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.