1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

hi-speed usb device attached to non-Hi-Speed hub error connecting IPod to T40

Discussion in 'Laptops' started by n0sferatu, Dec 2, 2004.

  1. n0sferatu

    n0sferatu Guest


    When I connect my IPod (latest gen) to my Thinkpad T40 (which I KNOW
    USB2.0 ports) (running Win 2003), I get the above message.

    When I look at Device Manager and list connections by type, I see many
    Hubs, and one USB Enhanced 2.0 Hub; the IPod is connected to one of the

    other ones.

    When I called IBM, they had me install a chipset driver. That didn't do


    Then I uninstalled all the hubs other than the USB2.0, and my IPod
    up on USB2.0 on the next connect, but my external mouse (which also is
    one of the other hubs) disappeared.

    My questions:
    1. How can I make my IPod always show up on the USB2.0 hub?
    2. If this laptop's ports are supposed to be USB2.0, why would devices
    show up on some USB1.1 hub anyway?

    n0sferatu, Dec 2, 2004
    1. Advertisements

  2. n0sferatu

    Doug Ellice Guest

    I think this might be Windows lying to us.

    I have a similar problem. I connected a no-name powered USB hub to my
    Dell desktop. I constantly get pop-up messages announcing that this
    USB-2 device would work faster if it were connected to a high-speed port.

    My computer doesn't have any USB-1 ports, I don't think.

    When I click on the pop-up balloon, as invited, for more info, I also
    see a chart listing many USB ports. Like yours, only one of my 8 is
    listed as high-speed.

    I'm convinced this is a Windows XP problem of some sort, and I ignore it.

    Does your iPod work O.K. when you connect it, despite the pop-up "error"

    Doug Ellice, Dec 3, 2004
    1. Advertisements

  3. Yes it does.
    The OHCI (USB1) ports are listed first (usually 2 ports to a root hub)

    The EHCI (USB 2) port is the last one (usually as many ports as all the
    above together.)
    Is this no-name hub of which you speak a true USB2 hub? Unfortunately,
    because the USB2 specification contains an ambiguity, hub, peripheral and
    motherboard manufacturers are able to sell devices as USB2 devices but that
    do not support the 480 Mbps high speed mode.

    Some devices are occasionally encountered which require a USB2 specific
    driver to be loaded otherwise they default to USB1. I have no knowledge if
    the iPod is one of these devices.

    This effect can also be seen if the USB cable that you use is not up to
    performing at USB2 speeds (or is too long). This could also be true of a
    true USB2 hub that has marginal performance. If the data is sufficiently
    corrupt, the USB system down trains to USB1 speeds.

    I have also encountered the occasional device that works in one port, but
    not in another. Try plugging into a different port.


    Electrik Fan Club, Dec 3, 2004
  4. n0sferatu

    Newscene Guest

    I started having this problem using a USB 2.0 Hard Drive intermittantly back
    in August. At first it would happen occasioanlly, then more often until
    finally it happened every time

    I tried all sorts of things and IBM tech support directed me to download and
    install a Thinkpad specific update for Windows XP even though I already had
    the IBM factory installed Windows XP --- they said try it, it can't hurt.

    Back in October my battery charging circuit in the T40 fried itself and the
    unit had to go in for a new systemboard. Since it came back I have not had
    the USB problem again {knock on wood}.

    I suggest that you report this to IBM and see if you can't get them to
    replace the systemboard.

    Newscene, Dec 3, 2004
  5. n0sferatu

    n0sferatu Guest

    The IPod works, but it works at USB1.1 speeds, which is useless because
    it takes eons to transfer a few songs.
    n0sferatu, Dec 6, 2004
  6. n0sferatu

    n0sferatu Guest

    Oh crap. I hope this isn't it, it will be a pain in the ass to convince

    Right now, they're telling me they can't help because I am running
    Windows 2003, which is not what they supplied me with.

    n0sferatu, Dec 6, 2004
  7. Windows 2003 is a server OS. Since it comes out of the box with USB 2.0
    support, my guess is you might have to enable the high speed interface.
    Check your error logs, those will more than likely point you too the
    problem. Server 2003 might not have detected your USB ports properly either,
    something to check on. You should see in your device manager, under
    Universal Serial Bus Controllers something listed as a USB 2.0 enhanced Host
    Controller. Hopefully I have given you a couple of avenues to check out.

    Angry American, Dec 6, 2004
  8. n0sferatu

    n0sferatu Guest

    Angry Dan

    I see the USB2.0 Enhanced Host controller in my Device Manager. The
    IPod somehow always connects to the other ones, which seem to not be

    How do you enable hi speed interface?

    n0sferatu, Dec 6, 2004
  9. IF you see it in your Device Manager, then it is there. Check your error
    logs, see if the system is throwing up an error when you plug in the IPod.
    Panel, then Administrative tools/Computer Management. Look Under the event
    viewer, and read your logs.

    Angry American, Dec 6, 2004
  10. n0sferatu

    Song Li Guest

    I have a TP41, and the USB2.0 ports worked correctly for a year, then
    stopped working properly a couple months ago. I'm not sure if it was XP
    service pack 2, or a BIOS or chipset update. I uninstalled SP2, and still
    have the problem. Tried removing all the USB drivers and re-installing, but
    still have problems. Sometimes devices aren't recognized, other times
    they're recognized, but the TP thinks it has 1.1 ports instead of 2.0.

    I think we may be out of luck until IBM and/or Microsoft figure this out.
    Did you update the BIOS or chipset firmware recently?
    Song Li, Dec 6, 2004
  11. n0sferatu

    n0sferatu Guest

    Someone else had this machine before with Win2k, but they never tried
    USB2.0 devices. I'm running Win2003, IBM won't support it beyond asking
    me to update to the latest chipset driver (which I did).

    I ran the latest embedded controller update, and also tried the latest
    bios update.

    n0sferatu, Dec 6, 2004
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.