Hideous PowerBook G3 woes

Discussion in 'Apple' started by Richard Burke, Nov 6, 2003.

  1. What could cause the ethernet port to spontaneously stop working? Why
    would the PCMCIA pot accept a wireless card (in only one of the two
    slots, mind) three times, and then refuse to even let it click into
    place?

    This is a PowerBook G3, 233 MHz, old, I admit (1997) - but still working
    perfectly. Until 3 days ago. It hasn't been dropped or damaged in the
    last 2 years. I've reinstalled the system (OS 8.5) and it's made no
    difference.

    I need to network =this machine with my Cube. I swap files constantly.
    Ethernet and wireless are the only two ways to go. But both ports seem to
    have jammed themselves especially to make my working day a stressful
    experience.

    The PCMCIA port thingy is particularly weird, because I tried the slot
    for the first time since buying the machine all those years ago *today*
    - worked 3 times, then nothing. Ethernet, I started using maybe a year
    ago. Three days ago, nothing, just a stupid message telling me to check
    my connections, which are fine.

    Am I missing something, or is this just Murphy's law, and an old machine?
    This is all losing me *so* much time...

    TIA,

    Richard
     
    Richard Burke, Nov 6, 2003
    #1
    1. Advertisements

  2. Richard Burke

    simples_it Guest

    For the ethernet, check all the settings are correct. Then check that
    the actual cable is not broken, by swapping it with a known good one.

    With the card slot, most likely some of the pins have been bent - this
    happened to me. You have to be very carefull when bending them back, so
    as not to break them.

    Rob.
     
    simples_it, Nov 6, 2003
    #2
    1. Advertisements

  3. Plus, the ejection mechanism is not the best designed. I had mine replaced
    3 times when I had a Wallstreet. It's not surprising that Apple replaced it
    with the push-in push-out lever in the following model, the Lombard...

    -Laurent.
    --
    =================================================================
    Laurent Daudelin Logiciels Nemesys Software
    mailto: <http://nemesys.dyndns.org>
    Replace ihatespam with verizon to reply
    +++++++++++ Sent using an Apple Newton MessagePad 2100 ++++++++++
     
    Laurent Daudelin, Nov 8, 2003
    #3
  4. Richard Burke

    Clark Martin Guest



    Try doing a full shutdown. If that doesn't help then try reseting the
    power manager. It's possible the power control to the card cage and
    Ethernet are messed up.
     
    Clark Martin, Nov 11, 2003
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.