High CPU Useage When Transfering Data from Liteon 166s on Abit IC7-G, 2.8 P4

Discussion in 'Abit' started by William.R.Reisen, Jan 11, 2004.

  1. Are these High CPU usage values typical when reading from dvd-rom
    drives normal? Can they be reduced?

    When I am transferring data in Windows Explorer from a DVD-R in the
    Liteon 16x 166s DVD-ROM drive when its plugged into the Abit IC7-G
    motherboard it uses 100% of the CPU power of a 2.8Ghz P4 to do this .
    When looking at the Windows Task Manager this 99% of the CPU usage is
    taken up by "System Idle Process".


    When transferring data from my Pioneer 105 Drive in the same way the
    CPU usage is at 72% and the System Idle Process is the taking 99% of
    CPU usage in Windows Task Manager.

    When copying between two Western Digital 80Gb Caviar Hard-drives the
    CPU usage is only about 15%

    I have Windows 2000, 1Gb of RAM.
     
    William.R.Reisen, Jan 11, 2004
    #1
    1. Advertisements

  2. William.R.Reisen

    Theo Guest

    (William.R.Reisen) wrote in
    just a suggestion, check to see if "DMA if available" is set on all of your
    drives. If they are already set to that, see if they are in fact operating
    as such. It wil say DMA, Ultra DMA, or PIO.

    device manager->IDE ATA controllers-> properties
     
    Theo, Jan 11, 2004
    #2
    1. Advertisements

  3. William.R.Reisen

    TomG Guest

    I'm confused... how can system idle processes be at 99 percent but CPU use
    be at 100%. I have never seen that combination, myself. is the IDE channel
    set to UDMA if possible and if so, what mode is the channel actually running
    in?

    --

    Thomas Geery
    Network+ certified

    ftp://geerynet.d2g.com
    ftp://68.98.180.8 Abit Mirror <----- Cable modem IP
    This IP is dynamic so it *could* change!...
    over 120,000 FTP users served!
    ^^^^^^^
     
    TomG, Jan 11, 2004
    #3
  4. Check Device Manager for the drive's IDE channel and make sure DMA is
    enabled.
     
    Robert Hancock, Jan 12, 2004
    #4
  5. Thanks set transfer mode to DMA if available on the Secondary IDE
    Channel advanced settings in Device manager.
     
    William.R.Reisen, Jan 13, 2004
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.