Highpoint Errors on BE7 Raid

Discussion in 'Abit' started by Marcus, Aug 13, 2003.

  1. Marcus

    KJ Guest

    Wrong. RAID 5 is different. What you described is RAID 0+1 (also called
    RAID 10).
     
    KJ, Aug 14, 2003
    #21
    1. Advertisements

  2. Marcus

    Jerry Polyak Guest

    I stand corrected. I thought it was something like that, but wasn't
    absolutely sure.

    All I have is an ST6R and I know it does not support RAID 5, just RAID 0+1.
    Have you checked to see if the RAID board / drivers indeed support RAID 5?


    | Wrong. RAID 5 is different. What you described is RAID 0+1 (also called
    | RAID 10).
    |
    |
    |
    | | > If I remember correctly Raid5 is the same as Raid0+1. If that is the
    | case,
    | > I would suspect that you need four drives to make it work.
    | > I could be wrong, but it's worth looking into.
    | >
    | >
    | > | > | My problem with the Highpoint RocketRAID 1640 (HPT374 chipset):
    | > |
    | > | I am trying to install the OS (tried both Windows 2000 and XP) on a
    | 3-disk
    | > | RAID 5 array with no other IDE hard drives installed with both
    matching
    | > | driver/BIOS versions (have tried both versions 2.01 & 2.02). I was
    | unable
    | > | to utilize RAID 0 configurations as well, but can use single drive
    modes
    | > | just fine. I have changed cables, power supplies, and other variables
    | > with
    | > | no improvement over this RAID 5 obstacle, and the use of RAID 5 is the
    | > very
    | > | reason I bought this card!
    | > |
    | > | I have just run Western Digital's latest diagnostics software on each
    | > drive.
    | > | Both the quick and extended tests pass with no errors for each drive,
    | but
    | > | errors are always present when I try to do a low-level format, there
    | > appears
    | > | to be a IRQ timeout error. The IRQ for the controller card is NOT
    | shared
    | > | with any other device and the system normally handles IRQ's properly
    for
    | > | everything but this controller card (and I have changed the IRQ to oth
    er
    | > | unused IRQs with no improvement).
    | > |
    | > | HDDs: 3 x 36GB WD 10,000 rpm Raptor SATA drives
    | > | (http://www.westerndigital.com/en/products/WD360GD.asp#spec)
    | > | Abit IS7-G motherboard (tried several very conservative BIOS
    | > configurations,
    | > | and different PCI slots to no avail) latest BIOS
    | > | 2 x 512 MB PC3200 Corsair XMS LL memory
    | > | Intel P4 3.0C
    | > | Lite-On DVD/CDRW drive master on IDE channel 1 (no other IDE drives of
    | any
    | > | type)
    | > |
    | > | Memtest86 (www.memtest86.com) has run several detailed iterations and
    | > there
    | > | are NO CPU/memory errors.
    | > |
    | > | Is there a known incompatibility with these drives?
    | > |
    | > | Thanks for any help or suggestions.
    | >
    | >
    | >
    |
    |
     
    Jerry Polyak, Aug 14, 2003
    #22
    1. Advertisements

  3. Marcus

    KJ Guest

    KJ, Aug 15, 2003
    #23
  4. Marcus

    TomG Guest

    no good ideas from me. almost sounds like a flaw in the way the disk
    management utility attempts to utilize the array through the drivers or
    something...

    --

    Thomas Geery
    Network+ certified

    ftp://geerynet.d2g.com
    ftp://68.98.180.8 Abit Mirror <----- Cable modem IP
    This IP is dynamic so it *could* change!...
    over 115,000 FTP users served!
    ^^^^^^^
     
    TomG, Aug 15, 2003
    #24
  5. Marcus

    TomG Guest

    I'm with you that it would appear to be a driver/bios issue with the
    Highpoint controller. I have never used that controller and you are the
    first poster I have seen here in this group using it so I am out of ideas.
    maybe Highpoint might respond to a query?

    --

    Thomas Geery
    Network+ certified

    ftp://geerynet.d2g.com
    ftp://68.98.180.8 Abit Mirror <----- Cable modem IP
    This IP is dynamic so it *could* change!...
    over 115,000 FTP users served!
    ^^^^^^^
     
    TomG, Aug 15, 2003
    #25
  6. Marcus

    KJ Guest

    Just got this reply from Highpoint support:

    Hello,

    Thanks for your contacting us!
    You can try set the device mode at ATA133 or ATA100 temp, then
    re-set back it to ATA150.
    Set it in BIOS->Setting->Device.

    Regards,
    HighPoint Technologies Inc.

    I have tried this a few days ago as ATA133 with no luck, and I'm in the
    process of recreating the RAID 5 in ATA100 now. Will let you all know how
    this works.
     
    KJ, Aug 15, 2003
    #26
  7. Marcus

    KJ Guest

    For anyone still following this thread, RAID 5 SUCCESS!

    I was REQUIRED to slow down to ATA100 for the initial OS install, even
    ATA133 was too fastl. Works like a champ now!

    Built as a budget small business server (4 machines now, but fantastic
    growth), this setup is even impressing me with it's speed running Windoze 2k
    AdvSvr.
     
    KJ, Aug 15, 2003
    #27
  8. Marcus

    TomG Guest

    good luck with it...

    --

    Thomas Geery
    Network+ certified

    ftp://geerynet.d2g.com
    ftp://68.98.180.8 Abit Mirror <----- Cable modem IP
    This IP is dynamic so it *could* change!...
    over 115,000 FTP users served!
    ^^^^^^^
     
    TomG, Aug 15, 2003
    #28
  9. Marcus

    TomG Guest

    cool! glad you got it going!

    --

    Thomas Geery
    Network+ certified

    ftp://geerynet.d2g.com
    ftp://68.98.180.8 Abit Mirror <----- Cable modem IP
    This IP is dynamic so it *could* change!...
    over 115,000 FTP users served!
    ^^^^^^^
     
    TomG, Aug 15, 2003
    #29
  10. Marcus

    Marcus Guest

    Hello Tom,

    I have downloaded the DP Bios with the Highpoint 2.34 BIOS and installed it,
    so we'll have to wait and see.

    I have been dealing with Western Digital with my problems for the last few
    months and they have now advised me to buy a Promise TX 2 controller card.
    If my problems continue I will buy one as I at my Wits end on these problems
    (I will install my drive on IDE 1 to confirm the Highpoint is the problem).

    I'm had a very quick look at the specs on the card and it says that it
    supports the 66Mhz PCI slot, I've had a look in my Abit manual and it does
    say what speed the PCI slots work at, would you know the answer ??, I assume
    they are backwards compatible if my PCI slots run at 33Mhz.

    Thanks for your help Tom,

    Marcus
     
    Marcus, Aug 16, 2003
    #30
  11. Marcus

    TomG Guest

    I am confused by the statement that the card supports the 66 Mhz PCI slot
    since all I know about is a 33 Mhz PCI bus standard. The AGP bus is the
    only thing that I know of that is at 66 Mhz besides old CPU busses. in any
    event, I'm sure it will work fine in the PCI bus that you have on that
    board...

    --

    Thomas Geery
    Network+ certified

    ftp://geerynet.d2g.com
    ftp://68.98.180.8 Abit Mirror <----- Cable modem IP
    This IP is dynamic so it *could* change!...
    over 115,000 FTP users served!
    ^^^^^^^
     
    TomG, Aug 16, 2003
    #31
  12. Marcus

    Marcus Guest

    Could an add on PCI hard disk controller be as quick as the built in
    Highpoint controller.

    My PC has been OK for the last few days but sometimes it will perfectly OK
    for a week then play up every day for a few days.

    Marcus
     
    Marcus, Aug 16, 2003
    #32
  13. Marcus

    Tony Scott Guest

    Glad you have it working.
    If I had been watching the tread earlier, I would have suggested that you
    tried ATA100.

    I have an IT7Max2v2 with highpoint 374 integrated on Motherboard. I tried
    RAID 0, 0/1 and 5, but always ended up with these timeout errors..
    I *never* managed to get rid of them until I turned the drive option down to
    ATA100. Bingo!

    So I have ended up running for 6 months error-less at ATA100. I suspect that
    there may be other users out there experiencing the errors, but never
    looking at their logs. The only visible effect that multiple errors had on
    me was a processing 'pause' of several seconds, a log entry and when using
    RAID 0/1 or RAID 5 the occasional need to rebuild the array. Under RAID 0,
    you simply get dataerrors on your HDDs, no doubt!

    The only slight improvement I managed was to use short, screened ATA cables
    to the drives, but never managed to completely eliminate the timeouts.
    Highpoint have to look at their ATA bus timing parameters, I think!

    Tony
     
    Tony Scott, Aug 19, 2003
    #33
  14. Marcus

    Marcus Guest

    Hello Tony,

    I started this thread off, I am still getting the odd Highpoint error.

    It normally happens on a cold boot, I get a delay just before Windows boots
    into the desktop or sometimes in the middle of loading my system tray Apps.
    It will clear after 30-120 seconds (sometimes less), it will also happen
    after I reboot just after the cold boot, when it clears it will perfectly OK
    until the next cold boot, sometimes it will be OK for a week before it plays
    up.

    My Windows XP Pro install is new with all updates applied, I have just been
    sent the 2.4 version of the Highpoint BIOS and Driver which Tom G kindly put
    into a Abit BIOS for me which I installed last night.

    This morning I got a slight delay in booting and the error only appeared 3
    times in the event viewer so maybe it's much better but time will tell.

    I'm not using my drive in a Raid array but it is on IDE 3, the drive is a
    Western Digital 120GB 8Mb cache version which is ATA100.

    Highpoint and Abit are not interested, if I can't solve this then I might
    buy a promise controller card and this will be my last Abit board if it
    comes to that, shame really as Abit make good products but there technical
    support is non exisisant.

    I have wrote to them loads of times with a full description of the problem
    with pictures etc and I normally get a reply with a few words if I'm lucky.

    Can you offer me any advise.

    Thanks

    Marcus
     
    Marcus, Aug 19, 2003
    #34
  15. Marcus

    Marcus Guest

    Hello Again Tony,

    I've found your thread on the ABit Forums, it looks like I'm not the only
    one with these problems, looks like I'm gonna have to wait until ABit
    release a fix (if they ever do)

    Thanks

    Marcus
     
    Marcus, Aug 19, 2003
    #35
  16. Marcus

    Tony Scott Guest

    The outcome of the theads on highpoint errors was that i remained on ATA100.
    Several posters advised me that ATA 133 wpould provide a marginal (if at
    all) improvement over ATA 100.
    Actually, I like to push performance if possible and the outcome was
    somewhat unsatisfactory!

    I am now overclocking (slightly) with no timeout errors in the logs since I
    last cleared them (4th April 2003). So that's good isn't it? My config is
    now RAID 0/1 and I recovered successfully from a single hardware HDD drive
    failure a few months ago with minimal disruption.

    Like you , I am awaiting a fix. I am convinced that Highpoint ATA bus
    timings are dodgy and I don't hold out much hope. I do think that the rate
    at which you are suffering errors is too high. Without the error checking of
    RAID - how do you know that you are not getting data errors on the drives
    which are presently going unnoticed?

    Have you tried screened cables? I found a marginal improvement. Also I
    noticed an improvement when I powered each HDD from a separate power cable
    from the PSU and made sure there were no other drives on the same power
    cable. Finally, I made really sure that the drives were grounded securely to
    the chassis of the computer, using 'star' washers which bite into the
    metalwork providing secure grounding.

    Like you I got nowhere with ABIT support. They were much more orientated
    around their own range of controllers than the embedded chip solution from
    motherboard manufacturers. I got the 'did you use the latest BIOS?'
    suggestion also. It wasn't a lot of use explaining that one is at the whim
    of the Motherboard manufacturer to release an updated BIOS - or use a
    non-approved release of the BIOS provided by a kind developer outside ABIT.

    I almost got to the point of getting a Promise board, but I suspect you will
    need to re-install the O/S from scratch if you go that route.

    Running out of further suggestions............

    Tony
     
    Tony Scott, Aug 19, 2003
    #36
  17. Marcus

    Tony Scott Guest

    For Promise controllers take a look at thread "Problem with Maxtor
    harddrives and Promise Fasttrack 100" in comp.sys.ibm.pc.hardware.storage
    This poster has a ATA133 /ATA100 issue too!!

    Tony
     
    Tony Scott, Aug 19, 2003
    #37
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.