How did I create this startup item?

Discussion in 'Apple' started by Kurt Tappe, Nov 2, 2004.

  1. Kurt Tappe

    Kurt Tappe Guest

    Early this year I did something to my installation of Panther to make
    it always open Internet Connect utility on boot. It is NOT in System
    Preferences->Accounts->Startup Items. I added it to some Unix file
    somewhere using Terminal...I just can't recall which one.

    I've poked around in /System/Library/StartupItems and in /Library but
    don't see what I did. It can't be something in /Users because
    Internet Connect gets launched for any user who logs in, not just me.

    Thanks for any reminders on what it was I did,
    -Kurt
     
    Kurt Tappe, Nov 2, 2004
    #1
    1. Advertisements

  2. Kurt Tappe

    respower Guest

    Right, those "startup" items actually run at login, not at system
    startup (boot time). A rare bad-naming decision on Apple's part.

    Somewhere under /etc/mach_init.d/ maybe? Those items run at boot
    time. You can also configure a crontab entry to run at boot time,
    with the '@reboot' tag.

    You shouldn't be messing with /System/Library/StartupItems and I doubt
    anyone would have suggested to you that you do. If you add your own
    StartupItems they should go in /Library/StartupItems. Those do run at
    boot time. But sounds like you're not seeing anything there.


    You're sure you did this by editing a text file?
     
    respower, Nov 2, 2004
    #2
    1. Advertisements

  3. Kurt Tappe

    Tom Stiller Guest

    Did you, by any chance, add a plist file to '/etc/mach_init_per_user.d/'?
     
    Tom Stiller, Nov 2, 2004
    #3
  4. Kurt Tappe

    Dirk Kring Guest

    something in /etc/rc.xx, ie rc.common?
     
    Dirk Kring, Nov 3, 2004
    #4
  5. Kurt Tappe

    Kurt Tappe Guest

    Thanks everyone for your suggestions. I did mistype in my original
    message--"Internet Connect" is being run as a login item, not a boot
    item. Sorry about that.

    I looked in the system.log and found nothing. I tried renaming
    "Internet Connect" to something else and it does not get launched, but
    no error is generated in system.log when it fails to find the app.

    I found no signs of it in /etc/mach_init.d nor
    /etc/mach_init_per_user.d.

    Nothing in the /etc/rc.* files either.

    I do see some interesting things in system.log that I might want not
    to be running; various sharewares I've tried in the past and no longer
    want. How can I see where they're being kicked off and possibly edit
    them out? Perhaps this is where I'll also find my edit.

    Thanks,
    -Kurt
     
    Kurt Tappe, Nov 4, 2004
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.