1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

How do I repair Windows XP on a ThinkPad? (without a CD-ROM)

Discussion in 'IBM Thinkpad' started by ship, Apr 17, 2006.

  1. ship

    ship Guest

    Hi

    How do I repair Windows XP on an IBM ThinkPad?

    I do NOT have a working CD-ROM reader (and in any case
    there was no CD that came with my PC!!) but I DO have broadband
    internet access...

    I tried running keyfinder and so I now know my CD Key.

    How can I get to a "recovery console"?

    (My CD-ROM player has blown up - but IBM didnt supply any
    Windows CD in any case - which is BLOODY irritating considering
    that I paid for "Windows XP Pro" so why the heck cant I have a
    CD?!)

    With thanks

    Ship
    Shiperton Henethe









    Model: IBM Thinkpad T23. 2647 (type) 9NG (model)
    Model Number: 26479NG (== "2647-9NG") G=GB
    Running: Windows2000 Pro
     
    ship, Apr 17, 2006
    #1
    1. Advertisements

  2. ship

    George Hein Guest

    I just rebuilt the OS'es for my 240 elsewhere.

    I removed the disk, attached it to a usb container (APRICORN).

    Via Linux on a t42 I re-partitioned disk, then did a dump/restore of a
    W2K partition using partimage and copied two linux bootable partitions
    to the new partition.

    Then I put the disk back onto my old screenless 240 attached to my
    lcd-tv and it worked (not the first or second time, but third time).


    I also did this to a 600e recently as well onto this t42 when I went
    from a 40GB to 80GB disk drive, but with this I copied my WinJunk-XP as
    well as 3 bootable Linux partitions.

    Have fun, this is not for a newbie.
     
    George Hein, Apr 17, 2006
    #2
    1. Advertisements

  3. ship

    ship Guest

    Frickin pants!

    All well and good... except the CD-reader hardware doesnt work any
    more.

    What a damned stupid, inconvenient system. How does it KNOW that
    one is running off a CD? How the heck come it cant repair from a hard
    disk - because that is, afterall where IBM have hidden my "WindowXP CD"
    !

    GADS!

    Any suggestions, anyone?


    Ship
    Shiperton Henethe
     
    ship, Apr 17, 2006
    #3
  4. ship

    Ed Guest


    Yes. I would gather from your comments that you really aren't
    familiar with computer hardware technology. You have a problem with the
    software on your Hard disk, or the HD itself. Without a functional means
    of running diagnostic or repair/restore softare to remedy the situation
    (an external drive, CD, HD, or whatever), you're up a creek. I suggest
    you use your name as a hint...... "ship" it for repair. Or break down
    and buy a CD drive to replace the one that doesn't work.

    Ed
     
    Ed, Apr 17, 2006
    #4
  5. ship

    ship Guest

    No way am I going to ship it anywhere. For a start it's too fragile -
    it hates
    being moved. The case is slightly cracked and it does to it ANY good to

    be transported more than necessary.

    I think it's not the CD drive itself but the PC. I have USB2.0 PCMCIA
    port
    which gave up the ghost so I bought another (new) one. Unfortunately
    this has a habit of (running very hot and) crashing my PC stone dead
    when copying iPod files. The iPod is fine on my other PC, however.

    And the iPod is fine on the original (grindingly slow) USB1 port.

    - Does it REALLY *have* to be a CD-ROM or can the data in question
    be obtained on the CD or even on a networked computer's CD...

    - And supposing I COULD get the CD-ROM to work, does anyone know
    how to get it to build a WindowsXP CD for me from the data on the CD.

    - Incidentally the current problem I have is that I can't get M$
    Internet Explorer
    [now updated to v7 in desperation but it didnt help!] ...to run M$
    Update!
    When I click the Express button it comes back moaning that files
    required to
    use M$ Update are no longer registered or installed on my PC. But when
    I ask
    it to Register or Reinstall the files for me, although it claims to be
    a) downloading
    and then b) registering the files... it takes be back to the start of
    the process
    and displays the Express button again and when I click that it still
    stays it
    cant find the files it needs...

    Ship
    Shiperton Henethe
     
    ship, Apr 17, 2006
    #5
  6. ship

    Lars Guest

    That is incorrect!

    You have to *install* Recovery Console, from Windows. And once that is
    done you will be given an option to boot to that recovery console
    every time you boot, from Hard Drive.

    However, to install the recovery console you need access to a few
    files that normally sits on your CD, in the \i386 directory.

    A lot of people do have the \i386 directory on their HD without
    knowing it, or understanding what it is for. The OP should have a
    look, maybe it is on his drive too.

    If so; Open a cmd-window and find the \i386 -folder and follow these
    directions, (from Windows Help-file);
    At the command prompt, type the following:
    \i386\winnt32.exe /cmdcons
    <enter>

    Follow onscreen directions. (It takes a few seconds for anything to
    happen.)

    Lars
    Stockholm
     
    Lars, Apr 17, 2006
    #6
  7. ship

    ship Guest

    Ah-ah - yes, I have the directory "\i386" sitting in C:\

    So I entered your command into a CMD window.

    But it came back with
    "The option to upgrade will not be available at this time because Setup
    was unable
    to find the file C:\i386\WINNTUPG\NETUPGRD.DLL. The system cannot
    find
    the specified file."


    Hmm sounds a bit dire.

    Is there anywhere online where I can grab whatever is supposed to be in
    C:\i386 ?!

    (Like I say I dont have a functioning CD-reader nor an WindowsXP
    CD-ROM!)

    What about uninstalling Windows SP2 and then re-installing it?
    Maybe that would get some of the missing files...?
    I have been trying this but one of the key problems is that the
    "Windows Update" / "Microsoft Update" utilities dont work on
    my PC - so I have been trying to poke around using Netscape...



    Ship
    Shiperton Henethe
     
    ship, Apr 17, 2006
    #7
  8. ship

    ship Guest

    Whoops!
    It went right throught the installation of SP2, rebooted
    and then during the reboot it came back with:

    "UPdate Windows - MS00be.exe (sp??) - Application Error
    Instruction at 'OX604a296e' referenced memory at '0x000000000"
    The memory could not be read."

    Any thoughts?


    Ship
     
    ship, Apr 18, 2006
    #8
  9. ship

    ship Guest

    Okay I'll run that command:
    "\i386\winnt32.exe /cmdcons"
    and see what it does...
    Something about verifying that all protected Windows files are intact
    and original versions...
    (Not sure whether or not that includes service patches - somewhat
    confusing...)

    I have a big deadline for tomorrow.
    I fear my hard disk is on the way out... help!

    More later.


    Ship
     
    ship, Apr 18, 2006
    #9
  10. ship

    ship Guest

    Okay, I managed to get
    "winnt32.exe /cmdcons" to run this time.
    It was pretty slow to run and took about 30+ minutes.

    What was it supposed to achieve? Is it supposed to clean up
    any errors &/or corrupted files?

    All it seemed to do was check the integrity of the original Windows
    files. But I'm afraid that it didnt seem to do much else!
    There were no more onscreen instructions or anything.

    * * *

    Ah-ha, *SOME* progress...! The little yellow sheild thing has appeared
    and now I can download updates (and presumably install them too).
    [Whereas this definitely WASNT appearing beforehand...]

    However I *still* cant get that Microsoft / Windows Update thing to
    work when I surf to Microsoft's website...!


    Ship
    Shiperton Henethe
     
    ship, Apr 18, 2006
    #10
  11. ship

    Tony Hwang Guest

    Hi,
    You may have virus infection or spyware problem.
     
    Tony Hwang, Apr 18, 2006
    #11
  12. ship

    ship Guest

    You may have virus infection or spyware problem.

    Hmmm I was starting to wonder myself.
    I am running Norton AntiVirus (up to date) but it hasnt found any
    problems.

    I have just downloaded "Windows Defender (Beta2)" from MSoft and am
    running a scan...

    Any thoughts on best way of removing spyware?
    I have LavaSoft's Adware 6 & also "Spybot Search & Destroy" (both of
    which I havent
    run for about a month)

    With thanks


    Ship
    Shiperton Henethe
     
    ship, Apr 18, 2006
    #12
  13. ship

    GomJabbar Guest

    Each spyware is unique, and some is quite difficult to remove. Once
    you have identified it, try to find a removal tool. Also, look on
    Symantec's site for removal instructions.
     
    GomJabbar, Apr 18, 2006
    #13
  14. ship

    alordofchaos Guest

    Any reason you can't network your laptop to the other PC and install or
    repair using the other PC?
     
    alordofchaos, Apr 18, 2006
    #14
  15. ship

    ship Guest

    Yes I was just wondering about that kindof thing myself...
    The other PC is on the same network and shares internet access
    AND it does have a functioning CD-reader. However I must admit I
    havent managed to get it to see the other PCs, of late.

    One difficulty is that that laptop needs to work in several different
    offices. The other problem is that the other PCs are still running
    ms Windows2000 (Pro), rather than WindowsXP.

    A third difficulty is that we can only find a WindowsXP SP1 HOME
    Edition
    CD-rom in the office... so far.

    But I suppose *if* I got hold of a WinXP Pro CD and *if* I managed to
    get
    my PC to see the other PC's hard disk, (or CD reader) then I could
    presumably
    just copy the entire CD over onto my Laptop's hard disk...

    And then maybe run the System File Checker ("sfc /scannow") again??
    Which is presumably all that a Windows Repair is doing in the first
    place, no?


    Ship
    Shiperton Henethe
     
    ship, Apr 18, 2006
    #15
  16. ship

    ship Guest

    Oh no this sounds serious!

    I keep getting errors to do with WINNET.dll.

    e.g. I just tried reinstalling Norton Internet Security (includes
    AntiVirus) and all I get is:
    "The procedure entry point InternetGetSecurityInfoByUrlW could not be
    located in the dynamic link library WINNET.dll"

    Any suggestions?

    Ship
    Shiperton Henethe
     
    ship, Apr 18, 2006
    #16
  17. ship

    ship Guest

    Okay, too late!
    I gave up an formatted the hard disk.


    Ship
    Shiperton Henethe
     
    ship, Apr 19, 2006
    #17
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.