how to change fonts when printing via lpr from OS X

Discussion in 'Apple' started by Paul Nevai, Dec 29, 2004.

  1. Paul Nevai

    Paul Nevai Guest

    How can I set what font I use when printing from OS X via lpr to my laser
    printer?

    On our SUN I just set ENSCRIPT as in

    setenv ENSCRIPT "--no-header --margins=36:36:36:36 --font=Courier11
    --word-wrap --media=Letter"

    and all works fine. In OS X this doesn't have any effect.

    Please help. Thanks, Paul
     
    Paul Nevai, Dec 29, 2004
    #1
    1. Advertisements

  2. Paul Nevai

    John Doherty Guest

    Well, enscript is there, so there's no good reason it shouldn't
    work. Your syntax for setting the environment variable suggests that
    you're using a csh-derivative shell (e.g., csh itself or tcsh),
    whereas the default user shell on MacOS/X is bash, which uses a
    different syntax for that purpose, namely:

    ENSCRIPT="--no-header --margins=36:36:36:36 --font=Courier11 \
    --word-wrap --media=Letter" ; export ENSCRIPT

    You could also change your shell on MacOS/X to tcsh (which was the
    default in earlier versions and is still included, though no longer
    the default).

    --
     
    John Doherty, Dec 29, 2004
    #2
    1. Advertisements

  3. Paul Nevai

    Paul Nevai Guest

    John Doherty <> aszonygya:
    :> setenv ENSCRIPT "--no-header --margins=36:36:36:36 --font=Courier11
    :> --word-wrap --media=Letter"
    :>
    :> and all works fine. In OS X this doesn't have any effect.
    :
    :Well, enscript is there, so there's no good reason it shouldn't
    :work. Your syntax for setting the environment variable suggests that
    :you're using a csh-derivative shell (e.g., csh itself or tcsh),
    :whereas the default user shell on MacOS/X is bash, which uses a
    :different syntax for that purpose, namely:
    :
    : ENSCRIPT="--no-header --margins=36:36:36:36 --font=Courier11 \
    : --word-wrap --media=Letter" ; export ENSCRIPT
    :
    :You could also change your shell on MacOS/X to tcsh (which was the
    :default in earlier versions and is still included, though no longer
    :the default).

    I use tcsh as defualt shell on both the Mac and the Sun. Best regards, Paul
     
    Paul Nevai, Dec 29, 2004
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.