1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

How to get hardware acceleration in OpenGL?

Discussion in 'Nvidia' started by Robert Gault, Apr 14, 2006.

  1. Robert Gault

    Robert Gault Guest

    I am trying to run opengl apps on a Win98SE system. The card is the Ti4200
    which does support opengl. The drivers tested were all of the nVidia
    releases from 44.03 up through 81.98. None of these nvopengl.dll drivers is
    being seen by the OS (opengl32.dll) so there is no hardware acceleration.

    Does anyone have any ideas other than install WinXP? Don't bother
    suggesting reinstalling the nVidia drivers as that is not the problem. The
    nVidia driver is installed in the registry key
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\OpenGLdrivers
    RIVATNT nvopengl.dll

    By rights, the system should be working but is not. I can't believe my
    system is unique so would those of you who have experienced this problem
    please report your successes or failures.
     
    Robert Gault, Apr 14, 2006
    #1
    1. Advertisements

  2. Robert Gault

    Mark M Guest

    A complete reinstall of Win98SE and NV drivers will almost certainly
    clear up your problem. If you've installed all driver versions from 44.xx
    to 81.xx, your system by now is a hopeless jumble of conflicting registry
    entries....:)

    One other suggestion, Win98SE is dead and buried. Update to an OS
    made this century.
     
    Mark M, Apr 14, 2006
    #2
    1. Advertisements

  3. Robert Gault

    Robert Gault Guest

    Not true. I know how to install nVidia drivers and there are no leftover
    entries of any kind in the registry nor leftover file in the Windows\System
    directory. This is a trivial concern that anyone knowledgeable about nVidia
    drivers can avoid.
     
    Robert Gault, Apr 15, 2006
    #3
  4. Robert Gault

    deimos Guest

    I generally agree as an expert myself, but every once in a while I've
    had to resort to DriverCleaner or had a WHQL driver stuck in the Windows
    driver cache. One thing to note about 8x.xx however; NVIDIA changed
    some internal code handling communications over the AgP bus and
    signaling. If your chipset drivers are out of date (or no longer
    supported), it could result in low level incompatibilities.

    Worst case scenario, revert to 71.84 or some 7x.xx version working for
    98. I never paid attention to 9x releases, so best of luck.
     
    deimos, Apr 15, 2006
    #4
  5. Robert Gault

    Mark M Guest

    Natural selection hard at work.

    What a sucker.
     
    Mark M, Apr 15, 2006
    #5
  6. Robert Gault

    Conor Guest

    Are you sure that the installer doesn't replace the Microsoft
    opengl32.dll file with a nVidia one? Have you checked the file info to
    see who the vendor is for it?
     
    Conor, Apr 15, 2006
    #6
  7. Robert Gault

    Robert Gault Guest

    That is not what nVidia does. Microsoft made provisions for card drivers
    listed as ICDs to be called from the Microsoft opengl32.dll. If you look at
    the properties of the nvopengl.dll file, you will see it is NVIDIA
    Compatible OpenGL ICD. nVidia places the name of the nvopengl.dll in a
    registry entry and opengl32.dll is supposed to find the driver entry and
    use it. That is not happening on my system.
     
    Robert Gault, Apr 15, 2006
    #7
  8. Robert Gault

    Inglo Guest

    What software is it that isn't working?
     
    Inglo, Apr 15, 2006
    #8
  9. Robert Gault

    Mark M Guest

    First step to solving your problem is to stop being an arrogant asshole
    who thinks he knows everything, and jumps on people who try to help
    him. Second step is to upgrade to an OS that was made this century.
    Or if that isn't possible, reformat/reinstall your freaking Win98SE.
    Problem solved.
     
    Mark M, Apr 15, 2006
    #9
  10. Robert Gault

    Conor Guest

    Fair enough. The last time I was into anything like that, a vendor
    provided application specific driver had to be placed in a specific
    folder.
     
    Conor, Apr 15, 2006
    #10
  11. Do you have your mobo chipset drivers ( AGP GART ) installed? Sometimes lack
    of OpenGL support arises from lack of AGP support. What does DXDiag says?

    Secondly, though this proly won't apply, are you in a 32 bit mode? Matrox
    cards supported 16/24/32 bit modes and OpenGL was only supported in 16/32
    bit modes as the extra 8 bits for the alpha channel were required for OpenGL
    and weren't supported in 24 bit modes.
     
    Sharanga Dayananda, Apr 15, 2006
    #11
  12. Robert Gault

    Robert Gault Guest

    The motherboard chip sets are installed. DXDiag shows no problems. I've
    tried both 16 and 32 bit modes.
     
    Robert Gault, Apr 17, 2006
    #12
  13. Robert Gault

    Robert Gault Guest

    I finally found what was causing the problem. It had nothing to do with the
    Registry, nor nVidia drivers, and did not require reinstalling the OS.
    There was a single entry in win.ini file, presumably inherited when
    upgrading from Win95 to Win98SE. In fact there is information about this in
    the Microsoft Knowledge Base.

    win.ini
    [DrawDib]
    DVA=0

    The above entry kills opengl hardware acceleration. Changing the 0 to 1, or
    just removing the entry fixed the problem.
     
    Robert Gault, Apr 17, 2006
    #13
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.