How to use SuperSpeed on Asus P5Q Pro Turbo

Discussion in 'Asus' started by Bill Anderson, May 31, 2012.

  1. I have identical 1TB HDDs that I'd like to use with the board's Drive
    Xpert mode to have a high speed RAID0-like 2TB drive. I've installed
    the drives in the orange and white sockets and I've chosen SuperSpeed in
    BIOS and I've allowed BIOS to do whatever it did to the drives and now
    I'm showing a new 1TB drive in Windows 7 64-bit. BIOS tells me that
    it's a 2TB drive, but Windows is having none of it.

    I tried installing from the P5Q's installation disk the Intel Matrix
    Storage Manager but that only bogged down the system. It took over a
    half hour to boot fully (some things came up immediately and worked,
    like Windows Explorer, but the network took FOREVER to launch).

    Somewhere I googled that I need to have installed some sort of Marvell
    driver to make SuperSpeed work, but I don't know what that is.

    Anybody have any experience with making the P5Q Pro Turbo give Windows 7
    whatever it needs to see the two 1TB drives as one 2TB drive? Thanks.

    Bill Anderson
     
    Bill Anderson, May 31, 2012
    #1
    1. Advertisements

  2. Bill Anderson

    Paul Guest

    P5Q Pro Turbo

    ICH10R
    5 x SATA II

    JMB361
    1 x ribbon cable
    1 x ESATA

    SIL5723
    Two port combiner SATA II, with internal processor (potential rate limit)

    *******

    ICH10R ---- \
    ---- \
    ---- \___ Five ordinary SATA ports
    ---- /
    ---- /
    ----- sil5723 ---- SATA_E1 Orange (1TB)
    ---- SATA_E2 White (1TB)

    The driver would be whatever driver is on ICH10R. The ICH10R
    is in control here. The SIL5723 combines the two drives, and
    creates a single virtual drive with bogus naming convention.
    The drives should no longer have a "personality" when they're
    behind the SIL5723.

    You should not need any "special" driver for ICH10R, as near as
    I can tell. The SIL5723 is supposed to emulate a single drive,
    no matter what is behind it. So to the ICH10R, it looks like
    a sixth hard drive of 2TB capacity (when your config is in
    SuperSpeed mode).

    I would return to the BIOS menu, try all operating modes
    (Superspeed, EZBackup, Normal mode), then return to the
    OS and see what capacity and status is reported. It's possible
    you have a bad SATA cable, so try changing cables, try
    swapping drives on the two connectors and so on. Or,
    verify the drives work (report 1TB each), when connected
    to the five ordinary SATA ports. There has to be an answer
    there somewhere. Make sure the drives have power etc.

    Maybe the SIL5723 chip itself has a bad port, or the orange or white
    connector is dirty or bad. It may not be possible to test
    the two ports equally well, as in single drive mode, E1 is
    preferred. I don't know if a single drive on E2 would work
    in single drive mode. You could try it.

    The I2C interface might possibly be able to report RAID
    status, but motherboards don't typically connect that
    to anything. On something like a NAS, the I2C would be
    connected to something, for monitoring.

    http://www.siliconimage.com/products/product.aspx?pid=103

    The first version of this chip, was a flop. I think the product
    brief of the first generation part, actually stated it was
    limited to around 110MB/sec or so. Presumably, this one
    was fixed, but also note that the Product Brief for your
    chip, no longer attempts to estimate performance. So when
    you do get it working, benchmark in HDTune (free version 2.55)
    to see how well the internal processor on that thing works.
    To test chips like this unambiguously, a couple SSD drives
    would be a good choice. But you can use the "burst transfer
    rate" number from HDTune as an estimate. The cache on your
    hard drives, is bigger than the FIFO on the 5723.

    http://www.siliconimage.com/docs/sii5723_pb_FINAL_11-28-06.pdf

    Paul
     
    Paul, May 31, 2012
    #2
    1. Advertisements

  3. Yay! Got it! Done. Fixed. Working!

    The first clue came from you, Paul, and the second was dumb luck. You
    made it clear that I needed ICH10R to be working under Windows and I
    just figured that naturally it was. Then came the dumb luck: I forgot
    and left my P5Q Turbo installation CD in the drive when I rebooted and
    when the computer booted from it right there in front of me it was
    asking if I wanted to create a 32-bit or 64-bit ICH10R driver
    installation disk. Well...

    So I tried to create a 64-bit disk and it asked me to insert a formatted
    floppy into my A: drive. Well...

    I haven't had an A: drive in years, so I decided to do a little
    exploring on the P5Q's installation disk. And so it was that I found
    under /drivers/RAID/imsm/Install/Ahci the file
    ICH10_AHCI_FOR_DriveXpert.msi.
    Well...

    That folder also had a setup.exe in it so I ran that as administrator
    and voila! It installed a driver.

    Now when I rebooted into Windows things got interesting. First I got a
    white text/black background screen telling me Windows was going to run
    whatever they call ScanDisk these days, and so it did. Then it rebooted
    and next I got a white text/black background screen telling me I needed
    to run fdisk on the drive. Then I rebooted and got into Windows, which
    seemed obsessed with telling me my recycle bin was corrupted. The first
    thing I did was go to Computer Management and check Disk Management,
    where I discovered a new disk with two 1Tb partitions. Hah!

    So I deleted the two partitions back to a total of almost 2Tbs of
    unallocated space, and then partitioned and formatted my new 2Tb drive
    as I wanted.

    And now it's working. I'm not sure about it being SuperSpeedy, but I
    will run the test you recommended later this evening to see. Right now
    I'm just copying data into my new partitions.

    All this is in preparation for a new SSD Newegg has on the way. Hope to
    get it Friday. All the reviews say it'll seem like I've bought a new
    computer. We shall see. It's a Samsung 256 GB SATA III that'll really
    shine one of these days when I have an SATA III MBo. But for now I'm
    keeping my fingers crossed that the SSD will keep me happy on my SATA II
    P5Q for awhile.

    You may remember we communicated a couple of weeks ago about my
    inability to make Win7 switch from RAID mode to IDE to accommodate a new
    3TB drive. Well, all that has inspired me to re-install everything on a
    separate drive -- Win7 64-bit and all apps -- just to make sure I can do
    it when the SSD arrives. I'll want to have a fresh AHCI installation on
    it.

    I'd dreaded doing this because I knew what a hassle it would be to (once
    again) make Google Calendar Sync play nice with Outlook. I'd been
    through all that once before and it was a huge headache. I mean,
    everything else I could do, but making Outlook work was driving me
    crazy. But now, after about a week and a half of experimenting, I've
    achieved Nirvana: I can install Win7 64-bit and all my apps and
    everything works.

    There were two problems with Outlook: 1) When I installed Google
    Calendar Sync (an absolute must for me), Outlook would begin asking me
    to identify a profile, even if there was only one profile to choose
    from. And 2) Outlook would stop closing properly on exit. I'd end up
    with three instances of Outlook running and then it wouldn't load again.
    I'd have to run Task Manager and kill three Outlook processes in order
    to start it up again.

    Turned out there was a two-part solution. 1) After installing Outlook
    and then Google Calendar Sync, I needed to install the Outlook Business
    Manager -- free software offered by Microsoft to owners of Outlook.
    That fixed the "profile" problem And 2) Avast AntiVirus was the culprit
    regarding Outlook shutting down. I'd thought it was iTunes, but it
    wasn't. Even with the Avast add-in disabled in Outlook, it still caused
    a problem But Microsoft Security Essentials causes no problem at all,
    so that's the virus protection I'll use from now on. I will never know
    how it is that I have Avast playing nice with Outlook on my old 32-bit
    and 64-bit dual boot system, but I do. I don't know what I did. But I
    don't have to worry about that anymore, apparently.

    And that's my story up to now. As always, Paul, many thanks for your
    incredible help!
     
    Bill Anderson, Jun 1, 2012
    #3
  4. OK I ran HDTune 2.55 (free) and here's what it said about my new 2TB
    SuperSpeed drive:

    Transfer Rate
    Minimum: 87.9 MB/sec
    Maximum 113.1 MB/sec

    Is that good? Bad? Sorta OK? I've done some Googling and I can't find
    a straight answer, but "sorta OK" seems the best description. Agree?
    Thanks.
     
    Bill Anderson, Jun 1, 2012
    #4
  5. Bill Anderson

    Paul Guest

    You can try moving each disk individually, to one of the regular Intel
    ports, and measuring there.

    In theory, a good RAID setup with two identical disks, should be
    able to make double the speed when doing RAID 0. Based on the size of
    your drives, they're probably not that old, in which case, they should
    probably be giving a curve with a higher initial value (at the outside edge
    of the platter).

    The HDTune window, should have a "burst transfer" measurement on the right
    hand side. And while that measurement method isn't perfect, it too might
    hint at the 5723 being a bottleneck.

    The thing is, I have a 500GB drive that can manage 125MB/sec on the
    left hand of the curve. And that's a single drive, by itself. There
    is nothing special about that drive - it was the cheapest thing I could
    find at the time. And there are some really amazing drives out there - I
    think there is a drive now, at 180MB/sec (hard drive, not an SSD).
    The older generation still in my rotation, are around 65-70MB/sec.
    The crappiest drive I have which still runs (a WD), is a 4GB drive at 8MB/sec.
    Not even as fast as my USB flash sticks.

    Move the drive connector over to an Intel port, and re-run HDTune.

    Paul
     
    Paul, Jun 1, 2012
    #5
  6. Bill Anderson

    Paul Guest

    I found a result here. The person benchmarking, doesn't report the
    drives being used.

    http://www.xtremesystems.org/forums...l-ICH10R-(Asus-P5Q-Series-Maximus-II-Formula)

    There are three charts.

    1) ICH10R (Intel RAID)
    Best case sustained - about 133MB/sec
    Burst transfer speed - 255.6MB/sec

    Now, that doesn't make sense, because a single SATA II might have been able
    to burst like that. I'd have expected a higher burst number. Burst testing
    has been known to be unreliable (needs tweaking every time another SSD comes out).

    2) ICH10R (Intel RAID with writeback cache)

    All this does, is "blow out" the burst transfer speed, to motherboard RAM speed.
    So rather useless, in terms of interpreting hardware performance.

    3) Silicon image 57xx (their terminology)

    Best case sustained - around 113MB/sec and eerily similar to the previous
    generation Silicon Image design.

    Flat spot on sustained curve, shows "bottleneck limiting" or SIL5723 "processor".

    Read and write performance are radically different.

    Testing with SSDs would be more fun, as then there is no ambiguity about
    the bottleneck. But I wasn't able to find any examples of that.

    HTH,
    Paul
     
    Paul, Jun 1, 2012
    #6
  7. For anyone around here who has been wondering whether investing in a new
    SSD would be a good idea -- whether installing OS and all apps on an SSD
    would provide a noticeable improvement in performance -- I'll just say
    I'm majorly pleased.

    Installing the SSD was a breeze; it has behaved for me just like a
    regular HDD and Windows 7 installed on it without a single hiccup. For
    data storage and video editing I still have another four HDDs in the
    system, one 3TB, one 1.5TB, and two 1TB drives paired as "SuperSpeed"
    drives under the P5Q's Drive Xpert feature.

    The SSD doesn't work magic, but it sure does speed things up on an Asus
    P5Q. From a cold start my Windows 7 is now up and running in about 30
    seconds, and this is with all Win7 updates installed plus about three
    dozen apps and gadgets. Virus protection is Windows Security Essentials.

    But even better than boot time is the almost incredible speed with which
    my apps load. Click on the Word icon and boom, I'm looking at a blank
    page. Same for everything else -- what once took maybe 10 or more
    seconds to load now takes less than 5 -- like Photoshop CS5 64-bit for
    instance, which I just now checked and it loaded in two seconds flat.

    Of course I know from experience that any time you install a clean OS
    with clean apps you'll get improved performance -- for awhile, anyway.
    But I've never seen an improvement like this. Pretty amazing, actually.

    And that's my experience so far.
     
    Bill Anderson, Jun 7, 2012
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.