1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

HP G72-b49WM question

Discussion in 'Laptops' started by Ken, Nov 10, 2012.

  1. Ken

    Ken Guest

    I have the above laptop and after troubleshooting it for a failure to
    turn on, I decided to open it all up and see if I could find something
    wrong. I looked for loose cables or a heat sink that was loose since
    the problems started out inconsistent and jumped all over the place with
    different symptoms, culminating in the failure to turn on.

    After finding nothing, I decided to reconnect the motherboard with the
    minimum hardware required to see if it would turn on. At first I added
    RAM, attached the display cable, the power switch, CMOS battery, and the
    power lead from the power adapter. No LED or any sign of life occurred
    when the power switch was depressed. I felt that should have been
    enough to at least turn on the computer, but I thought I would add one
    component at a time to see if more was required. I then attached the
    keyboard cable and tried it again. The computer powered up.

    Eventually I attached all the other cables and hardware checking it
    after each was attached. It powered up with no problems. In fact it
    appears as if I solved my computer problem with power not starting or
    even lighting the power LED. It has been working flawlessly ever since.

    My question is this: Does the lack of a keyboard on a laptop inhibit
    the power from turning on?? I have worked on many desktop computers and
    the lack of a keyboard generally produces an error message during POST.
    I have never seen one stop it from powering up. I hate solving a
    problem and not understanding why it behaved as it did. My guess is
    that a poor connection to one of the cables was the cause, perhaps the
    keyboard.
     
    Ken, Nov 10, 2012
    #1
    1. Advertisements

  2. Ken

    Bob_Villa Guest

    On Saturday, November 10, 2012 12:14:18 PM UTC-6, Ken wrote:
    My guess is
    HP's (and others) often have bad solder connection and may eventually come back to haunt you!
    On YouTube there are folks who have "baked" their laptops back to life...I have 3 Dells that have been good for me! Knock-on-wood!
    Hope it keeps working for you! (and I believe you are correct in assuming that it should power-up with-out a keyboard)
     
    Bob_Villa, Nov 10, 2012
    #2
    1. Advertisements

  3. Ken

    cameo Guest

    I was one of those who baked my HP laptop to life a year ago. Still
    working fine. The problem is usually associated with overheating NVIDIA
    GeForce graphic chip and poor heatsink, but I don't know what this G72
    model uses.
     
    cameo, Nov 10, 2012
    #3
  4. Ken

    Ken Guest

    I just thought I would update my original question even though I now
    know that a keyboard is NOT required for the motherboard to power up and
    show something on the display.

    What seemed to be fixed as described above was not the case. (The fact
    that the computer started working had nothing to do with the keyboard
    being connected. It was simply a coincidence.) The computer did work
    for several weeks and I thought perhaps it had been fixed, even though I
    did not understand how. Suddenly it started displaying the same failure
    symptoms that I originally encountered again. This time before taking
    the computer apart I searched the web to see if others with the same
    model of computer had experienced a similar failure. I found that many
    had, and that many thought it was attributed to the power switch
    daughter board used to turn on the computer. Again I don't quite
    understand the bizarre failures since they changed in their symptoms,
    but I decided to look at the computer again with particular attention to
    the daughter board used to turn on the power. I looked for a poor
    solder connection since intermittent failures are most often due to such
    a failure based upon my experience. I did not see any poor connections,
    but I re-soldered all the connections I could before reinstalling the board.

    Again the computer worked and has been working for about two weeks. Is
    it fixed?? I am not sure. It is working, and since there are others
    that believe the power switch daughter board was the reason for their
    failure, I thought I would pass on my experience.
     
    Ken, Dec 16, 2012
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.