hp proliant DL580 G3 -illegal opcode

Discussion in 'HP' started by steven acer, Oct 17, 2007.

  1. steven acer

    steven acer Guest

    i got a new hp proliant G3 P38 server with 4xAMD64 proc and 18Gb of
    RAM ,
    BIOS is v2006.08.08 ( latest ), smart array controller 6i.
    i tried to install linux redhat 4 U4 x86_64 and it crashed spitting a
    red screen on reboot - the installation was successful as far as i
    know
    red screen says :

    illegal opcode
    EAX=00007CFE EBX=00007C00
    ECX=00000007 EDX=00000180
    EBP=0000FBFA ESI=000007BE EDI=00000800
    DS=0000 ES=0000
    FS=0000 GS=0004
    CS:EIP=0000:0000835A SS:ESP=1000:0000B000
    EFLAGS=0000213

    i can't think of anything other than BIOS update or storage controller
    update, and these are actually up to date.
    HP support guys weren't of so much help, so if anyone anything that
    could help and i really mean anything
    suggestions,guidance,thoughts... it would really save my day or better
    to say my week since it's been 3 days i'm battling with the issue !
     
    steven acer, Oct 17, 2007
    #1
    1. Advertisements

  2. steven acer

    pcordova

    Joined:
    Nov 9, 2007
    Messages:
    1
    Likes Received:
    0
    hp proliant DL365 G3 -illegal opcode

    I'm having the same problem that you were having. After installing Fedora Core 5 on a brand new DL365 I received the same type of Illegal OpCode red screen error message that you did:

    EAX=00002DD3 EBX=0000F8000 ECX=00000101 EDX=00000000
    EBP=0000FBFA ESI=000007BE EDI=00000800
    DS=0000 ES=0000 FS=0000 GS=0002
    CS:EIP=0000:000083F5 SS:ESP=1000:0000AFFE
    EFLAGS-00000206

    Did you ever figure out what the cause of the error was?
     
    pcordova, Nov 9, 2007
    #2
    1. Advertisements

  3. steven acer

    jorgjeff Guest

    steven acer;357068 Wrote:
    > i got a new hp proliant G3 P38 server with 4xAMD64 proc and 18Gb of
    > RAM ,
    > BIOS is v2006.08.08 ( latest ), smart array controller 6i.
    > i tried to install linux redhat 4 U4 x86_64 and it crashed spitting a
    > red screen on reboot - the installation was successful as far as i
    > know
    > red screen says :
    >
    > illegal opcode
    > EAX=00007CFE EBX=00007C00
    > ECX=00000007 EDX=00000180
    > EBP=0000FBFA ESI=000007BE EDI=00000800
    > DS=0000 ES=0000
    > FS=0000 GS=0004
    > CS:EIP=0000:0000835A SS:ESP=1000:0000B000
    > EFLAGS=0000213
    >
    > i can't think of anything other than BIOS update or storage controller
    > update, and these are actually up to date.
    > HP support guys weren't of so much help, so if anyone anything that
    > could help and i really mean anything
    > suggestions,guidance,thoughts... it would really save my day or better
    > to say my week since it's been 3 days i'm battling with the issue !


    Steven,

    Did you ever find a resolution to the illegal opcode red screen error?
    One of our servers got the same error recently after our last patch
    cycle in January. I opened an HP case, and they only came back with
    update BIOS and controller firmware.

    Thanks for any help.
     
    jorgjeff, Feb 8, 2008
    #3
  4. steven acer

    jponza Guest

    Hey, hope this helps because I just had to register to post this :p

    I had the same thing occur tonight... which freaked me out a bit.

    I managed to fix the problem though (this was on a HP Proliant DL385
    G2).

    It seems like it arises from the server trying to boot from its HDD -
    and when it looks to the address where the bootable code should be (i.e.
    grub/initrd whatevr). And it gets something which isn't bootable - so it
    replies 'illegal opcode' and hangs.

    So I booted into Ubuntu using a 7.04 live CD (taking note to use a
    64bit one), and from there I used grub to regenerate an appropriate
    MBR.




    grub> device (hd0) /dev/cciss/c0d0
    grub> root(hd0)
    grub> setup ( hd0,0)


    Once that was done the server stopped ecountering the 'illegal opcodes'
    which were the result of it looking at the corrupted MBR/whatever, and
    seeing something other than a properly configured bootable image.

    So then instead of getting a red-screen of death, I got the grub menu.

    Sorry I wrote this the other night and then fell asleep at my desk
    before hitting send.
     
    jponza, Feb 21, 2008
    #4
  5. steven acer

    tieoneknees

    Joined:
    Mar 28, 2008
    Messages:
    1
    Likes Received:
    0
    FYI. this is from the HP website.


    Red Hat Enterprise Linux 4 Update 4 (AMD64/EM64T)

    To install Red Hat Enterprise Linux 4 Update 4 (AMD64/EM64T) to a DL585 G2 or a BL685c, perform the following steps:

    * Enable the Linux x86_64 option in RBSU:
    o Press the F9 key during powerup to access RBSU.
    o Select Advanced Options.
    o Select the Linux x86_64 HPET option and change the setting to Enabled.
    o Press the F10 key to exit RBSU. The server restarts automatically.
    * Before installation: Add the parameter "pci=nommconf" to the kernel boot string.
    * After installation: Add the parameter "pci=nommconf" to the GRUB configuration file.
     
    tieoneknees, Mar 28, 2008
    #5
    1. Advertisements

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Similar Threads
  1. El Bandito
    Replies:
    4
    Views:
    1,308
    El Bandito
    Apr 8, 2006
  2. El Bandito

    Loud compaq Proliant DL580 (gen1)

    El Bandito, May 12, 2006, in forum: Compaq
    Replies:
    7
    Views:
    3,577
    radafuk
    Jan 17, 2008
  3. stuart.h
    Replies:
    2
    Views:
    2,942
    Mark Borgerson
    Nov 11, 2004
  4. PIC Opcode Corruption

    , Oct 5, 2005, in forum: Embedded
    Replies:
    2
    Views:
    725
    Mark McDougall
    Oct 6, 2005
  5. Aeridyne
    Replies:
    3
    Views:
    1,718
    Jez T
    Jan 24, 2007
  6. Account1
    Replies:
    0
    Views:
    514
    Account1
    Mar 16, 2007
  7. IanB

    8080 DAA opcode

    IanB, May 27, 2007, in forum: Intel
    Replies:
    6
    Views:
    2,630
    Bill Davidsen
    Jun 15, 2007
  8. abramo

    HP Proliant DL580 G5.

    abramo, Nov 19, 2008, in forum: HP
    Replies:
    0
    Views:
    2,022
    abramo
    Nov 19, 2008
Loading...