I am not able to enter into BIOS

Discussion in 'Asus' started by ulixi, Apr 1, 2011.

  1. ulixi

    ulixi Guest

    Hi, I have just done some clumsy operations deleting every hard drive
    (volume) (by Windows 7 CD) and now I cannot enter into BIOS. BIOS is
    block and I cannot enter inside.
    My motherboard is: ASUS P5W DH DELUXE.
    Can I solve it and do the Boot with CD?
     
    ulixi, Apr 1, 2011
    #1
    1. Advertisements

  2. ulixi

    Paul Guest

    You could try unplugging the SATA hard drives, then try pressing <Delete>
    at powerup so you can enter the BIOS. Keep a record of which drive is
    connected to which connector, so you can put them back one at a time.

    If you need to erase all drives, you can try DBAN. Or use
    a copy of "dd" to do it (zero out the drive).

    There is a suggestion here, to try to clear CMOS, but I wouldn't
    try this as my first step. To safely clear the CMOS, you should *unplug*
    the computer power from the wall, just in case. It may mention that in
    the motherboard user manual. (See section 2.6 of the user manual.)
    Clearing the CMOS, clears all the settings in the BIOS, and if you
    haven't written down all the settings, it can be pretty hard to
    correctly define the settings after you're finished. That's why
    I would save this operation for the very last. Don't do it, unless
    you've tried everything else first.

    http://vip.asus.com/forum/view.aspx...=1&model=P5W+DH+Deluxe&page=1&SLanguage=en-us

    Paul
     
    Paul, Apr 1, 2011
    #2
    1. Advertisements

  3. ulixi

    ulixi Guest

    Hi, I have just succeeded to enter into BIOS and I have formatted
    every hard drive in my computer.
    I remember I have:

    ASUS P5W DH DELUXE
    1 hardi drive x il SO Windows 7 32bit (C)
    2 hard drives in RAID0 (D)
    2 hard drives in RAID0 (E)

    Now when I turn on my computer I see a black screen says:

    No enough space to copy PCI
    Option ROM 03:00:00
    Option ROM 04:00:00
    The cable not ready
    enter setup for detail
    Press F1 to Resume,

    If I click on F1, then arrives the desktop normally and I see every
    volome (C, D and E).

    I inform you I have done a a clumsy movement.

    On Strumenti di Amministrazione/Gestione Computer/Gestione
    Disco I clicked on su "Conver in dinamic disk.
    Then I have get these problems.
    Now I'd like to put that disk as before but I see avery unabled
    options.
    Can I solve that problem?
    Thanks
     
    ulixi, Apr 3, 2011
    #3
  4. ulixi

    Paul Guest

    These error messages are unexpected.

    They sound like the BIOS is running out of what is called "low memory".
    Back in the days of DOS, the memory was 640KB. The "option ROM" lives
    in some of that tiny memory space. A typical desktop computer reserves
    128KB of memory for "option ROM". Normally, that is plenty for the job,
    as the option ROM is just some BIOS code, a hardware driver for the
    BIOS level to use while booting. It sounds like your option ROM storage
    space is exhausted, and *no* user setting in the BIOS controls this
    directly. If a plug in card (like a video card) is causing the option
    ROM space to be exhausted, you can try unplugging the card. Since
    you haven't added any hardware, this should not be happening.
    (A video card has a 64KB option ROM. Storage devices also have tiny
    code modules, and those code modules help the BIOS boot from
    a hard drive. All of that code, must fit into 128KB space.)

    This 128KB of memory for "option ROM", has nothing to do with how much
    memory is installed in the motherboard. You cannot fix this problem by
    adding more DIMMs to the motherboard. That isn't the problem. It is
    because the BIOS design uses such a tiny allocation, that it runs
    out. It is the way the BIOS is designed and can't be changed
    by the user.

    Changing your disk to "dynamic", should not do this. Something
    else must be wrong, but I don't know exactly what that would be.
    You can easily convert a "Basic" disk to "Dynamic" disk. Microsoft
    does not make it easy, to convert in the reverse direction (and
    yes, Microsoft is stupid).

    When dynamic disk is applied to a single disk (no arrays made with
    the dynamic disk), changing the partition type field can be
    enough to change it back. If you've done something more complicated,
    like spanned a couple dynamic disks together, this won't work. This
    would work, if you'd done the conversion function, to individual
    partitions and nothing else.

    http://www.nthelp.com/NT6/dynamic.htm

    If the files are accessible, you could back them up, prepare the disk
    again (reformat, make the disk "basic"), Then, restore the files. But
    what are the odds you'll be able to do that, without running into
    yet more problems ?

    To see the number "42" they are referring to in that article, you
    can try this tool. This tool displays the primary partition entries.
    If your partitions happen to be one of the primary partitions,
    you may be able to change the number 42 in here.

    ftp://ftp.symantec.com/public/english_us_canada/tools/pq/utilities/PTEDIT32.zip

    Can you do that to the C: partition ? I don't know. I have my doubts,
    because if you did, the system might crash.

    You might be able to boot Linux and use the fdisk command to change
    the partition type. That might be another way to get to it. (On my
    computer, I have two Windows OSes. If I need to modify the C: partition
    on one OS, I boot the second OS and make the change. That way, the
    C: partition target is not "busy" and cannot stop my changes.)

    There is a page here, with all of the partition type values defined.
    This is what it says for type 42 ("Dynamic")

    http://www.win.tue.nl/~aeb/partitions/partition_types-1.html

    "42 Windows 2000 dynamic extended partition marker

    If a partition table entry of type 0x42 is present in the legacy
    partition table, then W2K ignores the legacy partition table and
    uses a proprietary partition table and a proprietary partitioning
    scheme (LDM or DDM). As the Microsoft KnowledgeBase writes: Pure
    dynamic disks (those not containing any hard-linked partitions) have
    only a single partition table entry (type 42) to define the entire disk.
    Dynamic disks store their volume configuration in a database located
    in a 1-MB private region at the end of each dynamic disk."

    OK, I tried an experiment here. I set up three NTFS partitions on
    a disk. (NTFS has a partition type of 07. If your partitions are FAT32,
    then you'll need to use a different value.) Then, I used diskmgmt.msc
    (Disk Management), to convert the disk to Dynamic.

    Next, I opened the primary partition table on the disk, with PTEDIT32.
    With three partitions defined, I see

    42 ... \
    42 ... \___ These are the three partitions. They were 07, now they're 42.
    42 ... /
    42 ... <---- This is a fake partition. There is no file system here.

    I used PTEDIT32 to change my three NTFS (07) partitions back to basic. This
    is a way of cheating, and this *only* works if you have not spanned disks or made
    RAID or whatever. Using PTEDIT32, I changed the four leftmost numbers as follows

    07 ... \
    07 ... \___ I changed these back to NTFS again.
    07 ... /
    00 ... <---- I zeroed this one out, because it is a fake.

    When you make the dynamic disk, they make one fake entry at the end.

    OK, so when you do that, and save the result (make sure Disk Management
    is not running when you do the save of the new values), the three partitions
    disappear! The reason for that, is they have lost their drive letter.
    If you reboot, and fire up diskmgmt.msc (Disk Management) again, you
    will see the partitions in Disk Management, but not in the file manager.
    You need to go to Disk Management, click on each partition, and give them
    drive letters again.

    So I was able to fix it here. As near as I can tell, it works.

    If you have valuable data on those partitions, I'd back it up before
    doing any of that :)

    Good luck,
    Paul
     
    Paul, Apr 3, 2011
    #4
  5. ulixi

    ulixi Guest

    I have just not told you when I install drivers of Motherboard a
    writing tells me Motherboard doesn't support Windows 7. The I force
    the installation and everything runs ok. In the past time I have
    formatted some times and never I get that writinng. mmmm
    thanks
     
    ulixi, Apr 3, 2011
    #5
  6. ulixi

    ulixi Guest

    I have just unpugged the videocard but the problem is the same. I
    always have to click on F1, then I see the deskop.
    When I enter into BIOS in the MAIN page I see:
    Primary IDE master: DVD reader (pioneer)
    Primary IDE Slave not detened
    is it normal?
     
    ulixi, Apr 3, 2011
    #6
  7. ulixi

    ulixi Guest

    May be the best option is to put BIOS in DEFAULT? If it is the best
    option how can choise default?
    thanks
     
    ulixi, Apr 3, 2011
    #7
  8. ulixi

    Paul Guest

    Lots of people suffer from this problem.

    http://vip.asus.com/forum/view.aspx...del=P5K+Deluxe/WiFi-AP&SLanguage=en-us&page=2

    To fix it, is a matter of understanding *what you have changed recently*.

    At startup, your motherboard has 128KB of RAM, to hold option ROMs.

    1) If your motherboard has a LAN chip, a PXE option ROM may load.
    2) If your motherboard has a RAID controller, that may have an option ROM.
    Some motherboards have more than one option ROM.

    In addition, the cards you plug into the computer have option ROMs.

    1) A video card has a 64KB option ROM. Some option ROMs don't shrink their
    usage of that tiny RAM space, like they're supposed to.
    2) If you add a RAID controller card, and leave the motherboard RAID
    controllers enabled, that uses option ROM space as well.

    I don't think your Matrox board would have an option ROM.

    Think carefully, about how you have reconfigured the computer recently.

    Did you recently flash upgrade the BIOS ? Maybe that changed something ?

    Setting the BIOS to "default" will not necessarily help. It is a
    matter of your hardware configuration, and how you've modified it.

    http://en.wikipedia.org/wiki/Option_ROM

    Paul
     
    Paul, Apr 4, 2011
    #8
  9. ulixi

    ulixi Guest

    I don't think your Matrox board would have an option ROM.

    I don't have Matrox, I have ASUS P5W DH DELUX and SAPPHIRE RADEON
    X1950XT 256MB GDDR3
    I don't remember, I have done some tries.
    But now I remember I have converted the (D) disk in Dinamic. But in
    the BIOS I have conterted it at Base again.
    I didn't upgrade the BIOS.

    .... but the greatest mystery is the CD of Motherboard. When I try to
    install drivers, a writing tell me they are not compatible with Win 7
    32 bit. I have instalkled other times those drivers without problems.
    Only this time I get an error.

    In Device Management in storage controller now I see one entry only.
    Some times ago I saw 3 entries: Intel(R), JMicron, Marvel.
     
    ulixi, Apr 4, 2011
    #9
  10. ulixi

    Paul Guest

    Are the controllers Intel(R), JMicron, Marvel, enabled in the BIOS ?

    It could be, there is a problem with your motherboard. So far,
    your symptoms don't make sense to me. Option ROM memory space is
    exhausted. Controllers are missing in Device Manager (and detection
    of controllers, is independent of the Option ROM memory issue). I
    can't see a failure that makes all those symptoms make sense.

    Paul
     
    Paul, Apr 4, 2011
    #10
  11. ulixi

    ulixi Guest

    I HAVE SOLVED MY PROBLEM!
    My problem was Lan card enableb on BIOS, when I have disabled it, the
    problem has disappeared.
    Now I have every hard drive without RAID0 but it is not a problem.
     
    ulixi, Apr 4, 2011
    #11
  12. ulixi

    Paul Guest

    In the user manual, I see

    Onboard PCIE GbE LAN_1 [Enabled]
    Onboard PCIE GbE LAN_2 [Enabled]
    LAN Option ROM [Disabled] <------- Disabling this, only stops LAN boot
    via PXE and saves a tiny amount of
    Option ROM memory space.

    I don't understand why disabling the LAN, solves all your
    problems.

    Paul
     
    Paul, Apr 4, 2011
    #12
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.