1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

IBM Memory Key ; mounting primary HD in IBM-DOS

Discussion in 'Laptops' started by MAG, Apr 2, 2004.

  1. MAG

    MAG Guest

    Hi folks-

    I'm the proud ownter of a new 256 MB IBM USB memory key ( 22P9025 ), and
    I'm using on my T30 laptop.

    Following the instructions that came with it, I set it up so that it is
    bootable as a hard drive recognized by the BIOS. That worked like a
    charm; it boots just fine emulating a HD and comes up with a DOS C:\
    prompt.

    I added in my usual CD drive enabling stuff (an autoexec.bat file, CD
    drivers, etc.) and that also works fine. I can access the CD drive fine.

    But, I'm having trouble mounting my primary hard drive partition(s) to
    be visible. I have a large FAT32 partition that I usually access via
    Win-98 style DOS (from bootable CD), but this partition doesn't mount
    when using the IBM DOS.

    Maybe I need to configure something in the memory key Autoexec.bat or
    Config.sys to get it to work?

    Any help would be appreciated. Probably this is user-error. I'm VERY
    rusty on my DOS stuff.

    Marc
     
    MAG, Apr 2, 2004
    #1
    1. Advertisements

  2. Are you using IBM's PC DOS on the key? Type VER at the command prompt and
    see. IBM PC DOS can not and will not see FAT32 partitions. The ONLY versions
    of DOS that can see FAT32 partitions are the DOSes that came with Windows 98
    and Me. (At least I think I'm remembering this correctly. Someone else will
    jump in set me straight if I'm wrong on the details.)

    Edward Mendelson
     
    Edward Mendelson, Apr 3, 2004
    #2
    1. Advertisements

  3. Only MSDOS ver 6.22 and higher reads FAT32... IBM DOS didnt support FAT32, that
    was a BillGatus of Borg thing..


    TJ
     
    Capt. Wild Bill Kelso, USAAC, Apr 3, 2004
    #3
  4. MAG

    Mike S. Guest

    There is **NO** version of MSDOS released as a standalone product that
    reads FAT32. Only the MSDOS kernels included with Win95b and above (V7)
    can read FAT32, and they were never packaged as separate DOS operating
    systems.
     
    Mike S., Apr 3, 2004
    #4
  5. MAG

    MAG Guest

    Hi Folks-

    Thanks to those who replied. True, it turns out that "IBM-DOS" that
    comes with the key and is installed by the boot utility is not based on
    the 7.x FAT32-enabled version.

    I found a solution, after poking around a bit. In case anyone ever
    googles this question, here's the solution:

    1. I booted from my normal backup utility CD (based on a Win-98 DOS boot
    disk), from bootdisk.com. This disk contains the typical Format, Sys,
    etc. utilities.

    2. Critical note: during the boot process, I had to go into the BIOS and
    set the order as follows:
    -CD ROM (of course, or else it won't boot from the CD)
    -In Hard Drives, set the USB MEMORY KEY BEFORE THE MAIN HARD DRIVE!!!

    If I did not set the memory key before the real HD, after the CD boot
    was done, the FAT32 partition on the HD would be mounted as C: and there
    would be no mounted partition representing the memory key at all.

    Having made the change in sequence, with the USB memory key before the
    primary HD in the boot sequence list, after the CD boots the memory key
    was assigned as the C: drive and the FAT32 partition on the real hard
    drive came up as D:.

    3. Now that the memory key was visible to DOS 7.x, I ran the following
    commands on it:
    Format C:
    Sys C:

    This made it a "DOS-bootable hard disk" as far as the T30 was concerned.

    Then I copied all my usual boot disk files like CD drivers,
    autoexec.bat, and so forth over.

    Rebooting from the memory key, I've got access to FAT32 partitions on
    the hard drive, access to my CD ROM, and Partition Magic and Drive Image
    2002 work fine in this environment. Yea!

    The only thing I don't understand is why, when booting from CD
    originally, I had to change the boot sequence such that the memory key
    was placed before the main HD. This seems very weird. I would have
    expected the FAT32 partition to come up as C: and the memory key as D:
    without this step, but no dice, apparently.

    Anyway, I wanted to document this solution in case anyone else ever
    needs it.

    Marc
     
    MAG, Apr 3, 2004
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.