1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

IBM t20 will only show IBM logo and afterwards just a blank screen

Discussion in 'IBM Thinkpad' started by linuxfoo, Jan 7, 2004.

  1. linuxfoo

    linuxfoo Guest

    Hello
    i have a t20 and at boot it will only show IBM logo and afterwards
    just a blank screen, no error codes, no beeps. i even tried to go into
    the setup so when i press F1, it says its entering setup, but blanks
    out just like hwne it tries to boot.

    so basically i can not even get into bios, i even tried to get into
    the bios without the HD installed, still nothing. can anyone shed some
    light on this issue please?

    thnxs
     
    linuxfoo, Jan 7, 2004
    #1
    1. Advertisements

  2. linuxfoo

    Barry Jones Guest

    Take out the backup battery (it's under the regular battery). If the
    unit boots, replace the backup battery.
     
    Barry Jones, Jan 7, 2004
    #2
    1. Advertisements

  3. First of all, make sure you have a partitioned hard drive installed.
    Without a hard drive, a T20 will take forever to enter BIOS
    Next, pop the keyboard and re-seat the CPU. THis is a common problem.
     
    Bruce Markowitz, Jan 7, 2004
    #3
  4. linuxfoo

    Jim Walker Guest

    With your same symptoms I had a motherboard failure on a T20.
     
    Jim Walker, Jan 8, 2004
    #4
  5. linuxfoo

    longqvo Guest

    I have the same problem with my T20, when I tried to boot it up it was
    either a blank screen or stuck at the screen where it says press f1 to
    enter bios. What I did was I removed the everything from HD, ram,
    NIC/modem, CD/floppy, etc.. and tried too boot it from there to see if
    I at least get an error beep or soemthing. Then start putting things
    back one by one too see which one is giving you the problem. My
    problem turn out to be the RAM, i just clean the tips of it with a
    eraser and some rubbering alcohol and it booted up fine.

    Also reseating the CPU might help also, I had another problem where it
    would lock up with the ac adapter plugged in reseating it, solved the
    problem.

    http://www-306.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-4UYM3F
    for the manual on how to get to the CPU
     
    longqvo, Jan 8, 2004
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.