1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

IBM T5240 memory failing

Discussion in 'Sun Hardware' started by geoffrey.falk, Feb 17, 2009.

  1. Probably not the best place for it (waiting for Sun support on initial
    warranty coverage, anyway) but I'm tossing this out here since this
    may have been seen elsewhere.

    The last several T5240's we've gotten have not been able to recognize
    more than 32 GB, 4 GB sticks in the D0 channels for both CPU's.
    Everything in D1 is Forced Fail (IBIST) according to the ILOM output
    in a 12 or 16 DIMM configuration. The mezzanine is a non-starter if
    the baseboard memory config isn't working so it's not even included in
    the trouble-shooting at this point.

    Where this gets weird, if I swap out the D1 memory sticks and put them
    in the D0 slots, they work just fine, and the D1 slots are still the
    ones failing so it doesn't appear to be individual memory. Thinking
    it might be power issues I yanked the extra hard drives, threw it on
    240V circuits which the system saw as 211 and 213V for the two power
    supplies, but still received the same errors. I've got the most
    recent firmware tracks (7.2.0 on one box, and 7.1.7f) on another for
    testing but they're both reporting the same issue. I've done the
    usual memory swap through random pieces of memory from the various
    boxes, cleared the faults, but the initial POST sequence after
    executing start /SYS picks them up every time.

    All the memory is Qimonda with Sun labels and the same FRU (371-2145,
    which appears to be the spare part designation for 501-7954 high
    voltage 4GB DIMMs) and comes up under the ILOM correctly matched on
    the part number so I don't think I have mis-labeled memory and given
    the swap between D0/D1 works fine that probably rules that out
    anyway. Short of replacing the memory wholesale or shipping the boxes
    back am I missing anything?

    I haven't worked with Solaris in too long apparently, and the
    documentation I can find simply says swap the memory though I'm
    unconvinced as I can't get anything to fail in the D0 channels and the
    thought of different testing in D0 vs. D1 is just too outlandish for
    me to accept on my own; is there any deeper error reporting I can find
    out through the ILOM or even Solaris tools? I can boot an OS with any
    combination of memory I try so everything in Sun's trouble-shooting
    deck as an end-user should be accessible. Is low voltage memory a
    requirement now? The last two T5240's that we had with an April build
    date worked just fine with this same memory (slightly older firmware
    in the 7.1.7 track from mid-December).

    Any insight or even off-the-wall ideas would be appreciated at this
    point as I've exhausted my bag of usual hardware tricks.

    Thanks,

    Geoff
     
    geoffrey.falk, Feb 17, 2009
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.