1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

IBM X30 and IBM Access Connections with Windows XP

Discussion in 'IBM Thinkpad' started by John, Jun 15, 2004.

  1. John

    John Guest

    I have read several posts regarding the same problem and still haven't
    seen a clear answer or anyone that has successfully corrected the
    problem.

    I have an X30 with wireless built in and Windows XP and the only way
    it will connect with an access point is if I check the box under the
    connection properties that says "Let Windows ."

    I would like the x30 to connect to the wireless networks automatically
    using the IBM Access Connections software, but it is incapable of
    doing that. I'm running IBM Access Connections version 3.20, have the
    newest drivers for the adapter and the newest firmware for the
    adapter. I have uninstalled and reinstalled both the drivers and
    Access Connections with no luck.

    I know I'm not the only one that has struggled with this so if there
    is anybody out there that has fixed this, please let me know.

    Thanks in advance,
    John
     
    John, Jun 15, 2004
    #1
    1. Advertisements

  2. John,
    Wish I could help, but I'm in the same boat. When I let IBM Update
    connector update my system, it hasn't worked correctly since.

    Funny thing, everything looks good. Access Connections shows I'm connected,
    the tasktray icons show I'm connected but I can't see anything on my
    network. IBMs only solution is to not use Access Connections or reload the
    machine. I have the A31p with the same settings and no problems.

    Regards-Michael G.
     
    Michael Gerbasio, Jun 16, 2004
    #2
    1. Advertisements

  3. John

    Gerald Vogt Guest

    I have and had the same problems. For a long while I had the problems
    with a T40 that did not connect to my access point using AC. I don't
    know why but with some update (I think it was version 2->3.0) it all of
    a sudden worked and does since then.

    On my T30 though, it worked well until, well I don't know exactly
    because I usually use the port replicator and ethernet cable, but when I
    tried two weeks ago it did not work and I did not get it to work either
    with de-/reinstalling drivers, AC etc. in different order...

    If you AC shows that you are actually connected then I would say
    something else is wrong. When I connect to an AP with open
    authentication the wireless tasktray icon shows good connection but
    WEP-key error in the status window, the window network connection is
    normal (because the connection is associated), AC is disconnected though
    and no traffic goes through. I never had it that AC actually shows
    connected status even though it was not working...

    I think at some time with my T40 it made a difference whether the AP
    allowed open authentication or required shared. I think (but I am not
    sure) it only worked with shared and not with open...

    Anyway, I guess my problem is related with some security/permission
    problems of AC setting the WEP keys in the wireless card driver as the
    SSID is correct and the card associates with an open auth AP. The only
    way to get it working again is to clean the installation of all traces
    of the wireless driver and AC and install again. I think this should do.
    But you certainly have to know all the registry keys and files the
    both require, and last time I tried I did not really figure out how the
    wireless configuration works and where AC does actually stores all its
    profile information etc...

    Gerald
     
    Gerald Vogt, Jun 16, 2004
    #3
  4. Gerald,
    Thanks for the information. Yes, seeing AC active had me on a wild goose
    chase looking somewhere else. Now, I believe that AC is screwed up. All the
    settings are the same if I use AC or let Windows manage my connections. All
    the animated icons show everything in AC is running fine. I can see the
    network tasktray icon and it never flashes, always showing nothing sent or
    received. Of course, can't even ping the router or AP. Same setting with
    windows configuration for wireless and it works fine. Very
    frustrating.Using Windows works so I'll stick with that.

    My experience is just the opposite of yours, prior to v3, everything worked
    fine on my A31p and X31. Since upgrading I've had nothing but problems on
    both Thinkpads although it is finally working on the A31p. I'm really
    disappointed in IBM tech support, all they ever seem to say is reset the PC,
    load the latest drivers, reset the router and if that doesn't work, reload
    the PC.

    I followed to the letter the instructions that came with driver 1.2.2.9 and
    AC 3.21 still no luck. This required an uninstall which I did, but as you
    said, you really can't be sure it cleaned up everything unless you could
    manually check and clear the registry. I even tried a new file which bundled
    AC with all the drivers to automate the loading of AC. Again, no luck.

    Regards-Michael G.
     
    Michael Gerbasio, Jun 17, 2004
    #4
  5. John

    Gerald Vogt Guest

    Are you sure your AC tray icon shows operating state and not
    disconnected? Mine does realize that it is not connected and shows the
    crossed icon and proper disconnected status. That is puzzling me. If
    yours says it is connected that would be really strange because it
    should not even get the DHCP address. (OK, maybe you have static IP and
    now AC does not know how to figure out whether or not it is
    connected...) The wireless icon (QCWLICON) is green though for the
    association with the open auth AP.

    I can see the
    That the same here. What does the status message for the wireless
    connection shows? (the QCWLICON status window)
    Well it seems to be a very tricky problem, I admit. What I find
    disappointing is that there is no documentation about a special debug
    command line option or something similar to get a little bit more output
    what is going on and what the problem might be. I browsed through the
    DLLs and EXEs with a text editor and find quite a few hints that there
    is actually debug code and logs included. But I was not able to figure
    out how to turn that on and where it goes... I think that would really
    help because I am pretty sure that somewhere during setting the WEP keys
    for the card there is something failing and thus there should be an
    error message somewhere telling something about it.

    The worst is: I don't know of an alternative: Intel ProSET does
    something similar but then IBM must provide it. Despite of these I am
    not aware of a program that does the switching automatically. I know of
    netswitcher, but there you have to do yourself i.e. tell the program
    which profile to apply when you want to switch.
    The new file actually does not even include drivers for my T30 (High
    Rate Wireless LAN Mini-PCI Adapter with Modem II) so I never tried it
    although I updated the power management driver after I looked through
    the contents. Which WLAN cards to you have? Has you AP open or shared auth?

    Gerald
     
    Gerald Vogt, Jun 17, 2004
    #5
  6. John

    John Guest

    I also have tried uninstalling everything and reinstalling (again who
    knows if it uninstalls clean) with still no luck. When I try to make
    a wireless connection with AC by pressing the connect button, I get a
    red x on the "Connecting to wireless access point..." line and it
    doesn't ever connect. As soon as I tell windows to manage the
    connection, I get right in.

    I'll keep struggling, it's a nice utility (AC) and would be even nicer
    if it would work fully.
     
    John, Jun 17, 2004
    #6
  7. John

    John Guest

    I actually finally had some success after my last post. In Windows
    XP, pull of the list of services and go to the bottom to "Wireless
    Zero Configuration" and disable the service. After restarting, AC
    connected to my wireless network. Now, I tried this once before and
    it didn't work but seems to be working great now. I'm also running
    the newest driver and firmware for the adapter as well as the newest
    version of AC and am not sure if I was when I tried disabling the
    service the first time.

    Hopefully this will help some others with the same problem.

    John
     
    John, Jun 17, 2004
    #7
  8. John

    Gerald Vogt Guest

    Bingo. That did it for me. (Well at least for now... ;-) AC configures
    the connection properly. No more WEP key errors as before. As far as I
    can test it at the moment it works fine now... I have never actually
    tried disabling the WZCSVC when I tried to figure out how to fix it. I
    always just stopped the service assuming that it would do to see if it
    makes a change. But you actually have to disable it and then reboot to
    take affect.

    Great job, John!

    Gerald
     
    Gerald Vogt, Jun 17, 2004
    #8
  9. Gerald,
    I'm using static ip. I didn't know that is how AC determines if it is
    connected. All those cute animations would make you think there aren't any
    problems yet I can't even ping the router when it shows it is connected to
    the router.
    I have two tasktray icons, one for the network connection which shows I'm
    connected, the other for the wireless which also shows green with an
    excellent signal.
    With all the problems I've been reading about, you'd think tech support
    could offer something more than reload the PC. Especially with IBM only
    providing restore disks. Setting up multiple partitions is such a pain in
    the ass without the actual Windows CDs. Although I really like the
    Thinkpads I have, this will probably be my last. No glidepad, no windows
    key, only restore disks and tech support that has never offered a solution
    other than "try reloading the system" anytime I call. Lastly, IBM got rid
    of the user forums and I find the web site very diffcult to navigate to find
    a solution compared with Dell.
    I'm using a Linksys WAP11 with two IBM Centrino PCs, a desktop with an
    Orinoco card, a HP4155 PocketPC all on the WLAN. AP is set for shared, not
    open.

    Regards-Michael G.
     
    Michael Gerbasio, Jun 17, 2004
    #9
  10. John,
    I had the service disabled but it didn't work. Same here with the drivers,
    firmware and Access Connections, all latest versions.

    Regards-Michael G.
     
    Michael Gerbasio, Jun 17, 2004
    #10
  11. John

    Gerald Vogt Guest

    I don't know how AC determines if it is connected. The problem is the
    wireless driver shows a connection once it is associated with the AP (if
    you are using open authentication with the AP, this does not happen with
    shared authentication). This does not mean though that you are able to
    send any data over this association as for data transfer you need WEP
    encryption (if you use WEP and 802.11b). If AC is configured to use DHCP
    than it is obvious that you do not have a connection if you do not get
    an IP address assigned (so here). If you have static IP I don't know
    what happens. Again, the problem here is how do you figure out that
    there is a working connection if your wireless card is associated and
    says "you have a connection" without any further assumptions (like ping
    the router/gateway or whatever which all would depend on specific
    functions of other devices...) That's not nice but a good way to test
    this would be to try it with Windows Zero Configuration: set your static
    IP for your network connection, configure it to use open auth (or even
    none should do it) and the card should associate with the AP which may
    or may not signal Windows to consider connected...
    You should have three icons: one for AC (QCTRAY), one for the wireless
    connection (QCWLICON) and one for the network connection. (well, OK, you
    can turn them on and off...) Each one of them signals something.
    The Centrinos are little troublesome anyway. I ended up upgrading to a
    abg card because I did not want to worry about that thing anymore...

    Anyway, have you tried disabling the Windows Zero Configuration service
    as mentioned in another post in this thread? That seems to solve the
    problem for me...

    Gerald
     
    Gerald Vogt, Jun 17, 2004
    #11
  12. John

    Gerald Vogt Guest

    [Off-Topic first: Michael, try not to full quote the previous post if
    you do not comment on anything there in particular if you use buggy
    Outlook Express which messes up the layout of the citation and makes it
    very hard to read. I quoted intentionally your post at the end of this
    one to show you that...]

    Disabling the service works for me. Just stopping the service when the
    computer is up did not do it. It must be in disabled state so that it
    will not start during boot. If you are sure you have that disabled and
    it is still not working, I would deinstall AC, let it trash all its
    profiles, deinstall the wireless driver. Then reboot.

    When Windows is coming up and tries to install the wireless driver, it
    should prompt you for the driver disk to install the driver. DO NOT
    point to the extracted archives but just abort the dialog and let it
    Windows come up without the driver installed (if Windows knows the
    driver and installs it automatically it may be necessary to rename the
    Windows distribution directory temporarily and deinstall, reboot again...)

    When Windows is up use the setup program of the WLAN driver to install
    the driver. Reboot. Install AC. Reboot.

    Check that WZCSVC is disabled and not running. Configure AC and see if
    it is working...

    This is the installation I did the last time and which seems to work now
    for me. (except I had WZCSVC running which I just disabled today...) I
    hope, this helps...

    And please, think about you full quotes...

    Gerald


    ---- Intentional full quote follows ------
     
    Gerald Vogt, Jun 17, 2004
    #12
  13. Gerald,
    I guess the biggest problem I'm having is I can't uninstall the wireless
    card driver without restarting and having winxp detect the card and
    reinstall it automatically. I tried searching for the files and manually
    deleting them but it always comes back. Any ideas?

    Regards-Michael G.
     
    Michael Gerbasio, Jun 20, 2004
    #13
  14. John

    Gerald Vogt Guest

    I suspected something like that. The setup program of for the drivers
    probably installs/configures some parts of the driver to work properly
    with AC. If you don't use it it won't work. And reinstalling the newest
    driver package doesn't do it either probably because the setup program
    thinks AC/the driver is already configured for that...

    Makes things a lot clearer...

    BTW, do you have the Windows Zero Configuration service disabled or is
    it running?

    Gerald
     
    Gerald Vogt, Jun 21, 2004
    #14
  15. BTW, do you have the Windows Zero Configuration service disabled or is

    I have it disabled. On my PC it was always disabled until I was having
    problems with the latest driver/AC, then I manually had to enable it. When
    I reloaded the drivers and AC this last time, it was disabled by default.

    Regards-Michael G.
     
    Michael Gerbasio, Jun 21, 2004
    #15
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.