IC7-G OnChip SATA RAID Problem with Add In PCI RAID Card

Discussion in 'Abit' started by sjconcord, Dec 29, 2005.

  1. sjconcord

    sjconcord Guest

    Hi Folks,

    I added a Highpoint RocketRaid 1640 SATA controller to the PCI
    interface of my IC7-G. With the card installed, I don't get access to
    the OnChip Intel SATA RAID ROM. The Intel RAID seems to work okay
    within XP but I can't access the interface (Ctrl-I) when the system is
    booting. The prompt never appears. I have tried all the PCI slots and
    get the same results. I also noticed that with the RocketRaid
    installed, I don't get access to the ROM prompt of a Symbios Logic SCSI
    controller I have installed.

    Is there any setting in the motherboard I can try that will allow the
    Highpoint card to "play nice" with other ROM based boards? I have the
    latest motherboard and RocketRaid BIOS loaded.

    Thanks,

    Steve
     
    sjconcord, Dec 29, 2005
    #1
    1. Advertisements

  2. Have you tried experimenting with the boot device settings in the upper part
    of the Advanced Setup section of the BIOS? If you set the "Bootable Add-In
    Device" to Onchip SATA-RAID, you should be able to access the Intel
    controller RAID BIOS via the Ctrl-I prompt no matter what other devices you
    have installed.

    To be honest, the IC7-G's BIOS isn't really designed to handle multiple
    bootable external storage controllers, which might be why the Highpoint and
    SCSI controller are arguing with each other. If playing with the
    motherboard's BIOS as suggested previously doesn't give you a workable
    solution, I'd suggest mailing Highpoint Support and detailing the problem to
    them. I've found them quite helpful in the past and you may well have turned
    up an issue they weren't previously aware of.
    --


    Richard Hopkins
    Cardiff, Wales, United Kingdom
    (replace nospam with pipex in reply address)

    The UK's leading technology reseller www.dabs.com
     
    Richard Hopkins, Dec 30, 2005
    #2
    1. Advertisements

  3. sjconcord

    sjconcord Guest

    I did play with the setting you mentioned. It did work initially but
    after a series of reboots it stopped allowing me to see the Intel SATA
    RAID BIOS when the Highpoint was installed. I think the best workaround
    is to turn off the RAID features for all the cards and use a software
    RAID solution by either installing Linux directly on the system, or use
    a Linux virtual machine within VMWare running on XP.

    I have a total of 12 disks I want to configure into a 6x6 mirror. I
    hope that turning off the RAID functions of all the SATA controllers
    (Intel, SIL, and Highpoint 4 port PCI Card) will provide me with 8
    usable ports. I can also install a couple of Promise ATA controllers to
    handle the other 4 drives (using the primary channel only on each
    card).

    Steve
     
    sjconcord, Dec 31, 2005
    #3
  4. sjconcord

    TomG Guest

    one thing I have seen interfere with ROM's on add-in cards is the setting of
    the USB KB and mouse support... frequently, if the USB support is set to
    BIOS as opposed to OS, the BIOS USB support is mapped into the ROM space and
    "steps" on the add-in card ROM. I can see this happen with an add-in SCSI
    card or other devices that have their own ROM and enable/disable the USB
    BIOS support setting.
     
    TomG, Jan 1, 2006
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.