IDE CD ROM devices not detected on boot from Asus P8Z68-V _Pro/Gen3

Discussion in 'Asus' started by Tom McCreadie, Feb 16, 2012.

  1. With a recent pc rebuild based on the Asus P8Z68-V _Pro/Gen3 mobo / i7 2600K /
    16GB Corsair ram, I preferred for various reasons to reuse my two previous IDE
    optical drives (Plextor dvd burner; Lite-On cd rom). As the new mobo has no IDE
    slots, I bought a couple of cheap SATA-to-IDE powered adaptor cards.

    When I boot up, however, the post routine reports the CPU and RAM as Ok, detects
    my two SATA-2 HD's hard drives, but does not find the two optical drives. Thus -
    since neither of the HD's contained an installed OS yet - the boot process
    grinds to a halt with a message like "no bootable device found".

    I can access the bios settings screens but couldn't see anything amiss. Also
    tried plugging the cables in different SATA 3GB sockets etc. But the two
    optical drives remain "invisible" - thus frustrating my efforts to install Win7
    from its dvd.

    Have I overlooked something? Any pointers? Perhaps those dinky SATA-to-IDE
    adaptors are only really intended to work with HD's, not for ATAPI optical
    devices?
     
    Tom McCreadie, Feb 16, 2012
    #1
    1. Advertisements

  2. Tom McCreadie

    Paul Guest

    It's true, that not all SATA-IDE adapters support ATAPI, but you
    detect that by reading the customer reviews. If the adapter
    is a stinker, the rating will be pretty low.

    If you've got a decent computer store handy, about $20 or more
    will get you a new SATA burner. You can think of it as "adding
    a floppy" to your new system, in terms of price.

    Some of the old burners are nice, because they have good
    error scanning capabilities, and shouldn't be discarded
    because of their age. Newer drives may not be suited
    to the best error scanning functions. I use an error scan,
    to judge whether I should buy more of the same media,
    the next time I go to the store.

    Another solution would be a 5.25" USB IDE enclosure, but
    for the price of one of those, you could probably buy a
    couple new SATA burners. I have one of those that I use
    for optical drives, and it works great.

    The only time I find that doesn't work (USB), is for Linux "server"
    installer CDs. Some of those insist the drive be connected
    to a motherboard connector, rather than coming through USB.
    But many other situations don't care about that. I think I've
    also had the Kaspersky Offline scanning CD, do something similar,
    and only work on an internally connected drive.

    Paul
     
    Paul, Feb 16, 2012
    #2
    1. Advertisements

  3. <snip>

    Thanks for the info, Paul. I'd grabbed the adaptor from a local shop. It was a
    "SATA HDD to IDE" from a no-name China manufacturer, so I couldn't really check
    up on any reviews. The spec had "Compliant with Serial ATA specification;
    Supports ATA 100/133", and the charming misspelling: "Converts Sevial ATA to
    Paraller ATA" :)

    My sticking with my previous IDE Plextor burrner wasn't driven by the stingy
    Scottish chromosomes :), but by a wish to retain the use of the Plextor
    software for extensive error checking of the drives. (I burn lots of recorded
    concert cd's for musical societies and like to check the C1, C2 errors etc.)
    Ironically that particular IDE Plextor was purchased only a couple of months ago
    (after my previous Premium- then PX-812A models wore out) and I had to go out
    of my way chase one down amid the plethora of SATA units.

    Yep. guess it's time to just buy a new SATA model...and possibly look out for a
    cheap or used USB enclosure for the IDE devices.
     
    Tom McCreadie, Feb 16, 2012
    #3
  4. Tom McCreadie

    Rob Guest

    As Paul said, some of the cheap adapters definitely don't work with
    optical drives, so I would say it is worth trying another one which
    states it fully supports ATAPI devices before getting a SATA drive.
    One thing to check - the optical drive *must* be jumpered as master
    with these adapters.
    HTH
     
    Rob, Feb 16, 2012
    #4
  5. Tom McCreadie

    Paul Guest

    Good point. If there is no jumper on the device, it could well be
    restricted to Master. Some adapters have a jumper that selects
    Master or Slave, depending on jumper position. There are all sorts
    of construction options, and the thing is, quality adapters
    may be hard to find as IDE falls from view.

    Paul
     
    Paul, Feb 16, 2012
    #5
  6. Good point, Rob, I'd indeed overlooked that my two IDE optical drives were still
    jumpered as Cable Select, from their previous career in the older pc. My renewed
    hope was alas short-lived, for after both devices were rejumpered to Master,
    they still went unrecognized on boot. (And don't you just hate searching for
    tiny jumpers in high-pile beige carpeting? :))

    I've since tried a different brand SATA to IDE adapter whose brief web blurb did
    specifically mention 'CD ROM', but returned it as it also failed to bring in the
    missing ATAPI devices. Unless I'm still overlooking something, it seems to be a
    crap shoot with those adapters. Another option could be expansion to IDE via a
    PCI card , but my mobo PCI slots are already spoken for :)

    Anyway, regaining a sense of proportion, I finally bought a SATA burner..and
    will try off-load the orphaned IDE devices down the family/acquaintance food
    chain. Thanks to Rob & Paul, for the input. Much appreciated.
     
    Tom McCreadie, Feb 18, 2012
    #6
  7. Tom McCreadie

    GMAN Guest

    Make sure that the SATA ports you are trying to put those adapters on in the
    BIOS are set for Compatilbe and NOT AHCI or enhanced
     
    GMAN, Feb 18, 2012
    #7
  8. Sorry for the delay in reporting back.
    At your advice, I toggled the Bios settings as follows:
    SATA Mode: 'ACHI Mode' (default) => 'IDE Mode'
    Serial-ATA Controller 0: 'Enhanced' (default) => 'Compatible'
    Serial-ATA Controller 1: 'Enhanced' (default) unchanged

    Still no joy, though. My new SATA Plextor shows up but the older IDE Plextor is
    still unrecognized. Looks like a classic case of "Lost in Translation" :)
     
    Tom McCreadie, Feb 23, 2012
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.