iMac will not boot ISO CD and will not bring up the Boot menu withoption button

Discussion in 'Apple' started by KDawg44, Jan 10, 2008.

  1. KDawg44

    KDawg44 Guest

    I have an old iMac (I have no idea what it is - I have never worked
    with a Mac before, it has a green back and runs Mac OS 9.2). I need it
    to be LAMP server for an application and so downloaded the Ubuntu
    Server 6.06 PPC ISO and burned it to a CD. I tried to boot to the CD
    from the iMac and nothing was happening ( c button). I also tried
    booting and hitting the OPTION button (repeatedly before throwing the
    keyboard) and I could not even get the boot menu.

    I need to get Ubuntu Server running because I need this to be a LAMP
    server to run a PHP/MySQL app for a small business that cannot buy a
    new machine.

    Has anyone seen this before? Is there another way to make an iMac
    boot to CD?

    Thanks for any help.
     
    KDawg44, Jan 10, 2008
    #1
    1. Advertisements

  2. KDawg44

    David Empson Guest

    Either "Lime" or "Sage". There were a total of four iMac generations
    which included a green model. The first two generations which include a
    "Lime" model differ only in CPU speed (266 or 333 MHz), and have a
    tray-loading CD-ROM drive which pops out when you press a button on it.

    The third one (iMac DV, also "Lime") runs at 400 MHz and has a
    slot-loading DVD-ROM drive. This model also has Firewire ports, which
    are missing from the older models.

    The fourth one (iMac DV+ "Summer 2000", "Sage" colour) is 450 MHz, has a
    slot-loading DVD-ROM drive, and Firewire. There were also 400 MHz models
    with CD-ROM in that generation, but the information I've found says that
    you couldn't get that combination in Sage.
    The Option key startup disk selector was added in the slot-loading iMac,
    so if your iMac has a tray-loading CD-ROM drive then it won't work.

    If the 'C' key isn't working then I expect the CD isn't set up correctly
    as a Mac boot CD, or the iMac or keyboard is faulty.

    You might try resetting the iMac's parameter RAM, by holding down the
    key combination Command-Option-P-R at startup until it repeats the
    startup chime. (This will at least prove the keyboard is functioning.)

    (Command is the Apple/Cloverleaf key beside the space bar.)

    I haven't tried booting any Linux variant on a Mac so I don't know if
    anything special needs to be done to set up the CD correctly.
    There may be a way to do it via Open Firmware, but I doubt it would work
    any better than holding down the 'C' key, and I don't know what commands
    you would have to type in to achieve this.

    If there are no other bootable volumes, it will try booting from CD
    anyway.

    The other method is to boot Mac OS and use the Startup Disk Control
    Panel (under the Apple menu) to select a bootable volume as the startup
    disk. This would only let you select the CD if it thought it was
    bootable.
     
    David Empson, Jan 10, 2008
    #2
    1. Advertisements

  3. KDawg44

    KDawg44 Guest

    THank you both very much for the information. I will take a further
    look when I get home.

    Thanks very much.
     
    KDawg44, Jan 10, 2008
    #3
  4. KDawg44

    KDawg44 Guest

    I think I downloaded a bad ISO. I downloaded from a different mirror
    and it worked.

    Thanks for all your help.
     
    KDawg44, Jan 11, 2008
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.