Image Capture app won't capture via scanner

Discussion in 'Apple' started by Countryman, Jan 11, 2007.

  1. Countryman

    Countryman Guest

    I have an HP PSC 1510 (it is an all in one jobbie). I have the HP drivers and
    scanning software installed and that work fine. However if I try to scan via
    the Image Capture app I get the error "no image capture device connected".

    Looking under devices/browse devices I can see that an "HP All-in-One Scan
    DS" appears under Twain but if I highlight this and click connect I get the
    "no image capture device" error again.

    Any ideas please?

    many thanks
     
    Countryman, Jan 11, 2007
    #1
    1. Advertisements


  2. I have the same HP PSC 1510. I don't use Image Capture, but HP Image Zone
    (under Hewlett Packard in your Applications folder if you've lost track of
    it.) I had thought that Image Capture was just for transferring photos from
    a digital camera to iPhoto, but I may well be wrong! Anyway, Image Zone
    works perfectly for me, provided I remember to change the settings not to
    scan to text but to jpeg!

    I tried with Image Capture and got the same result as you, so perhaps you
    should just use Image Zone?
     
    Sally Thompson, Jan 11, 2007
    #2
    1. Advertisements

  3. Countryman

    Countryman Guest

    Thanks Sally.

    I guess I have no option other than to use Image Zone and I do. That does not
    detract from the fact that Image Capture is supposed to work with a scanner
    though :)

    Thanks fo confirming the problem. Is is appeciated.

    Colin
     
    Countryman, Jan 11, 2007
    #3
  4. Now this is really weird. I have looked at /Library/Image Capture/Devices
    and it lists EPSON Scanner - I have never owned nor installed an Epson
    scanner. However, in /Library/Image Capture/TWAIN Data Sources sure enough
    there is a file named: HP All-in-One Scan DS.ds

    To the OP: it seems to me (us!) that somehow we need to get the HP
    All-in-One Scanner into /Library/Image Capture/Devices in place of the Epson
    Scanner - but I haven't the least idea how to go about it.

    Thanks for flagging up something I didn't know I was missing!

    (on an iMac G5 PPC with Tiger, by the way)
     
    Sally Thompson, Jan 11, 2007
    #4
  5. It is not necessary to have that ".ds" file in order to scan. It does
    not exist on my iMac G5, the one hosting my Epson all-in-one, only on my
    PowerBook where I've connected remotely.

    In order to get Image Capture on the OP's system to show the HP,
    assuming that its software is all properly installed, and assuming it's
    not already indicated in previous messages as tried, it should be a
    matter of using Browse Devices on the Devices menu (or Command-B) and
    looking for it. There's also a preference setting to open a scanner
    window when IC is launched.

    As for the Epson software being present on a system where no Epson was
    owned, I think it may be included with OS X's drivers, just as it
    includes printer drivers for tons of "common" models from various
    vendors.
    [/QUOTE]

    Thanks for the explanation Steve. Although I wasn't the OP, I found it
    useful. I have been able to Browse Devices in Image Capture (ignoring the
    "No Image Capture device connected" message and find my scanner. I had to
    tick "Use Twain software" to get it accepted. I still get the error message
    but at least I have something to experiment with, so thanks again.
     
    Sally Thompson, Jan 12, 2007
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.