Impossible to enable DMA- Tried Everything.

Discussion in 'Asus' started by Steve, Oct 3, 2005.

  1. Steve

    Steve Guest

    Used a drive from another build with the same Asus P5WD2 Motherboard
    and can't get Windows to enable DMA transfer. Am only mentioning that
    because when Windows first booted, both of my optical drives were not
    listed in Explorer.

    In Device Manager>Secondary IDE Channel>Advanced Settings, this is what
    it looks like:

    Device Type: Auto Detection
    Transfer Mode: DMA If Available
    Current Transfer Mode: Not Applicable

    Why is it reporting "Not Applicable" in both Secondary Channels if I am
    able to burn CDs and DVDs?

    The CDs are burning at a normal rate but a ~4.37 GB DVD is taking about
    40 minutes to burn. I have tried practically everything in the book:

    Uninstalled the Drivers
    Deleted both burners with the Device Manager
    Changed the existing round cable to ribbon
    Changed the ribbon back to round cable
    Checked the BIOS and both Burners are recognized
    BIOS Settings for these drives have the default setting of Auto

    Haven't attempted the registry fix yet in HKEY_LOCAL_MACHINE \ SYSTEM \
    CurrentControlSet \ Control \ Class \ {4D36E96A-E325-11CEBFC1-
    08002BE10318} because the guide was written before WinXP was released
    and values are listed differently in the registry.
    "MasterIdDataChecksum" is not listed.

    "if the troublesome drive is the master, delete the
    "MasterIdDataChecksum" named value. Or, if the troublesome drive is the
    slave, delete the "SlaveIdDataChecksum" named value. Reboot. The OS
    will redetect the device DMA capabilities after reboot.Note that for
    many older CD-ROM drives DMA can not be enabled in Windows"

    And to add more icing on this Cake; Both drives will not boot from CD -
    My boot sequence is listed as: Floppy, CD, DVD. The DVD-R drive is set
    as Master and CD-R as Slave. I've been fighting with this DMA issue for
    the past two days and rebooted the computer too many times to remember-
    Please help, I'm going nutZ.

    INTEL P4 630
    Asus P5WD2 Premium
    VGA ASUS EN6200TC256/TD/64M RTL
    CORSAIR XMS2 DDR2 SDRAM DDR2 675 (PC2 5400)
    ANTEC TPII-430ATX RTL


    Thanks -
     
    Steve, Oct 3, 2005
    #1
    1. Advertisements

  2. Steve

    Frank Eden Guest

    Frank Eden, Oct 3, 2005
    #2
    1. Advertisements

  3. Steve

    Steve Guest

    This update was installed and it is possible to boot from CD but in
    the Device Manager>Secondary IDE Channel>Advanced Settings, nothing has
    changed. Current Transfer Mode is still "Not Applicable".

    I disconnected the CD-R and am only using one burner. This would not install, the reason was: "Incompatible hardware. This
    software is not supported on this chipset"

    Thanks for replying -
     
    Steve, Oct 4, 2005
    #3
  4. Hi Steve,
    I've had a similar problem, I have made this to help people along :




    Most people have problems burning CD's, when DMA in on, however a few
    of us
    burns fine with DMA on, however we experience, that the computer has a
    mind of
    it's own, at switches to PIO mode apparently on it's own.

    I've got some good news and I have got some bad news for you.

    First the bad I don't know why this happens, nor do I have a
    permanent fix
    for you!

    The good I do have a fix, that sets your Plextor to DMA mode in
    less than
    4 seconds, if you follow this instruction.

    I had an Asus K7M board, I had The Plextor 12/10/32a as primary on the
    secondary
    channel, and a CD as slave on the secondary channel. On this setup I
    couldn't
    run both as DMA, the system would freeze during operation, so the
    Plextor was
    DMA and the CD was PIO. A few days ago I upgraded to MSI K7T PRO2-a,
    and on this
    system both the Plextor and Cd will run DMA simultanusly.

    Unfortunately on both systems the Plextor would get reset to PIO on
    it's own -
    usually after 'sleep' mode, some kind soul send me a workaround.

    You need to find this path in your registry:
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}
    In my present setup there is 7 keys under this path:
    0000
    0001
    0002
    0003
    0004
    0005
    Properties

    In my old setup the information I needed was in Key: 0002, but when
    the
    workaround didn't work with my new MSI board, then I sought the reason
    why, and
    found, that key 0002 and 0005 (presumably installed with the new
    motherboard),
    had the same information, and that the new motherboard takes it's
    information
    from key 0005. So if this doesn't work on the default key 0002, look
    into one of
    the other keys, and see if the information is there too, then maybe
    the system
    gets the information from there - You will then have to change the
    line:
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0002]
    to the key with the information in, which on my system is:
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0005]

    The information is (you can copy it, and save as DMA_ON.reg if you
    want to):

    -------


    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0002]
    "EnumPropPages32"="storprop.dll,IdePropPageProvider"
    "InfPath"="mshdc.inf"
    "InfSection"="atapi_Inst_secondary"
    "ProviderName"="Microsoft"
    "DriverDateData"=hex:00,40,99,31,33,2e,bf,01
    "DriverDate"="11-14-1999"
    "DriverVersion"="5.0.2183.1"
    "MatchingDeviceId"="secondary_ide_channel"
    "DriverDesc"="Secondary IDE Channel"
    "MasterDeviceType"=dword:00000002
    "SlaveDeviceType"=dword:00000002
    "MasterDeviceTimingMode"=dword:00000410
    "MasterDeviceTimingModeAllowed"=dword:ffffffff
    "MasterIdDataCheckSum"=dword:000223db
    "SlaveDeviceTimingMode"=dword:00000410
    "SlaveDeviceTimingModeAllowed"=dword:ffffffff
    "SlaveIdDataCheckSum"=dword:00009186
    "UserMasterDeviceTimingModeAllowed"=dword:ffffffff
    "UserSlaveDeviceTimingModeAllowed"=dword:ffffffff


    ------

    The settings for:
    "MasterDeviceTimingMode"
    "MasterDeviceTimingModeAllowed"
    "UserMasterDeviceTimingModeAllowed"
    are different for UDMA, DMA and PIO mode.

    If you set it like above you will get DMA on both channels, if your Cd
    on the
    secondary channel can run UDMA, then change the key:
    "SlaveDeviceTimingMode"=dword:00008010
    which is UDMA.

    You could also export the Key above, and just make the necessary
    changes to
    "MasterDeviceTimingMode"
    "MasterDeviceTimingModeAllowed"
    "UserMasterDeviceTimingModeAllowed"
    and leave the slave at it's present settings, then save it as a REG
    file.

    Once you have done this, then run the REG file, it will ask you
    whether you want
    to add the information to the registry, when you answer YES, you will
    get a
    confirmation, that the information has been added to the registry, and
    then the
    Plextor is in DMA mode again .... until next time it decides to go
    into PIO
    mode. I have a copy of DMA_ON.reg on my desktop, and I use it if the
    Plextor is
    in PIO mode, the change happens 'on the fly', no need to reboot.

    Sorry I didn't have a permanent solution, hope this makes the pain
    easier to
    live with, until someone comes with a BIOS upgrade, IDE Driver or
    system patch,
    which permanently solves the problem.

    I DO know that once Windows 2000 decides that the Plextor is only PIO
    mode
    capable, then nothing 'normal' will pursuade it otherwise. But if it's
    a fault
    on Windows side, or that the Plextor gives wrong information to
    Windows about it
    self, or the IDE drivers reports the wrong settings - I don't know.

    I've noticed, that upgrades of the Plextor Bios and IDE drivers cause
    a new scan
    of hardware, and the Plextor once again becomes DMA, but once it's set
    to PIO
    with these drivers, then Windows remember this setting and won't let
    you change
    it normally.

    So even downgrading the BIOS won't reset it to DMA, if Windows once
    has decided
    that with this BIOS it's only PIO capable, or with these drivers it's
    only PIO
    capable, then 'it's forever'!!
     
    Leif Nordmand Andersen, Oct 4, 2005
    #4
  5. Steve

    Tim Guest

    changing more to DMA can occur automatically in Windows if there are IO
    problems talking to the disc drive (not IO issues with the disc). E.G. when
    there is a shoddy cable.

    Try a different cable.

    Check your BIOS settings.


     
    Tim, Oct 4, 2005
    #5
  6. Steve

    RonK Guest

    You do have the 80 wire cables installed ?
     
    RonK, Oct 4, 2005
    #6
  7. Steve

    Frank Eden Guest

    Hi Steve,

    is there a BIOS option to enable AHCI mode for the southbridge. This read in
    the accompanied readme on Intels website.
    And trying changing the cables.

    Greetings,

    Frank
     
    Frank Eden, Oct 4, 2005
    #7
  8. Steve

    iGoR Guest

    Try the CD-R on cable select and the DVDRW as master. I have run into a
    similar problem before
     
    iGoR, Oct 5, 2005
    #8
  9. Steve

    Steve Guest

    I installed the burners using the ribbon which was supplied by Asus in
    the P5WD2 box and purchased a round cable from Compusa for the Optical
    Drives which also has 40 pins/wires.

    Could the 40 pinned cable be causing all these problems with DMA?

    Thanks for replying -
     
    Steve, Oct 5, 2005
    #9
  10. Steve

    Steve Guest

    Just tried this suggestion and the Current Transfer Mode still is
    listed as "Not Applicable" in the Secondary IDE Channel.

    Thanks for any help -
     
    Steve, Oct 5, 2005
    #10
  11. Steve

    Steve Guest

    There is an option in the Main Window > IDE Configuration > Configure
    SATA As Selected -

    [Standard IDE] <--- which is the Default Setting
    AHCI
    RAID

    This is the only place that "AHCI" is mentioned. Did a search at Google
    and found out that if this option was enabled, I would have to
    reinstall Windows to gain any benefits from this change.
    Are all these problems DMA problems with my CD & DVD Burners related to
    the 200GB Seagate SATA Hard Drive that I am running?


    Thanks once again -
     
    Steve, Oct 5, 2005
    #11
  12. Steve

    Muttley Guest

    Check my guess for duplicate post in alt.comp.hardware

    Cheers,

    John S.
     
    Muttley, Oct 5, 2005
    #12
  13. Not Applicable is supposed to mean there is NO device in that location,
    not that it is running in PIO mode. Are you sure that is actually the
    channel where the drives are hooked up? Try View - Devices by connection.
     
    Robert Hancock, Oct 6, 2005
    #13
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.