1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

impossible to upgrade bios and embedded controler on T40

Discussion in 'IBM Thinkpad' started by melaneum, Apr 1, 2005.

  1. melaneum

    melaneum Guest

    Hi,
    I've tried to upgrade the bios and the embedded program on my ibm t40
    thinkpad (resp. version 1.03 and 1.02). Following the instruction on
    the IBM website, i began with the embedded program first.

    After starting the upgrade program (non-disk), and followed the
    instruction (close all program, plug AC...), the computer switches off
    and restarts immediately, but hang on a blue screen (complitely blue,
    without any message) and a loud beep. After 5 to 10 min, starting to
    wonder if anything was normal, I switched off the computer (pressing 3s
    on the power button). Then, i press again the power button, and the
    computer restarted normally, but nothing was updates. I've tried
    several times, and the same symptoms occur and I can't update it.

    As anybody else encounter the same problem ? Any suggestion appreciated
    !

    Melaneum
     
    melaneum, Apr 1, 2005
    #1
    1. Advertisements

  2. melaneum

    DAve Allison Guest

    IBM PC Support has a new ONE TOUCH upgrade for all drivers including
    bios. Go to www.pc.ibm.com/support and look for "detect my system".
    click on that. and then on the next screen. See:Update your ThinkPad
    drivers and software automatically 2005-03-15
    click on that. and it will check all drivers and automatically install
    them. wow. wow.
     
    DAve Allison, Apr 1, 2005
    #2
    1. Advertisements

  3. melaneum

    Sapper Guest

    Another problem (slight) could be the downloaded file is bad. I would
    download it afresh and try again.
     
    Sapper, Apr 1, 2005
    #3
  4. melaneum

    Jan Andersen Guest

    Few days ago I had the same kind of problem with my T30 (BIOS Version 2.08).
    First I let the new software installer (V. 3.01.0503) do the job but the
    installation hung while in BIOS. Then I downloaded the same file manually
    with the same result.
    Finally I downloaded the Floppy version and there was no problem installing
    it.
    So my conclusion was that the eflash file available was defect or not
    perfect.

    JA
     
    Jan Andersen, Apr 1, 2005
    #4
  5. melaneum

    melaneum Guest

    I finally managed to solve the problem, probably coming from an option
    in the old BIOS: after resetting the BIOS, the update worked perfectly.
    True that the IBM PC Support works great !
    Thanks.
     
    melaneum, Apr 2, 2005
    #5
  6. melaneum

    Jan Andersen Guest

    Yes, setting BIOS to Default could possibly have made my eflash BIOS work on
    my T30, too.

    JA
     
    Jan Andersen, Apr 3, 2005
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.