1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Installing and Running Debian Linux on U10

Discussion in 'Sun Hardware' started by dmoore, Jan 30, 2006.

  1. dmoore

    dmoore Guest

    Hi,

    I couldn't find anything like this on the web so I wrote a page on my
    website about my experiences of Installing and Running Debian Linux on
    my SPARC Ultra 10s which someone may find useful.

    http://members.lycos.co.uk/dmoore0100

    Regards
    David
     
    dmoore, Jan 30, 2006
    #1
    1. Advertisements

  2. dmoore

    boera Guest

    Nice review. Some comments:
    1) sound should work, at least it works for me: both the onboard cs4231
    (kernel module cs4231 in case of 2.4.x or snd-sun-cs4231 ALSA kernel
    2.6.x) and my Creative Ensoniq (much better sound). xmms, audacity,
    mpg123 all should work.
    2) I have a Winfast 2000 XP TV tuner which works perfectly with the
    2.4.27 kernel. Unfortunately it locks up the machine with 2.6.9-2.6.15

    I'm using Fluxbox. The performance is good taking into account the age
    of this machine.
     
    boera, Jan 30, 2006
    #2
    1. Advertisements

  3. dmoore

    J.O. Aho Guest

    Maybe he was using Alsa, in Gentoo it works with the 2.6 kernels now, but
    thats not so long ago they fixed it.
    He may be trying with a 29bit sound card, this isn't supported in any kernel
    under sparc linux.

    Had same problem with the gigabit network card I first used, works fine in 2.4
    with sk98lin driver, in 2.6 it don't work with the depricated sk98lin nor with
    the new skge driver. So had to switch cards which works in both.

    I'm using ctwm, been my favorite since I run it on Sparc Classic with SunOS.



    By the way, anyone got the Creator3D to work on an U10 running xorg and with
    kernel 2.6.x? This is the only thing that has kept me from switching to 2.6,
    in 2.4 the card works fine with xorg.



    //Aho
     
    J.O. Aho, Jan 30, 2006
    #3
  4. dmoore

    John Reddie Guest

    Not sure if this answers any of these U10 questions, but fwiw, and since
    U60 is PCI based too...

    I'm running twin head Creator3Ds on Debian U60 (not U10). They were OK
    under 2.4.27 and, after the usual tweaks for keyboard and mouse settings
    (no longer defined as Sun types), under 2.6.8-2 too. I stopped at
    2.6.8-2 because that's a built package which installed painlessly with
    apt on my Debian system. One day perhaps I'll push it forwards (2.6.8-2
    has the 2.6.8 file system bug fixed btw), but for now it works, and
    that'll do.

    Bog standard EOM Creative PCI sound card worked without any fuss under
    both kernels.

    Networking all fine, but using onboard U60 hardware of course and not
    PCI cards.

    I've resisted the temptation to try and switch to either xorg or a later
    version of XF86Config. Since the majority of the X config (for the
    displays that is) is ignored because we're running framebuffers I can't
    see the point of upgrading if it works :)

    And yes, Xinerama is running fine now too after some initial hiccups
    getting the monitors "matched"...

    I can't, yet, make a PC PCI firewire card work, but I've been reading
    the threads here and am on the lookout for one from a Mac! I suspect
    that part of my problem may well be that my firewire drives are HFS+ and
    while I've loaded the relevant modules, that's too many variables to
    troubleshoot so later this week I'll format a drive EXT3 and try that...

    John
     
    John Reddie, Jan 30, 2006
    #4
  5. dmoore

    J.O. Aho Guest

    Okey, you haven't tried any later kernel then. I'll have to test and see if I
    get the 2.6.8 to work with my UPA based Creator3D (it's the UPA that is said
    to be the cause to the problems)

    So what version of XF86 are you using?



    //Aho
     
    J.O. Aho, Jan 30, 2006
    #5
  6. dmoore

    John Reddie Guest

    4.0 I think! Certainly pre 4.3. Standard version that installed with
    Debian Sarge 3.1.

    John
     
    John Reddie, Jan 30, 2006
    #6
  7. I have a Realtek PCI NIC which works just fine both with Linux
    (8139too) and Solaris (rf driver
    http://homepage2.nifty.com/mrym3/taiyodo/eng/). Actually my Sun Ultra 10
    is a router for my home network.

    Regards,
    Attila
     
    Boer Attila Laszlo, Feb 1, 2006
    #7
  8. dmoore

    J.O. Aho Guest

    Did compile the 2.6.8.1 kernel for the U10 and YES!!! Xorg did work for the
    first time with a 2.6 kernel for me too. With kernels 2.6.13 to 2.6.15.1 the
    UPA Creator3D don't seem to work with X (bad crash in the kernel).

    So stay with the 2.6.8 kernel if you want to be able to use X. I hope that
    this will be soon fixed, so that we too can use new features in the kernel and X.


    //Aho
     
    J.O. Aho, Feb 1, 2006
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.