1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Installing Latest XP drivers - ACCESS IS DENIED

Discussion in 'Nvidia' started by J, Feb 3, 2004.

  1. J

    J Guest

    Been trying to update drivers for GF3 for 2 hours now.

    Tried deleting old drivers manually, deleting with nastyfileremover,
    installing the new drivers in a number of different ways...

    I turned off Sophos Virus check as best as possible (there is one file that
    you can't stop in Task Manager or manually). managed to update like that
    before with no problems.

    I keep getting "access is denied" message just as the update is about to
    finish. Searched google and nothing useful there...


    Any ideas?

    Thanks

    Joel
     
    J, Feb 3, 2004
    #1
    1. Advertisements

  2. J

    Mangyrat Guest

    have you tryed loging in as the adminstrator?
     
    Mangyrat, Feb 3, 2004
    #2
    1. Advertisements

  3. J

    J Guest


    I'm in as admin. I have made loads of system adjustments, installations etc.
    Its just this driver won't install for some reason.
     
    J, Feb 3, 2004
    #3
  4. J

    SleeperMan Guest

    Do you by any chance get any illegal data or similar message? If so, go to
    c:\Windows\System32\Catroot2 and in there delete file edb.log. Normally it's
    shown as text file. Make a backup and delete it. then retry. File will
    re-create itself (it can happen that it gets corrupted)

    Also read below message, if there's of any help.

    Problem: When Trying To Install Hardware And/Or Drivers - error message is
    "There was a problem installing this hardware :Hardware Name. An error
    occurred during the installation of this device. The data is invalid." This
    problem is occurs because the registry will not allow writes to the driver
    information keys.

    FIX: To fix this problem, go to Start, Run... and type "regedit" without the
    quotes, to run the Registry Editor. Navigate your way down to:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ ENUM\PCI

    and you will see a number of keys in the form of "VEN_xxxx", where xxxx are
    strings like "1102&DEV_0004&SUBSYS_00011103&REV_04". Under each of these
    folders will be another folder with a long numerical name. Open each folder
    and look for the "DeviceDesc" which matches the hardware you are trying to
    install.
    Right Click on the "VEN_xxxx" for that device and select 'Permissions' and
    then tick "Allow" for "Full Control". Close Regedit and then continue with
    the installation of your device. You should not need to reboot after you
    close regedit but some people have found that they do.
     
    SleeperMan, Feb 3, 2004
    #4
  5. J

    J Guest




    Thanks for the reply, but that is a different problem.

    When updating to latest Nividia drivers, I keep getting "access is denied"
    message just as the update is about
    to finish.

    Can't install drivers.



    Please help!

    joel
     
    J, Feb 4, 2004
    #5
  6. J

    SleeperMan Guest

    do you have by any chance Nvidia tray icon running - tryto shut it down.
    Also did you try selecting standard VGA driver for your card, then uninstall
    old drivers, then install new ones?
     
    SleeperMan, Feb 4, 2004
    #6
  7. J

    snowfreeze

    Joined:
    Dec 9, 2008
    Messages:
    1
    Likes Received:
    0
    Hey guys...

    I know I'm responding to a really old post, but I'm getting some similar errors on my girlfriend's old pc (I cleared a few viruses off of it, and I think that they are responsible, but I'm not sure). Anyhow, Win XP Pro and I get:


    "Hardware Update Wizard
    Cannot Install this Hardware
    There was a problem installing this hardware:
    Multimedia Audio Controller
    An error occurred during the installation of the device
    Access is denied.
    Click Finish to close the wizard."


    When attempting to update the audio driver. I've tried everything previously suggested in this thread, but nothing is working.

    Thanks in advance... :)
    Jack
     
    snowfreeze, Dec 9, 2008
    #7
  8. J

    Dark Phantom

    Joined:
    Feb 8, 2016
    Messages:
    1
    Likes Received:
    0
    I've fixed mine. I was trying to install my VIA/S3G Unichrome Pro IGP (I accidentally uninstalled it) when this "Cannot install this hardware" window pops up. It also says "Access is denied". Well I used two solutions:

    1. Run cmd in any administrator account then type this line:

    secedit /configure /cfg %windir%\repair\secsetup.inf /db secsetup.sdb /verbose

    (Well this one didn't helped me. So I keep "googling", and found the second solution that helped me, here is it)

    2. Second solution, download the SubInACL from https://www.microsoft.com/en-us/download/details.aspx?id=23510 then install it, don't worry, it's less then 1 MB. Run cmd in any administrator account and type this line one by one after each is done:

    cd /d "%ProgramFiles%\Windows Resource Kits\Tools"

    subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=administrators=f /grant=system=f

    subinacl /subkeyreg HKEY_CURRENT_USER /grant=administrators=f /grant=system=f

    subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=administrators=f /grant=system=f

    subinacl /subdirectories %SystemDrive%\ /grant=administrators=f /grant=system=f
     
    Last edited: Feb 8, 2016
    Dark Phantom, Feb 8, 2016
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.