1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Intel wireless 2200bg on Dell D610

Discussion in 'Laptops' started by hsiacc, Mar 10, 2006.

  1. hsiacc

    hsiacc Guest

    We need to put an Intel 2100b mini PCI wireless card (which came out of
    a Latitude D600) into a Latitude D610. It had originally come with an
    Intel 2200bg which we needed to put into another machine. When we put
    the 2100b into the D610, the POST says installed wireless card not
    supported...F1 to continue... etc. I thought mini PCI is mini PCI, like
    if I bought a PCI video card I would expect it to work in almost every
    PCI slot out there. Any ideas on how to make it work??
     
    hsiacc, Mar 10, 2006
    #1
    1. Advertisements

  2. hsiacc

    zwsdotcom Guest

    It is fairly common for notebook vendors to BIOS-lock their machines so
    they will not work with third-party cards. This is partly for FCC
    reasons (since the antenna arrangement was only tested with specific
    card(s)) but I think mostly for revenue reasons.

    The card will physically work, but the BIOS sees an unrecognized
    VID/PID and disables it.
     
    zwsdotcom, Mar 10, 2006
    #2
    1. Advertisements

  3. hsiacc

    Jerry Park Guest

    I don't think Dell does that, but their install software often check to
    see if the device is 'approved' for that hardware. A change in the
    install software can usually correct that.

    Ask on the Dell forums:
    http://forums.us.dell.com/supportforums/board?board.id=si_wireless
     
    Jerry Park, Mar 10, 2006
    #3
  4. hsiacc

    zwsdotcom Guest

    Read the original post. The machine is reporting the error at POST.
    Nothing to do with installed software.

    It's possible a BIOS upgrade might fix it, if this is a Dell card. But
    I wouldn't count on that.
     
    zwsdotcom, Mar 10, 2006
    #4
  5. hsiacc

    Jerry Park Guest

    It could also be a simple change in the BIOS settings would fix the POST
    problem.
     
    Jerry Park, Mar 11, 2006
    #5
  6. hsiacc

    JHEM Guest

    This is how we resolve this problem on Thinkpads, perhaps it will assist
    you:
    http://www.thinkwiki.org/wiki/Problem_with_unauthorized_MiniPCI_network_card
     
    JHEM, Mar 11, 2006
    #6
  7. hsiacc

    zwsdotcom Guest

    The check and lock is there intentionally. I would bet cash that there
    is no setting to disable it.
     
    zwsdotcom, Mar 11, 2006
    #7
  8. hsiacc

    Jerry Park Guest

    One of the reasons I buy Dell computers is they don't play those games,
    locking you into 'approved' devices. However, as I noted, their install
    software does check the machine and may balk at installing on a machine
    which is not listed in the install program.

    I really do suspect that the BIOS has a setting where the computer
    expects a certain device in the mini-pci slot, and changing that setting
    would fix the problem.

    My computer (Inspiron 8200) came with a Dell 1180 broadcom card. The
    BIOS had that device listed as in the mini-pci slot. When I changed
    cards, I just deleted that entry. It now says 'unknown device', which is
    fine.
     
    Jerry Park, Mar 11, 2006
    #8
  9. hsiacc

    hsiacc Guest

    I posted the same question on Dell forums, and this is one response I
    got:

    This laptop has ICH6(Input Output Controller Hub Ver 6) Chipset
    controller. Intel has confirmed that Intel Pro/Wireless 2100 card will
    not work with laptops based on this chipset. The cards supported on
    this chipsed are Intel 2200/2915 and Dell 1370/1470.
     
    hsiacc, Mar 13, 2006
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.