1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Internal disk problems on Ultra-80

Discussion in 'Sun Hardware' started by Peter Lemmond, Sep 4, 2003.

  1. I loaned out a working, 2-yr old Ultra-80, worked fine for another 5
    months, then the borrower reported that the internal system disk (18GB
    IBM) died. When it came back to me, I found I could probe-scsi-all and
    see the disk correctly, but when accessing later would always report
    "...Sense Key: Not Ready...", "...ASC: 0x4 (LUN Not Ready)...". Same in
    either lower or upper slot. So I bought another disk (18GB Seagate), and
    I get the same result (probe-scsi-all passes, but can't access). Same in
    either slot, tried disks in both slots, same thing. I think I ran and
    passed the Openboot (3.23) SCSI test (came back with "TEST=selftest"),
    no other problem.

    I can attach an external SCSI disk, access is normal.

    Any ideas? Trying these disks in a different Ultra-80 or Ultra-60 might
    be possible, though a hassle, and would need to be 100% sure no damage
    could possibly occurr to the test system.

    BTW, this system is/was running Solaris 8. I've been using the Sol8 Boot
    CD for testing.

    Thanks,
    -Peter
     
    Peter Lemmond, Sep 4, 2003
    #1
    1. Advertisements

  2. It is certainly odd. Luckily I've never seen anything like that in my
    U80. Here are a few of my thoughts - they might at be some help.

    It sounds like the internal SCSI bus has developed a fault. There is a
    dual channel controller on that machine, with one channel used
    internally and one used externally. So the fact your external disk works
    is not surprising, since they are on different buses.

    Are you booting from an internal CD or an external one ? The internal CD
    uses the same scsi bus as the internal disks, whereas an external CD
    would not. If you are using an internal CD, it could be a fault on the
    CD that is mucking up the SCSI bus. It might be worth removing the
    internal CD and checking it it boots okay without that.

    I'm not about to pull the side off of mine, but is there a cable between
    the motherboard and the backplane to where the drives plug in? If so, it
    might be worth removing that and replugging it back in. If I recall
    correctly, there's a cable that plugs onto the internal CD that has the
    termination on that.

    Do you have a Sun disk you could try it with ?

    The OBP you have is not the latest, so it might be worth trying an
    upgrade, although it suggests the there is a hardware fault. Just be
    100% sure the media that you use to upgrade it from (i.e. boot disk) is
    functioning okay, although there is a way of recovering a failed upgrade
    on the U80.

    --
    The day Microsoft makes something that doesn't suck is probably the day
    they start making vacuum cleaners." -Ernst Jan Plugge.

    Dr. David Kirkby,
    Senior Research Fellow,
    Department of Medical Physics,
    University College London,
    11-20 Capper St, London, WC1E 6JA.
    Website: http://www.medphys.ucl.ac.uk/~davek
    Author of 'atlc' http://atlc.sourceforge.net/
     
    Dr. David Kirkby, Sep 11, 2003
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.