Internal harddisk (= startvolume) does not appear on desktop

Discussion in 'Apple' started by manfred.kooistra, Sep 19, 2007.

  1. Hello, maybe someone can help me with this:

    Since this morning the symbol for my internal harddisk (which is also
    my startvolume !) does not appear on my desktop anymore. All programs
    and files work fine, and external volumes appear as usual. Also, I can
    access all folders on my HD from the Finder via "Go to" > "Go to
    folder ..." [roughly translated from German]. Only the HD itself
    remains gone.

    What could be the problem? What can I do about it?

    Any ideas are greatly appreciated. Thank you.

    My system:

    Mac OS 10.4.10
    Dual 1.25 GHz PowerPC G4
     
    manfred.kooistra, Sep 19, 2007
    #1
    1. Advertisements

  2. manfred.kooistra

    Guest Guest

    check finder preferences, and in the general tab, make sure that the
    checkbox for showing hard disks on the desktop is checked.
     
    Guest, Sep 19, 2007
    #2
    1. Advertisements

  3. Thank you. Yes, the checkbox for showing hard disks is checked. I
    already made sure of that.
     
    manfred.kooistra, Sep 19, 2007
    #3
  4. A hail-mary: uncheck it, dismiss the panel, open it up and check it again.
     
    Clever Monkey, Sep 19, 2007
    #4
  5. Thank you. No, logging out then in or restarting or emptying parameter
    RAM don't change anything.
     
    manfred.kooistra, Sep 19, 2007
    #5
  6.  
    manfred.kooistra, Sep 19, 2007
    #6
  7. manfred.kooistra

    David Empson Guest

    How many icons are on your desktop? If your desktop is full, the hard
    drive icon might have just got buried underneath something. You should
    definitely clean up your desktop if it has got to this state.

    Another possible theory occurs to me, but let's narrow it down a little.

    First, what Mac model and version of Mac OS X are you running?

    If you open a new Finder window, does the hard drive icon appear in the
    sidebar? (If not, go into Finder > Preferences > Sidebar and make sure
    "Hard disks" is checked. Does it appear after that?)

    If you go to "Computer", using the "Go" menu, it should open a window
    which shows all your mounted volumes. Does the hard drive appear there?

    If the hard drive doesn't appear in "Computer", my next suggestion is to
    run Disk Utility and verify the disk. If it reports any problems, you
    will need to restart from your system install DVD, get past the first
    (language selection) screen, then choose Disk Utility from the
    "Utilities" menu and use it to repair the disk.

    If none of that helps, perhaps your hard disk has somehow been made
    invisible. There is a setting for this (not easily accessible). Someone
    had a similar problem recently where their home folder had been set to
    be invisible.

    In that case I was able to supply instructions for fixing the problem
    using a command line utility (in Terminal) which is supplied as part of
    the developer tools. You can install the developer tools from your
    system install DVD/CD set.

    I'm also aware of at least one Shareware tool which can set the
    invisible bit: Xray.
     
    David Empson, Sep 19, 2007
    #7
  8.  
    manfred.kooistra, Sep 19, 2007
    #8
  9. manfred.kooistra

    David Empson Guest

    Interesting. I was going to suggest it is likely to be a bug in the
    installer for a specific application, but it sounds like it might be
    Apple's Installer which has the bug, or it could be more widespread than
    one installer application, which suggests a system bug.
    Judging from the symptoms, something in the installation process
    deliberately sets the invisible option for the hard drive, then neglects
    to undo that setting upon completion.

    Why on earth would it need to do that in the first place?
    Ah yes, that is a much easier solution. I should have thought of that.
    :)
     
    David Empson, Sep 19, 2007
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.