Investigating why computer boots in SAFE MODE

Discussion in 'Apple' started by JF Mezei, Apr 6, 2008.

  1. JF Mezei

    JF Mezei Guest

    Is there documentation somewhere which details exactly what conditions
    would trigger 10.4 (Tiger) to boot in safe mode without the user
    pressing the shift key ?

    This has been happening to me for a few days now. I have no problem
    doing sudo, even managed to loging as "root" etc.

    Yesterday, I seemed to have fixed it by going into system preferences
    and reselecting my boot drive/OS. (this is on a PPC).

    Today, that trick didn't work. However, pressing command-S during boot
    didn't get me to single user mode, it good me a clean boot not in safe
    mode :) :)

    I know that the clock battery is weak. Unplugging the machine for
    maintenance causes the clock to think it is in 1970. However, if the
    machine remains plugged it, would a weak battery still cause havock ? I
    added a "-v" to the boot-args in NVRAM, and that value stays in there
    (indicating the nvram doesn't get zapped).

    the rc file looks for an environment variable SafeBoot . Does anyone
    know where that variable is set ?
     
    JF Mezei, Apr 6, 2008
    #1
    1. Advertisements

  2. JF Mezei

    Tim McNamara Guest

    Yes. That battery isn't weak, it's basically dead. Replace it and your
    problems should be solved.
     
    Tim McNamara, Apr 6, 2008
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.