IRQ Problem due to ACPI; LPT1 Problem without ACPI; Abit ST6

Discussion in 'Abit' started by Bernd Bubis, Aug 10, 2003.

  1. Bernd Bubis

    Bernd Bubis Guest

    In brief:
    In order to solve an IRQ-Sharing issue I switched my Windows 2000
    installation type from >>Computer = ACPI-PC<< to >>Computer =
    Standard-PC<<. Basically this switch solved my problem, however now I
    am unable to get my inkjet running, which is hooked up one single
    LPT1. The HP-Tool says there is no bidirection communication possible.
    Any suggestions?

    The details:
    Motherboard: ABIT ST6 with newest BIOS-Version 9P
    CPU : Pentium III Tualatin FCPGA-2 1 GHz
    Grafics : ATI Radeon 9000
    USB2 : Adaptec AUA-2000LP (two USB 2.0 ports)
    WLAN : D-Link AirPlus DWL-520+
    Printer : HP Deskjet 1220C

    The problem started with Windows giving me the error message "Unknown
    Hard Error". This Message frequently came about, when I plugged
    USB-devices in. The device manager showed me, that all devices were
    put onto one single IRQ !!! Some Newsgroup-research showed, that this
    seems to be a common problem. However I am unsure, wether it is
    motherboard-specific or a general problem. If it was due to my
    motherboard I would happily take suggestions on alternative
    motherboards that take my Pentium Tualatin (FCPGA-2 Socket 370).

    The only way to get Windows 2000 to *not* put all devices on a single
    IRQ seems to be to reinstall Windows 2000 with "Standard-PC" instead
    of "ACPI-PC" (this configuration can be checked within the device
    manager under the entry "Computer"). So I did reinstall my system and
    were thus able to neatly configure the IRQ-setup.

    Unfortunately about came a new problem: Before (Computer = ACPI-PC) my
    HP DeskJet 1220C worked perfectly on LPT1. Now (Computer =
    Standard-PC) this printer does not work anymore. The HP-Tool says,
    there is no bidirectional communication possible. Everything seems to
    be configured well though (just exactly as before).

    Any suggestions would be appreciated beyond imagination ... :eek:)
     
    Bernd Bubis, Aug 10, 2003
    #1
    1. Advertisements

  2. Bernd Bubis

    TomG Guest

    having all of your devices on a single IRQ or sharing IRQ's among multiple
    devices is not a "problem" in most cases. Every PC I have built for the
    last several years shared IRQ's and some even had all devices on one IRQ
    such as IRQ 11. Assuming that you are using a PCI bus system, sharing IRQ's
    is quite normal. The problem comes in where you have poorly written drivers
    or poorly designed hardware, or two devices that are just plain incompatible
    for some reason. Sometimes swapping devices in their slots can help with
    that issue.

    By disabling ACPI, you loose power management features as well as the
    ability to share the IRQ's in the same fashion as with ACPI. Regarding your
    printer, have you set the LPT port correctly in the bios and then made sure
    that the correct type of port is reflected in the device manager?

    --

    Thomas Geery
    Network+ certified

    ftp://geerynet.d2g.com
    ftp://68.98.180.8 Abit Mirror <----- Cable modem IP
    This IP is dynamic so it *could* change!...
    over 115,000 FTP users served!
    ^^^^^^^
     
    TomG, Aug 10, 2003
    #2
    1. Advertisements

  3. Bernd Bubis

    Rick Guest

    <raising hand>

    1. Download the most recent driver from HP.

    2. Turn off the printer and disconnect the printer cable from the
    computer.

    3. Uninstall your existing HP driver via Add/Remove Programs.
    Do NOT reboot if prompted after the uninstall.

    4. Go into Device Manager and uninstall your existing parallel port(s).

    5. Reboot. At this point, go into your system bios and make sure
    the LPT port type is set to "ECP". Set DMA channel to 3 and ECP
    type to 1.7, not 1.9.

    6. Save your system bios changes and reboot into Win2K, which
    will rediscover and install your ECP port. Go back into Device
    Manager to verify the port is showing as properly installed and
    working.

    7. Shutdown the computer and plug the printer cable in. Turn on
    the printer and allow it to finish initializing. Turn on the computer
    and boot into Win2K. If the Add/Remove Hardware wizard
    appears, cancel it.

    8. Run the setup program for HP's driver downloaded in step 1.
    Reboot after the install.

    Rick
     
    Rick, Aug 16, 2003
    #3
  4. Bernd Bubis

    Bernd Bubis Guest

    You are a genius!
    With your help I got it going now.
    I am really happy.

    However, there was no ECP 1.7 in my BIOS. So I tried EPP1.7 (I guess,
    that might actually be, what you meant).

    Thank you very much for your help. I would have never figured that out
    by myself.

    :--)
     
    Bernd Bubis, Aug 22, 2003
    #4
  5. Bernd Bubis

    Bernd Bubis Guest

    Now, that I have installed my PC with windows 2000 in mode PC-Standard
    (instead of ACPI) and solved the LPT1 problem a new problem comes up:
    My adaptec USB2 PCI-card hangs. Or more in detail: If I hook up my
    external sound-device Creative Soundblaster Extigy to one of those
    USB2 ports the sound is interrupted and very soon my computer will
    restart (even without a blue screen).

    Any ideas?
     
    Bernd Bubis, Sep 11, 2003
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.