ite raid controller extremely slow in 7n400 pro2 rev2

Discussion in 'Gigabyte' started by Ale, Jul 1, 2004.

  1. Ale

    Ale Guest

    Excuse for my poor english...
    I have noticed that when i try to read from my two maxtor 60 gb in raid 0
    the value sounded normal (70-80 mb/s) but when i'm trying to write in that
    discs the value il really really poor...like an ata 33 hd...does anyone know
    about this problem??
    I'm using win xp pro with the latest raid drivers....but if this is normal
    for this motherboard i will sold it almost now!!
    It's impossible to use the raid in this way....
    CAn someone help me??
    Thanks!!
     
    Ale, Jul 1, 2004
    #1
    1. Advertisements

  2. Ale

    jpsga Guest

    Ali,

    What are Maxtor the model numbers for the drives?
    What is your test software.
    Are you on the GigaRAID (PATA) ports or the SATA ports?
    I use the Rev 1 board and both he serial and the Parallel RAID ports read
    very fast ( in the 90 mb/s range). I do not check the write speeds as I
    don't have a tester that I trust that will do it
    Testing these arrays can be a problem.

    Jim

    PS-If you think your English is bad you should see my Italian
     
    jpsga, Jul 1, 2004
    #2
    1. Advertisements

  3. Ale

    Ale Guest

    :)
    I'm using 2 maxtor diamondmax plus9 60 gb..i use hd tach and hd speed..the
    values in reading are good but when i'm copying something in these discs the
    speed is very very slow if we look at a single hd (6 minutes against 30
    minutes of the raid discs !!!!!!!!! a horrible result)...
    the sata raid is better because it's a highpoint controller....this ite is
    really out of any imagination!!
    But i've read this :

    PATA RAID powered by ITE GigaRAID Controller
    Found on: K8NNXP, K8N Pro, 7NNXP, 7N400 Pro and 7N400 Pro2 NOT AVAILABLE on
    K8N, 7N400L and 7N400L1
    General
    There have been many complaints about the lackluster, if not completely
    awful performance from the ITE RAID controller. To date, there IS NO FIX. It
    appears to be a hardware design flaw.
    Errata
    Besides the hardware design flaw in the implementation of the ITE GigaRAID
    controller, there is also another flaw which affects professional level
    sound cards.
    -= PR3ACH3R =- wrote:
    When Used With Any Pro Audio Card ,For recording ,
    The ITE CHIP will send Horrible Repeating Clicks every second or so while
    WRITING TO THE DRIVE ..

    The clicks are sent to ALL THE DEVICES ON THE PCI BUS,
    & Repeat every second or so WHILE THE DRIVE IS WRITING.

    The Clicks DO NOT APPEAR when used with the
    STANDARD IDE Channels of the Nforce2 .


    For more information on the ITE bug, check out pr3ach3r's website

    ( http://pr3ach3r.overkillsystems.net/ )

    ............so i'm not the only one that has this problem :-(
    Suggestions???
     
    Ale, Jul 1, 2004
    #3
  4. Ale

    Tim Guest

    Check for driver updates at the ITE web site.
    They have produced some new drivers a while back that are reported to
    "solve" the performance problems. I don't use mine so can't confirm.
    Check that you do not have discs pugged into Master and Slave on the same
    cable - this will kill performance (read and write) so doesn't sound like
    the cause.

    - Tim
     
    Tim, Jul 2, 2004
    #4
  5. Ale

    Ale Guest

    The discs are plugged in two different cables as masters...
    the official page is this:
    http://www.ite.com.tw/productInfo/Download.html#Software Support

    Can i change the bios of the controller if it is inside the mainboard??
     
    Ale, Jul 2, 2004
    #5
  6. Ale

    Ale Guest

    I've tried the latest v1.7.1.9 drivers but the situation is the same...and
    the flash utility don't recognize the controller as IT8212....i think
    because it is the it8212F implemented in the mb...
    Suggestions??
     
    Ale, Jul 2, 2004
    #6
  7. Ale

    Tim Guest

    The ITE firmware will be part of the motherboard bios, so check your bios
    version.

    The ITE Drivers are separate and on the web site you referred to somewhere.

    You may only see the performance boost when a matched bios / firmware /
    driver is installed.

    - Tim
     
    Tim, Jul 2, 2004
    #7
  8. Ale

    Ale Guest

    Thanks, i have already the latest bios for my mb...
    Now i'm thinking to delete my raid and use the normal ata controller....
    :-(
    This is something very annoing for me, a bad point for gigabyte...
     
    Ale, Jul 2, 2004
    #8
  9. Ale

    jpsga Guest

    Well, it turns out that this is not a RAID problem but a file copy problem.
    When copy /paste is used, both read and write buffering come into play and
    things slow down.

    The 'move' command is faster.

    JPS
     
    jpsga, Jul 4, 2004
    #9
  10. Ale

    Ale Guest

    But when i'm for example decompressing a file .rar of 50 megab.of mp3s the
    all operation takes about 1 minute...when i used the raid with my old 7vaxp
    ultra with the promise controller the operation takes 15 seconds with my
    discs..the file is so stupid to decompress..so it's a controller
    problem..and in italy i've found a lot of people with this problem..no one
    has a solution..
    Now i have found an external raid card with the ITE 8212F chip...i wanna see
    if with an external card the situation is the same or not..
    Stay tuned next week..
    Bye
     
    Ale, Jul 4, 2004
    #10
  11. Ale

    Tim Guest

    Some decompression programs (EG winzip) use a not very intelligent method of
    decompression:

    They decompress to Temp directory then *copy* to the directory you indicate
    so you have 3 times the amount of disc IO's needed to do the operation.
    (Winzip does this and its a royal pain with multi GB files - in fact I had
    to ditch it cos it could not produce zips > 2Gb, version 9 addressed this
    problem too late).

    - Tim
     
    Tim, Jul 5, 2004
    #11
  12. Ale

    Ale Guest

    This is exactly what makes winrar...but the question is : why the promise
    use 15 seconds and ite 1 minute??there is something that i can't
    understand...
    Does anyone knows this page??
    http://underclock.rocks.it/
     
    Ale, Jul 5, 2004
    #12
  13. Ale

    Ale Guest

    even flashing the bios of the ite controller the situation is the
    same..there is no solution..i've tried everything ...even modifing the bios
    of the mb...
    bye bye ite raid ....bllleeeaaahhhh!!!
     
    Ale, Jul 8, 2004
    #13
  14. How do you flash the ITE controller BIOS?
     
    Richard Dower, Jul 8, 2004
    #14
  15. Ale

    Ale Guest

    :) Inside the mb bios there's the old ite bios (45k)...i've replaced that
    bios with the newer one that i've found on the ite home page...for raid the
    1.7.1.92 bios exactly...
    Wanna try??
     
    Ale, Jul 8, 2004
    #15
  16. I've downloaded the latest BIOs from the website, but how do you actually
    flash the ITE BIOS?

    I also have the ITE controller disabled, it dosen't appear during POST. So
    would i have to enable it first to flash it?
     
    Richard Dower, Jul 8, 2004
    #16
  17. Ale

    Ale Guest

    Yes ..first enable the controller....then try with a boot diskette with the
    iteflash utility inside...but in this way i can't flash the ite bios
    already..for me the only way was the modification of the gigabyte official
    bios...an easy operation.. :)
     
    Ale, Jul 8, 2004
    #17
  18. Ale

    Tim Guest

    Hi,

    I doubt your method would work. You would need to take the mobo bios, rip
    out the existing ite component and replace it. The bios update program for
    8KNXP seems to incorporate the bios editing functions - this is risky - you
    need to know what you are doing and be able to recover the bios if you stuff
    it. EG you will need a bios recovery method of some sort.

    Of course, I could be wrong about this - seeing as I have never done it.
    Perhaps go to one of the Uber Bios sites and research there.

    - Tim
     
    Tim, Jul 8, 2004
    #18
  19. Ale

    Ale Guest

    My bios mod works perfectly...but the operation is useless..the controller
    is awful..
    For programming the bios i use a program (awdedit if i remember correctly)
    that replaces the parts automatically..
    And about the risks..we have 2 bios installed in the mb...if one don't
    works..the other is available...now i use the official bios ff not
    modified..because my mod was useless :-(
     
    Ale, Jul 9, 2004
    #19
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.