Just added RAM to my Dell E510

Discussion in 'Dell' started by History Fan, Jan 31, 2007.

  1. History Fan

    History Fan Guest

    I have a Dell E510 that came preinstalled with 1GB of RAM. I just added
    two Kingston 512MB RAM chips, boosting the system total to 2GB. Everything
    seems fine. No error messages or glitches....yet. A quick question,
    though. When I go into the System Setup, scroll down to Memory
    Configuration, it says that the original two RAM chips are rank 1, and the
    two new ones I just added are rank 2. What is that all about?
     
    History Fan, Jan 31, 2007
    #1
    1. Advertisements

  2. History Fan

    History Fan Guest


    According to a website I just visited, RANK-1 is single sided RAM,
    RANK-2 is double sided RAM. I just chatted with a Dell tech and he said
    this shouldn't be a problem. As long as the other specifics are the same,
    which they are: 533Mhz, non-ECC, DDR2 SDRAM.
     
    History Fan, Jan 31, 2007
    #2
    1. Advertisements

  3. Are you sure it's "rank" and not "bank"?

    If the system supports dual channel memory (it probably does), then
    there are normally two memory banks of two sockets each.
     
    Barry Watzman, Jan 31, 2007
    #3
  4. History Fan

    History Fan Guest


    No, it says rank.

    The E510 system has 4 memory banks, and RAM chips must be installed
    in pairs.
     
    History Fan, Jan 31, 2007
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.