K8v sata boot with IDE and SATA in place (solution)

Discussion in 'Asus' started by Harry Putnam, Oct 25, 2004.

  1. Harry Putnam

    Harry Putnam Guest

    [NOTE: This message started out as a request for help but as I worked
    thru what I wanted to say I actually solved my problem so decided to post
    this in case anyone else has similar trouble installing both sata and
    IDE hard drives]

    Setup:
    MOBO K8V SE deluxe (Athlon 3400+)

    I've caused myself some kind of thorny problem by installing two IDE
    drives on a system that previously only had sata drives in place.

    Original system was 2 indential sata drives hooked up to the sata1 and
    sata2 connectors nearest the ATX power supply plug on Mobo. They are
    noted simply as sata1 and sata2 in the Asus motherboard manual layout
    view. They are just inboard from floppy plugin.

    I'm not sure how they were configured since this setup was built for
    me by a shop no longer in business. But viewed from windows explorer
    they showed up as two separate drives.

    Cdrom/dvd was installed on SEC_IDE plug as master.

    Win xp pro (no sp2) was installed on sata1 and that is where it booted
    from.

    I took the machine down and installed two IDE drives (wd 250 gb).

    I didn't really notice that the cdrom already occupied SEC_IDE mobo
    plug so mistook the PRI_RAID plug for an IDE plug. So at first I had
    one IDE drive plugged into PRI_RAID and one into PRI_IDE. Not sure
    what that might have caused to happen, but when I tried to boot. The
    machine found no media to boot from.

    I noticed my error then and unplugged the cdrom altogether and moved
    the misplaced IDE to SEC_IDE. So that the new IDE HDD were on
    PRI_IDE and SEC_IDE. I left both jumpers on `cable select'.

    Now when I boot I get first the bios identification screen then a
    screen showing the sata drives. Where one can press <TAB> to enter the
    raid utility. Finally a message saying
    `Reboot and select proper boot device....'

    On the first screen is shown the auto detection of PRI master and
    Secondary master (The two new IDE drives)

    On the second screen (where one can press <tab> to config raid)
    is shown the two sata drives on
    Serial_ch0 master WDC [...]
    Serial_ch1 master WDC [...]

    I think I probably need to do something here but don't know what.
    I don't want to loose the xp pro setup on sata1 since it has lots of
    video editing work on it. Any kind of raid setup appears to involve
    reformating disks. And I don't really think it was a raid setup
    anyway.

    Entering the Bios config screen I see the new drives were detected as
    PRI master and Sec master.

    Moving to `Advanced/On Board Devices' I see `promise controller' is
    disabled as before. The only thing I see that might be related to
    sata drives is that there are addresses shown for serial ports
    1 and 2.

    Moving to the `boot screen' Under Hard Disk drives:

    I see a list like:

    Drive 1 [One of the new IDE HDD]
    Drive 2 [The other new IDE HDD]
    Drive 3 [VIA VT6420 1st hdd]
    Drive 4 [VIA VT6420 2nd hdd]

    Which is I guess how the bios sees the sata drives.

    (Maybe all I have to do is put Drive 3 in Drive 1 position)

    bingo ... that is what is needed so to summarize:

    1)
    Make sure new IDE HDD are on the correct Mobo plugs (PRI_IDE
    SEC_IDE)
    2) boot into bios and make sure drives are being seen, then
    move to `boot' screen and under 'hard disk selection'
    set what ever sata drive contains your OS to number 1 position.

    (They should be listed like VIA VT6420 1st hdd etc)

    I also moved the other sata drive into second position but that may
    not be necessary.
     
    Harry Putnam, Oct 25, 2004
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.