K9N SLI Platinum Realtek HD audio drivers don't load

Discussion in 'MSI' started by Marc, Nov 12, 2007.

  1. Marc

    Marc Guest

    I just reinstalled XP Pro SP2 and the audio drivers won't/don/t load.. They
    are in "Add or Remove Software", the install disk doesn't have them high
    lighted in white but there is no sound and when I go to "Sound and Audio
    Devices" it shows no audio device. I have tried removing and reinstalling
    the drivers in "Add or Remove Software" I've reinstalled Windows several
    times think this would help but it didn't.

    Any suggestions?

    Thanks

    Marc
     
    Marc, Nov 12, 2007
    #1
    1. Advertisements

  2. Marc

    Paul Guest

    HDaudio needs UAA loaded first.

    http://global.msi.com.tw/index.php?func=downloaddetail&type=driver&maincat_no=1&prod_no=251

    In the "Realtek High Definition Audio Driver" download (39407KB), there is a
    MSHDQFE folder, with a copy of 888111 patch, which is UAA. Normally, such a
    patch would support 24 languages, but I suspect the small size of this folder
    means it only supports English. If you need a more complete UAA, from KB888111
    or later, you can get that from Microsoft. 888111 was the first release.

    Paul
     
    Paul, Nov 12, 2007
    #2
    1. Advertisements

  3. Marc

    Marc Guest

    Paul where did you find that info I looked at the MSI site and searched
    online and couldn't find anything.

    Thanks!!!

    Marc
     
    Marc, Nov 12, 2007
    #3
  4. Marc

    Marc Guest

    I used the live update so I never say this.

    Marc

    Thanks again!!!!
     
    Marc, Nov 12, 2007
    #4
  5. Marc

    Marc Guest

    Paul I tried the update it didn't take becasue the Microsoft update wasn't
    done I installed KB88811 manual it shows up in the "Add and Remove Software"
    than removed the RealTek drivers and re-booted reinstalled the RealTek and
    rebooted and still no sound.

    Marc
     
    Marc, Nov 12, 2007
    #5
  6. Marc

    Paul Guest

    OK, first off, does it "look" like it has sound ? In other words,
    do you have entries where they should be ? Or is audio still
    "missing in action" as far as Device Manager and the rest are
    concerned.

    Is there an "Azalia" or "HDaudio" icon in Control Panels, so
    you can set up the Realtek stuff ? There is at least one
    control there that has a mute function, so carefully check over
    the configuration. If you cannot get it to work in 2 channel
    mode, try 4, 6, or 8 channels, and test all the channels
    in each case. I've run into the odd problem, where the
    speakers that respond, aren't the ones you expect. So if
    you're not making any progress, try changing the number of
    channels and then test again.

    If you did Start:Run and typed "dxdiag" in the box, to run dxdiag
    from the Microsoft DirectX, and then tried the sound test in dxdiag,
    does dxdiag think the test is running ? The purpose of that, even
    if there isn't physically any sound, is to prove the software
    stack seems to be present and working.

    Normally, I'd suspect the problem was with the audio header. With
    AC97, it is possible to bugger up the sound when wiring the front
    audio header. But HDaudio is different, and shouldn't have that
    issue. HDaudio doesn't need the two jumpers on the audio header,
    that AC97 uses when the header is not being used. So that probably
    isn't the problem.

    Other than that, I suppose it could be a software interaction of
    some sort. I checked the Newegg reviews for your board, and
    none of them seem to mention a problem, which is a good sign.
    That improves the odds it is going to work :)

    Paul
     
    Paul, Nov 12, 2007
    #6
  7. Marc

    Marc Guest

    They are still missing in action but both the KB888111 and the RealTek
    drivers are listed in "Add and Remove Programs". I ran the "dxdiag" test
    with the same results "No Audio Devices". I didn't look at the headers
    this seems to be a motherboard issue.

    This is a reinstall so and everything was working fine until I started the
    install. I added a bigger hard drive and was going to clone everything to
    the new one except the OS partition didn't clone so after several attempts I
    decided to start from scratch. I had
    "Programs Files" on "E" but now they are on "D" but they installed on the
    "old machine" without a problem on "E". So I don't see changing teh drive
    as teh problem.

    I tried to manually add the drivers but that crashed the computer. Also to
    make this more bizzare I don't remember the Microsoft update list in "Add
    and Remove Programs" on the old machine.

    Paul if you lived in Atlanta I'd buy you a beer now all I can say is thanks
    for your help.

    Marc
     
    Marc, Nov 13, 2007
    #7
  8. Marc

    Paul Guest

    Now, in installing this stuff, I'd want: latest service pack for WinXP (SP2),
    latest DirectX (9c or whatever the latest is), then install HDA (888111 or
    835221 is a later one). The reason I say that, is it is possible that
    the UAA install, has some minimum system requirement, such as one of
    the WinXP service packs.

    http://support.microsoft.com/kb/835221/en-us

    One problem I have with HDaudio, is dumping information on it. For example,
    I've never seen a convenient tool to just dump the registers in a human
    readable way. There are a couple tools with raw dumps, but then you
    never know what you're looking at.

    DXDIAG has an option, to save all info into a file. I don't have HDaudio
    on any motherboard here (mine have AC'97), so I cannot compare directly.
    And DXDIAG is only going to dump "successfully" installed devices, not
    like Everest would.

    This is what someone else's DXDIAG output showed. I think this is for
    a RealTek ALC888, but under Vista. The driver name won't be the same
    one, as is used in WinXP. The hardware ID HDAUDIO\FUNC_01&VEN_10EC&DEV_0888
    is the device part, and should match yours. The SUBSYS is related to the
    motherboard. It consists of two parts - the manufacturer ID (103C) and the
    motherboard part (2A61). The manufacturer ID, you can sometimes figure out,
    but the motherboard (or instance) part of it is probably only known to
    the driver writer and the developers. The INF file, in the installer,
    contains lines which match that Hardware ID. If the INF doesn't
    specify the SUBSYS and REV, then the INF "wildcard matches" all
    motherboards using the same chip. You don't really want that, in cases
    where the jack configurations are customized a bit. But in this case,
    I would expect a lot of the ALC888 designs, would all have complete
    jack stacks on the back of the motherboard (pretty silly to throw
    outputs away, but it happens sometimes). So the info in this
    example, won't exactly match your board, but shows what DXDIAG
    dump would contain if the thing had installed and loaded on reboot.

    -------------
    Sound Devices
    -------------
    Description: Speakers (Realtek High Definition Audio)
    Default Sound Playback: Yes
    Default Voice Playback: Yes
    Hardware ID: HDAUDIO\FUNC_01&VEN_10EC&DEV_0888&SUBSYS_103C2A61&REV_1001
    Manufacturer ID: 1
    Product ID: 100
    Type: WDM
    Driver Name: RTKVHDA.sys
    Driver Version: 6.00.0001.5377 (English)
    Driver Attributes: Final Retail
    WHQL Logo'd: Yes
    Date and Size: 3/1/2007 09:21:10, 1744928 bytes
    Other Files:
    Driver Provider: Realtek Semiconductor Corp.
    HW Accel Level: Basic
    Cap Flags: 0xF1F
    Min/Max Sample Rate: 100, 200000
    Static/Strm HW Mix Bufs: 1, 0
    Static/Strm HW 3D Bufs: 0, 0
    HW Memory: 0
    Voice Management: No
    EAX(tm) 2.0 Listen/Src: No, No
    I3DL2(tm) Listen/Src: No, No
    Sensaura(tm) ZoomFX(tm): No

    The question is, is there an "unknown" device in Device Manager, that has
    a VEN and DEV like that, that lacks a driver ?

    HDaudio has to be enabled in the BIOS. And if it is, and the chip is actually
    working, then you should be able to "see" it.

    Programs like Everest can list hardware that can be seen. So Everest is
    another tool you can look, to see if VEN_10EC&DEV_0888 is there. It must exist,
    because you say this is just a reinstall, and the sound was working before
    you started the reinstall. So the hardware really should show up.

    Everest free version - for the latest commercial version , see lavalys.com
    http://www.majorgeeks.com/download4181.html

    ( Commercial version here: http://www.lavalys.com/news.php?article=49&selcat=PN&lang=en )

    I'm also surprised that the Realtek installer didn't complain, if it didn't find
    matching hardware.

    Paul
     
    Paul, Nov 13, 2007
    #8
  9. Marc

    Marc Guest

    I contacted MSI tech support with the problem This is what I sent them:

    I have tried to install the RealTek HD Audio drivers. It shows up in "Add
    and Remove Software" but when you go to "Sound and Audio Devices" there a
    "No Devices Found message. This is a reinstall. The only difference is that
    I replace a smaller drive with a larger drive and change the order of some
    of the partitions "Program Files" was on "E" now it's "D" but it installed
    on "E" without a problem so I don't see that being the problem. I have
    removed and installed Windows and the same with the drivers and still no
    sound. I was on "alt.comp.periphs.mainboard.msi-microstar" newsgroup and
    said the new drivers included a Microsoft update KB888111. I installed the
    new drivers and the problem still existed. The person that told about the
    new drivers said that the Microsoft update should be listed along with the
    RealTek up in "Add and Remove Software" the RealTek was but not the
    Microsoft so I manually installed that and now they are both listed but
    still no sound. So I uninstalled the RealTek and installed them again and
    still nothing. I don't know what to try next. Thanks, Marc

    This is what they sent back:

    The Microsoft HD UAA device drivers interfere with the Realtek drivers and
    prevent them from loading. The cure is to 1) Open the control panel and
    launch System 2) Click on the Hardware tab and then launch the Device
    manager. 3) Go to the bottom and click on System Devices 4) Look for
    Microsoft UAA HD Audio driver. 5) Right mouse click on it and first disable
    the driver, and then unload it. 6) Reboot the machine. 7) There should be no
    problem now with loading the HD audio drivers. Please check and be sure the
    bios setup has the on board audio setting been set to enable or Auto. Please
    have all on board audio header removed from any case front audio or other
    adapter connections and only connect the speaker/headset to the rear audio
    output port (green) and retest with the updated audio driver v1.81 been
    applied:
    http://www.realtek.com.tw/downloads...=3&GetDown=false#High Definition Audio Codecs
    ** Please test out the mb and components outside the case with mb box to
    support the board. This can prevent any short or grounding problem to the mb
    which can cause audio to stop working as well. If all steps have been tried
    and problem still persists then please kindly refer to our website for
    manufacturer warranty RMA info/request:
    http://www.msicomputer.com/support/CustomerS.asp

    I tried to do the process but the Microsoft drivers weren't listed - going
    backwards already both again were listed is "Add and Remove Programs". So I
    removed both and re-booted and added just the RealTek. I happen to be
    watching the Install at the right moment and guess what got installed - the
    UAA HD drivers that weren't suppose to be there. I didn't do any of the
    rest - doesn't make sense for everything to be working OK for almost 2
    months and than start acting up. It looks like replacing the MB is the only
    option since tech support seems to be clueless.

    Marc
     
    Marc, Nov 14, 2007
    #9
  10. Marc

    Paul Guest

    The WDM folder contains the Realtek specific part of the install. But there
    really isn't anything convenient inside that folder, to use for installing.

    You could open one of the INF files, or use that to upgrade a driver for
    a hardware device that had no driver. I think if you upgraded, based on
    working with the WDM folder, that would avoid UAA being installed.
    I'm not sure how much use that will be to you, though.

    It is possible, what the MSI tech support were trying to achieve, was
    to use their copy of UAA as provided in the installer.

    If you disable the HDaudio, in the BIOS, and then use the installer
    from Realtek, does it complain there isn't any hardware ?

    If I suspected the hardware didn't work, I might try booting my
    Knoppix or Ubuntu Linux LiveCD, just to see if they could see an
    audio device or not.

    Did you have any luck with Everest ? Can it see a device with those
    enumeration numbers (HDAUDIO\FUNC_01&VEN_10EC&DEV_0888) ?

    And finally, before I'd buy another motherboard, I'd find a cheap
    PCI sound card and use that. I use a crappy CMI8738 based card
    in my current computer, and that is good enough. I stopped using
    the built-in SoundMax AC'97 codec.

    http://castle.pricewatch.com/s/search.asp?s=cmi8738

    Paul
     
    Paul, Nov 14, 2007
    #10
  11. Marc

    Marc Guest

    PauL I was driving home from an appoiintment today when it dawned on me to
    try an reset the CMOS. Did that and I have sound!!!

    Thanks for your help!

    Marc
     
    Marc, Nov 16, 2007
    #11
  12. Marc

    Paul Guest

    Excellent.

    Do you remember doing anything, or having something funny happen,
    that would account for the corruption ? Like a funny power
    off event ? Pretty weird for a bit to flip out of the blue,
    and since some portions of the CMOS are checksum protected,
    it is a wonder the checksum didn't catch it.

    Paul
     
    Paul, Nov 16, 2007
    #12
  13. Marc

    Marc Guest

    Even funnier - ironic - is tha tI've been in comsumer electromnis for over
    20 years and the standard answer to some one that is having a funny/bizzare
    problem is unplug it for 20 minutes miminum plug it back in and see what
    happens. I've got the computer on a UPS and surge protector and I don't
    remember any surges that shut down the computer. Than I started to freak no
    I had no USB devices - I didn't realize that resetting the CMOS would
    disable them turned tham back on and good to go!

    Paul thanks for your help - owe you a beer:)

    Marc
     
    Marc, Nov 17, 2007
    #13
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.