1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Knights of the old republic was originally designed on Xbox hardware which has an equivalent Geforce

Discussion in 'ATI' started by Atiupgrade, Jan 10, 2004.

  1. Atiupgrade

    Atiupgrade Guest

    Knights of the old republic was originally designed on Xbox hardware
    which has an equivalent Geforce3 TI card I'm told? So since it's
    optimized for Nvidia hardware I'm guessing that's my problem?

    I have a Celeron 900Mhz, 384mb, Win98SE, Direct X9b and a Radeon 9100
    64mb 128bit/Geforce2 GTS 32mb

    I was playing fine at 10-15fps on Knights of the old republic when I had
    my Geforece2 GTS 32mb (Detonator 30.82 drivers ) card in my system (I
    know min req are 1ghz but search google and you'll see others with lower
    specs than mine playing with Geforce2/3/4 cards at playable rates) ) but
    then I switched up to my Radeon 9100 64mb 128bit card (Cat 3.6 drivers
    have tried 3.10 but slower) and I was running at like 2-5fps
    everywhere!....Is this game just horribly optimized for ATI
    hardware?????

    KOTOR is the only game I'm seeing that's suffering from the upgrade
    rather than benefiting from it. Battlefield 1942, Halo, LOTR Return of
    the king, MOrrowind, Jedi Academy, Counter-strike are ALL running MUCH
    faster with the 9100...

    Knights of the old republic.....WHAD UP?
     
    Atiupgrade, Jan 10, 2004
    #1
    1. Advertisements

  2. Atiupgrade

    Atiupgrade Guest

    In Kotor everything is set to the lowest settings. I even went into the
    ATI Control panel and cranked down both D3D and OpeNGL to lowest
    settings (wasn't sure which kotor used but figured I’d try both on
    lowest) NO DIFFERENCE!!!!

    On my Geforce2 GTS 32mb I never went into the NVIDIA Control Panel to
    crank down OpenGL or D3D settings just stuck with lowering all KOTOR in
    game settings and still 10-15fps (Maybe 8 fps in city scenes but
    everywhere else was fine on the Geforec2 GTS).

    I think it's definitely an optimizing issue with ATI cards because like
    I said my other games are running MUCH faster with the 9100 it's only
    KOTOR having issues. Battlefield 1942 I'm able to play at 800x600-32bit
    colour with 80% texture settings and high detail for special fx and it's
    running VERY smooth. On the Geforce2 GTS I could only run the game at
    800x600-32 bit colour 60% Texture settings and medium detail for special
    fx and the game was still relatively slow in many areas...Likewise for
    Morrowind...the game runs faster and looks much nicer with pixel shaders
    and I'm able to play at higher settings with the 9100 than I was with my
    older card.
     
    Atiupgrade, Jan 10, 2004
    #2
    1. Advertisements

  3. Atiupgrade

    trooper Guest

    My god man, what resolution are you using? I had to scroll and rearrange my
    tabs just to read your silly subject!
     
    trooper, Jan 11, 2004
    #3
  4. Atiupgrade

    Buck Guest

    Using Xnews newsreader instead of OE:
     
    Buck, Jan 11, 2004
    #4
  5. Atiupgrade

    Matt Guest

    I'm running it at full settings with a 9500 Pro without any major problems,
    though my system is a bit faster than yours: AMD 1.4 T-Bird, Win98SE, 784
    megs ram, DirectX9b. It will occasionally crash (maybe once every 15 hours)
    but I assumed this was because my system is a bit older...
     
    Matt, Jan 12, 2004
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.